89 mustang won't rev past 4000 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-06-2014, 09:45 PM   #1
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
89 mustang won't rev past 4000

Fox won't rev past 4000 sounds like it's hitting a limiter
No cats straight pipe to flowmasters(had these since my dad got it in '97)
Thnx in advance


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-06-2014, 11:38 PM   #2
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Bump


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-07-2014, 07:26 AM   #3
Registered User
Newbie
 
Infantry09's Avatar
 
Join Date: Aug 2011
Region: Missouri
Posts: 15
Rev limiter on the ignition


Sent from my iPhone using Mustang Evolution
Infantry09 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-07-2014, 08:49 AM   #4
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Have you run your codes?


What's your timing at?


What's your fp at?


Great place to start.


And posting at night and bumping 2 hours later is an exercise in futility.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-07-2014, 10:09 AM   #5
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Bump


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-07-2014, 10:11 AM   #6
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Quote:
Originally Posted by Infantry09 View Post
Rev limiter on the ignition


Sent from my iPhone using Mustang Evolution

Have msd set to 6000


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-07-2014, 10:16 AM   #7
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
89 mustang won't rev past 4000

Quote:
Originally Posted by smurf stang View Post
Have you run your codes?


What's your timing at?


What's your fp at?


Great place to start.


And posting at night and bumping 2 hours later is an exercise in futility.

No I haven't
Timing is advanced to *14
FP is at 32
My phone posted it randomly


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-07-2014, 02:37 PM   #8
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Pull your codes................BUMP and report back.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-19-2014, 02:52 PM   #9
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Just pulled the codes today
21, 33, 88, 94


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-19-2014, 04:27 PM   #10
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Quote:
Originally Posted by smurf stang View Post
Pull your codes................BUMP and report back.

Just pulled the codes today
21, 33, 88, 94


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-19-2014, 06:36 PM   #11
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Bump


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-20-2014, 08:36 AM   #12
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
21- ECT Sensor Out Of Self Test Range


33 - EGR Valve Opening Not Detected


88 - Loss Of Dual Plug Input Control


94 - Secondary Air Injection Inoperative. bank two, driver side


Did this just happen out of nowhere or has this been getting worse?


Do you still have your EGR or is it deleted?


ECT sensor is probably bad.


What happens when you hit 4k. Does it hit you like a rev limited like you said?


The FP, when you pulled the vacuum line did the pressure go up to 38 or 40? Also try different rpm ranges when you have the gauge set up. The pressure should stay about the same. If it drops then there is a problem.


When was the last time she had a tune up? New wires, plugs, cap, rotor, fuel filter?


Start with the simple like a fresh tune up. Start and check for vacuum leaks. Check the condition of the balancer to make sure it hasn't spun. Now it might be that your coil is on it's way out as it happened to me once with a bad MSD coil. Also it could be that your fuel pump might be on it's way out also.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-20-2014, 10:54 AM   #13
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Quote:
Originally Posted by smurf stang View Post
21- ECT Sensor Out Of Self Test Range


33 - EGR Valve Opening Not Detected


88 - Loss Of Dual Plug Input Control


94 - Secondary Air Injection Inoperative. bank two, driver side


Did this just happen out of nowhere or has this been getting worse?


Do you still have your EGR or is it deleted?


ECT sensor is probably bad.


What happens when you hit 4k. Does it hit you like a rev limited like you said?


The FP, when you pulled the vacuum line did the pressure go up to 38 or 40? Also try different rpm ranges when you have the gauge set up. The pressure should stay about the same. If it drops then there is a problem.


When was the last time she had a tune up? New wires, plugs, cap, rotor, fuel filter?


Start with the simple like a fresh tune up. Start and check for vacuum leaks. Check the condition of the balancer to make sure it hasn't spun. Now it might be that your coil is on it's way out as it happened to me once with a bad MSD coil. Also it could be that your fuel pump might be on it's way out also.

We'll I thought that it would just go up to 3500-4k but my friend has a mustang also and he said easily the car can go to 5-5800k that's when I first noticed the problem..

EGR is still on the car..

I read the codes when the car was cold that could've been why it thru out the code right.?

This is what happens when it hits 4k
http://youtu.be/oITDoL-ZxVw

What vacuum line do I pull to check the FP.?

I'm going to do a tune up on the car this weekend 'cause I don't know how long it's been since my dad gave it to me

How do u check the balancer.?

Just dropped in a new fuel pump 190lph and a fuel filter this past weekend




Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-20-2014, 12:37 PM   #14
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Yes the car must be at operating temp.


The vacuum line you pull is on the fp regulator.


Physically and visually check the balancer to see if there is rubber sticking out or if it has spun on the hub.


If the EGR is bad it could be stuck open or closed. That would be a vacuum leak there also.


Give her a good once over and lets see what happens after that.


Also make sure you have the proper firing order for the plug wires.


good luck.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-28-2014, 02:15 PM   #15
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Did a complete tune up wires,cap and rotor, spark plugs checked all the wires see if they r firing right..
Same problem


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-28-2014, 07:52 PM   #16
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Does it still have catalyc converter on exhaust?could be stopped up


Sent from my iPhone using Mustang Evolution
Liebert91stang is offline   Reply With Quote
Old 08-28-2014, 08:48 PM   #17
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Just noticed it has no cats.does the Msd have the rev limiter on it?


Sent from my iPhone using Mustang Evolution
Liebert91stang is offline   Reply With Quote
Old 08-29-2014, 08:10 AM   #18
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Quote:
Originally Posted by Liebert91stang View Post
Just noticed it has no cats.does the Msd have the rev limiter on it?


Sent from my iPhone using Mustang Evolution

Yes it does 6k


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Old 08-29-2014, 08:48 AM   #19
Registered Member
Regular
 
Liebert91stang's Avatar
 
Join Date: Jun 2013
Location: New Albany
Region: Indiana
Posts: 375
Quote:
Originally Posted by Vazqueza90 View Post
Yes it does 6k


Sent from my iPhone using Mustang Evolution

I would say that is your problem.thats where I would be looking to solve the issue.cant think of anything else that would keep it under a certain rmp that doesn't have some kind of a governor on it


Sent from my iPhone using Mustang Evolution
Liebert91stang is offline   Reply With Quote
Old 08-29-2014, 01:45 PM   #20
Registered Member
Regular
 
Vazqueza90's Avatar
 
Join Date: Dec 2012
Location: Bell,Los Angeles
Region: California
Posts: 199
Quote:
Originally Posted by Liebert91stang View Post
I would say that is your problem.thats where I would be looking to solve the issue.cant think of anything else that would keep it under a certain rmp that doesn't have some kind of a governor on it


Sent from my iPhone using Mustang Evolution

I'm going to disconnect it see if that's the problem


Sent from my iPhone using Mustang Evolution
Vazqueza90 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lookin at 90 mustang gt rust free $4000 l Sambrostang 1979-1995 Mustang GT 5 03-01-2012 09:55 AM
For Sale: 1998 gt $4000 obo Nate98stang Mustangs for Sale and Wanted 2 07-30-2011 03:12 PM
Trying to unhook the rpm mine is peging at 4000 like to have more? pierre 1996-2004 Mustang GT 1 08-19-2009 12:28 AM
1996 V6 in Boston, $4000 OBO mexor Mustang Parts for Sale and Wanted 0 05-31-2004 06:22 PM

» Like Us On Facebook



10:10 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.