Heat - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-12-2014, 10:14 PM   #1
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Exclamation Heat

Hey everyone. 1988 mustang gt 5.0. I bought this car last week with a few little issues that I'm knocking out as I go along but the one big issue that I need to take care of is that I have no heat. A little background is that the guy said the A/C condensir doesn't work and needs to be replaced and that the heat is "intermintant". I've had the car since Wednesday and I haven't gotten the "intermintant" heat to work lol. I set the temperature to the hottest and adjust the knob to the defroster selection or even the vent selection but when I do nothing happens, even if I cycle through the low-high settings. I feel no heat, nothing comes out of the vents and I feel nothing kick on. Is this the blower motor that's bad? Need heat because this is my daily driver until I can get a cheap pos daily driver. Thanks guys
antnvlz1294 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-14-2014, 02:15 AM   #2
Registered Member
Regular
 
Chris01's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 135
When u cycle thru the blower setting does the blower come on? If it does that good but then it means u need a new heater core which is under the dash
Chris01 is offline   Reply With Quote
Old 10-14-2014, 06:11 AM   #3
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Quote:
Originally Posted by Chris01 View Post
When u cycle thru the blower setting does the blower come on? If it does that good but then it means u need a new heater core which is under the dash
When I cycle through the blower settings nothing comes on at all. I already know not to put it to a/c because the condensir is bad but still no heat.
antnvlz1294 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-14-2014, 11:59 AM   #4
Registered Member
Regular
 
Chris01's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 135
Did you check your fuses? If so it could be the switch or the blower


Sent from my iPhone using Mustang Evolution
Chris01 is offline   Reply With Quote
Old 10-14-2014, 12:01 PM   #5
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Quote:
Originally Posted by Chris01 View Post
Did you check your fuses? If so it could be the switch or the blower


Sent from my iPhone using Mustang Evolution
My fuses are all good. I'm thinking it could be the ignition switch possibly since the blinkers don't work either?
antnvlz1294 is offline   Reply With Quote
Old 10-14-2014, 04:35 PM   #6
Registered Member
Regular
 
Chris01's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 135
Ok so u have other problems with the car. What else Doesn't work


Sent from my iPhone using Mustang Evolution
Chris01 is offline   Reply With Quote
Old 10-14-2014, 04:40 PM   #7
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Quote:
Originally Posted by Chris01 View Post
Ok so u have other problems with the car. What else Doesn't work


Sent from my iPhone using Mustang Evolution
Reverse lights, passenger side window doesn't like to go back up unless I wait a bit and dimmer switch is bad. That's all.
antnvlz1294 is offline   Reply With Quote
Old 10-14-2014, 04:44 PM   #8
Registered Member
Regular
 
Chris01's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 135
I'm guessing u bought the car with all these problems


Sent from my iPhone using Mustang Evolution
Chris01 is offline   Reply With Quote
Old 10-14-2014, 04:50 PM   #9
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Quote:
Originally Posted by Chris01 View Post
I'm guessing u bought the car with all these problems


Sent from my iPhone using Mustang Evolution
Yeah. I've owned a fox before so to me those are little things since I've dealt with them before. The only things that are new to me is this heater issue because I had heat before and this power window issue because I had no electric anything lol
antnvlz1294 is offline   Reply With Quote
Old 10-14-2014, 04:56 PM   #10
Registered Member
Regular
 
Chris01's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 135
Heat

Have u check bulbs and/or flasher relay? Could be simple as mine was but behind the hazard switch the wires come loose something and need to be shoved back into the plug because the blinker are wired thru the hazard switch. As for heat take the wires of the plug and hot wire it just to see if the blower motor work


Sent from my iPhone using Mustang Evolution
Chris01 is offline   Reply With Quote
Old 10-16-2014, 10:05 PM   #11
Registered Member
Regular
 
antnvlz1294's Avatar
 
Join Date: Nov 2013
Location: Mount Laurel
Region: New Jersey
Posts: 212
Quote:
Originally Posted by Chris01 View Post
Have u check bulbs and/or flasher relay? Could be simple as mine was but behind the hazard switch the wires come loose something and need to be shoved back into the plug because the blinker are wired thru the hazard switch. As for heat take the wires of the plug and hot wire it just to see if the blower motor work


Sent from my iPhone using Mustang Evolution
Hot wire the wires? How so?
antnvlz1294 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94-98 Heat Extractor Hood Roadhawg Mustang Audio & Video 28 08-02-2006 04:53 PM
WTB: Cobra Heat Exchanger SwpdMR2 Mustang Parts for Sale and Wanted 2 05-02-2006 01:33 PM
run 16.3 in high heat/humid...low temp good for 15's? tedness Pre-2005 V6 Mustang 7 01-02-2006 01:56 PM
Some new(er) pics of my car..bringing the heat mike!! greenflash00 Mustang Audio & Video 18 06-24-2004 03:26 PM

» Like Us On Facebook



03:43 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.