Maf - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-24-2015, 06:02 PM   #1
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
Maf

Car runs fine with maf unplugged but plug it in and try to accelerate at all and it dies


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-24-2015, 06:05 PM   #2
Moderator Emeritus
 
Adogg's Avatar
 
Join Date: Nov 2011
Region: Massachusetts
Posts: 1,499
Well then looks like you need to either clean the one you have or replace. Does it look really dirty on the little metal strand inside?
__________________
Don't hate....... appreciate
Adogg is offline   Reply With Quote
Old 01-24-2015, 06:45 PM   #3
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
Ok so i replaced it with my brothers sn95 its good now, but now i move the distributor to try and adjust timing and yes the mark moves but dosent seem to run any beter or worst as i move it. Yes with the litle chip unplugged


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-24-2015, 07:05 PM   #4
Moderator Emeritus
 
Adogg's Avatar
 
Join Date: Nov 2011
Region: Massachusetts
Posts: 1,499
Are you using a timing light to check??
__________________
Don't hate....... appreciate
Adogg is offline   Reply With Quote
Old 01-24-2015, 07:29 PM   #5
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
Yes . i just intalled gt40ps and deleted both smog pump and egr. But the car smells really strong it makes you cough. And kind of idles rough. Anything i should look into? I blocked all of the uneeded vaccums coming from the intake. Anything else needed to be done?


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Old 01-24-2015, 07:46 PM   #6
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
Yes . i just intalled gt40ps and deleted both smog pump and egr. But the car smells really strong it makes you cough. And kind of idles rough. Anything i should look into? I blocked all of the uneeded vaccums coming from the intake. Anything else needed to be done?


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Old 01-24-2015, 11:00 PM   #7
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Well what injectors?
What MAF? Is it calibrated to the injector size?
When setting the timing are you disconnecting the spout?
Have you ran your codes yet?

Sent from the Bathroom
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 01-24-2015, 11:08 PM   #8
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
Stock inyectors with 95 maf


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Old 01-24-2015, 11:09 PM   #9
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
And yes spout was unplugged sorry


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Old 01-25-2015, 01:16 AM   #10
Registered Member
Regular
 
Blue skull's Avatar
 
Join Date: Jan 2015
Location: Austin
Region: Texas
Posts: 59
And yes spout was unplugged sorry


Sent from my iPhone using Mustang Evolution
Blue skull is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 5.0 MAF upgrade to a 80mm 2000 4.6 MAF chatanaka36 1979-1995 Mustang GT 3 07-03-2012 09:57 PM
Parts for sale: gauge, fuel acc., filter adapter, MAF,bumper Mus35th Mustang Parts for Sale and Wanted 7 08-31-2004 02:58 PM
2002+ GT C&L MAF...BRAND NEW Junior2561 Mustang Parts for Sale and Wanted 0 03-15-2004 07:18 AM
maf and chip for sale grendel Mustang Parts for Sale and Wanted 2 03-11-2004 09:12 AM
Maf Sensor Torx Bit Screws sctalbott Pre-2005 V6 Mustang 5 01-12-2004 02:51 PM

» Like Us On Facebook



02:14 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.