No power? Leak somewhere? Help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-22-2015, 10:12 AM   #1
Registered Member
Regular
 
jriccard's Avatar
 
Join Date: May 2015
Location: Orlando
Region: Florida
Posts: 33
No power? Leak somewhere? Help

Feel like I'm chasing a ghost here... I put an explorer intake on my 88 fox body and since then under load car makes a loud whooshing sound.. Sounds like it's missing and has no balls... There's barely any power there at all.
No intake leak or vacuum leak that I could find anywhere. I've had multiple people look at it and no one can give me a straight answer. Can anyone here help me out?


'88 GT
jriccard is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2015, 10:12 AM   #2
Registered Member
Regular
 
jriccard's Avatar
 
Join Date: May 2015
Location: Orlando
Region: Florida
Posts: 33
Click image for larger version

Name:	ImageUploadedByMustang Evolution1440256358.999206.jpg
Views:	61
Size:	75.1 KB
ID:	189865


'88 GT
jriccard is offline   Reply With Quote
Old 08-22-2015, 10:27 AM   #3
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,020
have you tried a smoke test?
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2015, 11:15 AM   #4
Registered Member
Regular
 
jriccard's Avatar
 
Join Date: May 2015
Location: Orlando
Region: Florida
Posts: 33
I'm not familiar with that.. What is that?


'88 GT
jriccard is offline   Reply With Quote
Old 08-22-2015, 12:45 PM   #5
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
You inject smoke into the intake and you will see it escape through your vacuum leak.

Sounds like a vacuum leak somewhere.

Also what is your timing set at?

What's your fuel pressure at?

Sent from the Bathroom
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-24-2015, 11:41 AM   #6
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,588
It really does sound like there is a vac issue somewhere. The explorer intake has a lot of extra ports underneath the upper intake that need to be re-routed or plugged. I'd start there.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Old 08-24-2015, 02:57 PM   #7
Registered Member
Regular
 
jriccard's Avatar
 
Join Date: May 2015
Location: Orlando
Region: Florida
Posts: 33
I ran a smoke test and it was fine. No leaks?


'88 GT
jriccard is offline   Reply With Quote
Old 08-24-2015, 07:50 PM   #8
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
How about what I asked?

Sent from the Bathroom
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 08-24-2015, 08:11 PM   #9
Registered Member
Regular
 
jriccard's Avatar
 
Join Date: May 2015
Location: Orlando
Region: Florida
Posts: 33
Timing 12 degrees and fuel pressure is good


'88 GT
jriccard is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaf stuck somewhere. Not in A/C. Help? thevanman Mustang Paint, Appearance & Detailing 1 12-10-2014 11:52 PM
Leak somewhere XSlashDashX 1996-2004 Mustang GT 10 08-07-2014 11:36 PM
HELP! oil coming from somewhere v8pony 1996-2004 Mustang GT 15 09-11-2012 09:10 PM
electrical problem, maybe a short somewhere jacop Pre-2005 V6 Mustang 2 03-30-2012 11:35 PM
so my dad took me somewhere today.. Rellik The Bar 12 01-19-2004 03:59 PM

» Like Us On Facebook



11:40 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.