losing power could it be the tranny?? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-06-2015, 01:03 AM   #1
Registered Member
Regular
 
Haav2's Avatar
 
Join Date: Sep 2012
Region: Florida
Posts: 173
losing power could it be the tranny??

I've been driving my car for about 4 months after the engine build and it drove fine and couldn't be happier but recently I've been noticing that when i stomp on the gas my car just doesn't go and i think hear some noise coming from the transmission.

the rpms just go up and i and accelerate slowly and sometimes stay the same speed. now I've checked my clutch by doing a couple tests. no smell , stall out test, cable check, etc… so i don't think that could be it. also when i begin to accelerate going about 2500 rpm i can hear a light tap going on somewhere behind the engine getting louder the more i accelerate.

i currently have a center force clutch don't know what could be the culprate. I'm thinking it can be something in the tranny like the input shaft or something but I'm clueless at this point. if anyone has had experience with something like this please let me know , it will be much appreciated
Haav2 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-06-2015, 05:19 AM   #2
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
I would think if rpms go up but not speed it would have to be the clutch...
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 11-06-2015, 07:37 AM   #3
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Put the car in 5th at about 30. Floor it. If rpm's shoot up without speed it is most likely your clutch.

Sent from my XT1045 using Tapatalk
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-06-2015, 07:58 AM   #4
Registered Member
Regular
 
Mike roush02's Avatar
 
Join Date: Oct 2015
Location: Denham Springs
Region: Louisiana
Posts: 76
Clutch


Sent from my iPhone using Mustang Evolution
Mike roush02 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing power? 2013 gt w/ procal 5.Ohboy 2011-2014 Mustang GT 4 11-15-2014 05:43 PM
1991 mustang 2.3l losing power just wanted to know why? beverley86 2.3 Mustang 4 12-16-2011 12:52 PM
2010 Gt 4.6L with JLT, SCT Tune, and BBK throttle losing power yoshywown7 2011-2014 Mustang GT 3 06-11-2011 12:51 AM
Helping gas without losing power back from iraq 1996-2004 Mustang GT 4 08-06-2008 09:18 PM

» Like Us On Facebook



09:53 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.