Code 22 BAP Sensor Out of Range - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-13-2016, 11:19 PM   #1
Registered User
Newbie
 
Join Date: Feb 2016
Location: Lansdale
Region: Pennsylvania
Posts: 9
Code 22 BAP Sensor Out of Range

Hey all, first post here. I'm trying to fix code 22 on my 1991 5.0. It has to do with the Barometric Pressure Sensor being out of range. Being that my car is now 25 years old I have a feeling that sensor might have to be replaced. My symptom is a crappy slightly fluctuating idle...very annoying. I will note that I did previously have codes 44 and 94 which I fixed by diagnosing with a smoke test and plugging up some vacuum leaks. But like I said now I have 22. Has anyone ever had this issue and then replaced their BAP (for mass air flow) or MAP (for speed density) and then had the code go away, fixing the idle? Also, I do plan on replacing my O2 sensors soon because I don't know how old they are since I bought the car from the previous owner back in June 2015 and haven't replaced them yet. All advice and help is greatly appreciated. Thanks.

Sent from my Nexus 6P using Mustang Evolution mobile app
UltraBlue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2016, 06:31 PM   #2
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 289
This trouble shooting link will help you test the BP sensor & its wiring,but you'll need a multimeter that measures frequency,to test the sensor itself.You can test the BP sensor wiring with a regular multimeter,but you'll need the frequency measuring meter to do the sensor test.
BP/MAP Sensor Code 22 Troubleshooting

To answer your question,yes the BP sensor affects idle,fuel trim & spark advance.
Be sure to check the 10 pin(aka:salt&pepper)connecters
& do the maintenance procedure on them.They can cause idle issues,driveability problems & false trouble codes,if their pinouts are loose or corroded.
Salt & Pepper (10-pin) Connectors Fix[COLOR="Silver"]
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Old 02-15-2016, 01:54 PM   #3
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Also before buying new O2 sensors, have you done a full tune up?


I also didn't see any codes for O2 sensors that is why I am asking.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-15-2016, 02:22 PM   #4
Registered User
Newbie
 
Join Date: Feb 2016
Location: Lansdale
Region: Pennsylvania
Posts: 9
I recently did a pretty good tune up, a couple months ago I got plugs, wires, new distributer cap, and new coil. I'll have to test the BAP Sensor and salt and pepper shakers, I just happen to have one new o2 sensor laying around so that's less money I'd have to spend in case I do replace them.

Sent from my Nexus 6P using Mustang Evolution mobile app
UltraBlue is offline   Reply With Quote
Old 02-18-2016, 09:28 AM   #5
Registered User
Newbie
 
Join Date: Feb 2016
Location: Lansdale
Region: Pennsylvania
Posts: 9
Replaced BAP sensor and fuel filter as well, she's running great

Sent from my Nexus 6P using Mustang Evolution mobile app

---------- Post added at 03:28 PM ---------- Previous post was at 03:28 PM ----------

Also cleaned salt and pepper shakers, those are sons of *****es to take off

Sent from my Nexus 6P using Mustang Evolution mobile app
UltraBlue is offline   Reply With Quote
Old 02-23-2016, 11:05 AM   #6
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 289
So the problem must have been caused by a faulty bp sensor.Thanks for updating the thread.
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BAP VS. New fuel pump Usmcdav2011 General Mustang Discussion 2 01-11-2014 11:54 PM
Is a BAP enough? 6SpeedFreak 2011-2014 Mustang GT 3 01-28-2013 09:17 AM
Kenne Bell BAP southernstang00 1996-2004 Mustang GT 14 09-14-2012 10:29 PM
JLT CAI for 03/04 cobra and Kenne Bell BAP slostang Mustang Parts for Sale and Wanted 6 11-04-2008 06:29 PM
KB BAP 40 amp, Lethal wiring upgrade 99MustangGTman Mustang Parts for Sale and Wanted 0 08-24-2008 04:00 PM

» Like Us On Facebook



07:50 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.