Rough idle, mods w/BBK performance items - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-18-2016, 07:47 PM   #1
Registered User
Newbie
 
Join Date: Feb 2016
Location: Middle River
Region: Maryland
Posts: 2
Rough idle, mods w/BBK performance items

Did minor modifications BBk 76mm MAF housing cal for 24lb injectors, 24lb injectors, BBK CAI,BBK 70mm throttle body w/EGR and a Bama chip. Cannot get the TPS down under 2.0 volts, won't stay running when cold and idles like crap. I am using the original intake manifolds upper/lower. Has any other members experience this and how to correct it.
89LxMustang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-19-2016, 07:05 AM   #2
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 289
Does the CAI system have the curved pipe thats mounted to the fender with the filter installed inside the fender??If yes,does the MAF sensor you're using have a screen attached to its inlet side??If no,that could be your problem.The air stream gets turbulent due to the curved section of pipe & it causes idle issues.You can try reclocking the MAF housing so the sensor is sitting in a different position.Its at 12 o'clock now.Rotate it to 3,6 or 9 o'clock to see if that helps.
If the TPS won't adjust into the .70-1.0 range,follow the tests in the link below then replace the sensor,if it doesnt pass.You also need to do the maintenance procedure on the salt & pepper shakers.

TPS Codes 23/53/63 Troubleshooting

Fuel Injection Technical Library » 10-pin Connector Fix[COLOR="Silver"]
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Old 04-19-2016, 03:38 PM   #3
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
Pull your codes (when car is at operating temp).


Also check for vacuum leaks. Did you remove your intake? Check all the vacuum lines 3 times to be sure? Also I have seen a few BBK TB that just do not act right.
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-19-2016, 07:27 PM   #4
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 289
It wouldn't hurt to run koeo & koer tests to see if the components have caused any codes.The cel doesnt have to be on,in order for codes to be present.I had the same issues years ago when I installed a cai,but that was before I knew anything about needing a maf screen.Like smurf said,check for vacuum leaks.You can spray some carb cleaner around the silicone hoses,to make sure theyre sealing good.The idle will surge if you spray an area thats leaking vacuum.Any air that enters the engine,which didnt get measured by the maf sensor,is considered "unmetered air"(vacuum leak)
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Old 04-19-2016, 07:32 PM   #5
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 289
Quote:
Originally Posted by smurf stang View Post
Pull your codes (when car is at operating temp).


Also check for vacuum leaks. Did you remove your intake? Check all the vacuum lines 3 times to be sure? Also I have seen a few BBK TB that just do not act right.
I agree.Their tb's are also bad about whistling.You can supposedly use a dremel to match the tb, iac valve & gasket passages,to rid the whistle.
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Old 04-21-2016, 09:55 PM   #6
Registered Member
Regular
 
Splogan's Avatar
 
Join Date: Jan 2013
Location: Scott AFB
Region: Illinois
Posts: 67
Quote:
Originally Posted by wbrockstar View Post
Does the CAI system have the curved pipe thats mounted to the fender with the filter installed inside the fender??If yes,does the MAF sensor you're using have a screen attached to its inlet side??If no,that could be your problem.The air stream gets turbulent due to the curved section of pipe & it causes idle issues.You can try reclocking the MAF housing so the sensor is sitting in a different position.Its at 12 o'clock now.Rotate it to 3,6 or 9 o'clock to see if that helps.
If the TPS won't adjust into the .70-1.0 range,follow the tests in the link below then replace the sensor,if it doesnt pass.You also need to do the maintenance procedure on the salt & pepper shakers.



TPS Codes 23/53/63 Troubleshooting

Fuel Injection Technical Library » 10-pin Connector Fix[COLOR="Silver"]

Not to threadjack but i do use that style (SR Performance) and there is no way for the screen to be installed. I often wondered if that was causing the very slight initial start up idle issue in my car. So I have to get the screen back in somehow?
__________________
1970 Mustang Fastback (Primer Gray)
1995 Mustang GT Convertible (Deep Forest Green)
2005 F-150 SCAB (Arizona Beige Metallic)
2016 Mustang GT, Fastback Perf Pack (Ingot Silver)
Splogan is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance Cart of items. Save or spend? MattsMustang224 Pre-2005 V6 Mustang 8 08-25-2014 12:46 PM
ROUGH IDLE joseandmarilyn 1979-1995 Mustang GT 8 09-28-2007 12:39 AM
My car seems to idle rellay rough, and miss badly johnpittbull 1979-1995 Mustang GT 21 07-04-2006 10:06 AM
Rough Idle and Rough Start Cajun JungleBoy Pre-2005 V6 Mustang 3 04-23-2006 11:33 PM
MIL P1414, rough idle BlueDonkey Pre-2005 V6 Mustang 7 11-14-2003 12:27 AM

» Like Us On Facebook



06:16 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.