Help - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-18-2012, 11:24 PM   #1
Registered Member
Regular
 
Killastang's Avatar
 
Join Date: Jan 2012
Region: Florida
Posts: 61
Help

I put in a aftermarket head unit and ever time I turn the key on the speaker make a popping noise, like the amps are kicking on. Is that normal?
Killastang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-2012, 12:24 AM   #2
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Yep. It's one of the downsides to running the Mach 460 speakers with an aftermarket head unit.

---------- Post added at 06:24 AM ---------- Previous post was at 06:23 AM ----------

Whoops didn't realize you didn't have the 460. Do you have the Shaker system?
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 02-19-2012, 12:35 AM   #3
Registered Member
Regular
 
Killastang's Avatar
 
Join Date: Jan 2012
Region: Florida
Posts: 61
It's the shaker 500
Killastang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-2012, 12:41 AM   #4
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Well I haven't messed around with one of those yet. But assuming Ford stayed true with the whole amplifier set up, yes that's just something that happens with the stock amps.
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!!!! jacob.a.gasparp 1979-1995 Mustang GT 41 04-29-2012 08:07 PM
Wheel spacers help! jamin22786 2005-2010 V6 Mustang 9 02-26-2012 07:32 PM
O2 sensor help? redfox48 1996-2004 Mustang GT 5 02-19-2012 08:56 AM
Dynomat help with drone? Jmoss 2011-2014 Mustang GT 5 02-18-2012 01:52 PM
exhaust help!? reeg2010 2011-2014 Mustang GT 28 02-18-2012 03:36 AM

» Like Us On Facebook



11:33 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.