Radio will not work right. - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-19-2012, 02:01 PM   #1
Registered Member
Regular
 
Srohda's Avatar
 
Join Date: Aug 2011
Location: Aberdeen
Region: Maryland
Posts: 150
Radio will not work right.

I got in my car today and had the radio tuned to a station, turned the volume to the right setting and went about my business. Later on down the road I tried turning the volume down and nothing happened. Tried changing the station and nothing. Tried turning off the power and nothing. My radio is currently stuck at o e station set to one volume and it won't even power off. Any suggestions?
__________________
2012 GT Premium w/Brembo
Roush axle backs
MGW short throw shifter
Srohda is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2012, 02:04 PM   #2
The Blue Dragon
Regular
Supporter
 
GrabberBlue5.0's Avatar
 
Join Date: Feb 2012
Location: Louisville
Region: Kentucky
Posts: 5,661
Blue monster literally had this problem just yesterday, take it to the dealer, problems with the radio
__________________
New quick exhaust video

AUGUST 2012 MOTM!!!!
GrabberBlue5.0 is offline   Reply With Quote
Old 12-19-2012, 02:05 PM   #3
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Still have dealer warranty? Try disconnectin youee batt
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2012, 02:10 PM   #4
Registered Member
Regular
 
Srohda's Avatar
 
Join Date: Aug 2011
Location: Aberdeen
Region: Maryland
Posts: 150
Yea it's under warranty
__________________
2012 GT Premium w/Brembo
Roush axle backs
MGW short throw shifter
Srohda is offline   Reply With Quote
Old 12-19-2012, 02:12 PM   #5
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Take it in
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 12-20-2012, 12:22 AM   #6
Registered Member
Regular
 
Ratraget's Avatar
 
Join Date: Jul 2012
Region: Texas
Posts: 123
Disconnect and reconnect battery. Take it in if it doesn't work
Ratraget is offline   Reply With Quote
Old 12-20-2012, 01:21 AM   #7
Registered Member
Regular
 
bluemonster13's Avatar
 
Join Date: May 2012
Region: California
Posts: 453
Yea he pm me and I told what my issue was. Mine was a bad battery and faulty radio system.
__________________
2013 Mustang GT Premium
brembo package
heat extractor hood
3.55 Gears
Borla "s" type catback exhaust
20% tint alll around.
bluemonster13 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:05 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.