Radio displays "mustang" 2011 - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-10-2013, 01:08 PM   #1
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Radio displays "mustang" 2011

Mustang v6 2011 . Radio display screen only displays "mustang" no stereo buttons work .
Maperez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-10-2013, 01:25 PM   #2
Registered Member
Regular
 
xxPIKExx's Avatar
 
Join Date: Jun 2013
Location: Ft Lauderdale
Region: Florida
Posts: 450
Mine did that when I was hooking up a sub. It was a blown fuse
xxPIKExx is offline   Reply With Quote
Old 10-10-2013, 01:27 PM   #3
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by xxPIKExx View Post
Mine did that when I was hooking up a sub. It was a blown fuse
. Which fuse was it ? And how was it acting ?
Maperez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-10-2013, 01:43 PM   #4
Registered Member
Regular
 
xxPIKExx's Avatar
 
Join Date: Jun 2013
Location: Ft Lauderdale
Region: Florida
Posts: 450
Sorry. Don't remember which fuse exactly, but if I remeber correctly it was in the head unit and not the fuse box. It was just like you described. Turn on radio, the display just read mustang. Nothing worked at all.
xxPIKExx is offline   Reply With Quote
Old 10-10-2013, 02:10 PM   #5
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by xxPIKExx View Post
Sorry. Don't remember which fuse exactly, but if I remeber correctly it was in the head unit and not the fuse box. It was just like you described. Turn on radio, the display just read mustang. Nothing worked at all.
. In the actual stereo head unit ??
Maperez is offline   Reply With Quote
Old 10-10-2013, 02:15 PM   #6
Lord NoMoney
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,630
probably on the backside.

---------- Post added at 02:15 PM ---------- Previous post was at 02:15 PM ----------

just get a double din touch screen!! whoop whoop!!
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Old 10-10-2013, 02:52 PM   #7
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by silverskoundrel View Post
probably on the backside. ---------- Post added at 02:15 PM ---------- Previous post was at 02:15 PM ---------- just get a double din touch screen!! whoop whoop!!
my friend has the same problem . He bought a double din touch screen and ima help him install it . Hopefully it goes well . If I can't fix mine . I'll just sell the car like it is . Thanks
Maperez is offline   Reply With Quote
Old 10-10-2013, 03:00 PM   #8
Lord NoMoney
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,630
why sell it
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Old 10-10-2013, 05:03 PM   #9
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by silverskoundrel View Post
why sell it
I sell cars .

---------- Post added at 05:03 PM ---------- Previous post was at 05:02 PM ----------

Quote:
Originally Posted by silverskoundrel View Post
why sell it
I sell cars
Maperez is offline   Reply With Quote
Old 10-10-2013, 05:24 PM   #10
Registered Member
Regular
 
xxPIKExx's Avatar
 
Join Date: Jun 2013
Location: Ft Lauderdale
Region: Florida
Posts: 450
Quote:
Originally Posted by Maperez View Post
. In the actual stereo head unit ??
Yes sir. Back side. Comes out pretty easy
xxPIKExx is offline   Reply With Quote
Old 10-11-2013, 01:20 AM   #11
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by xxPIKExx View Post
Yes sir. Back side. Comes out pretty easy
on this thing ? this one is my friends . 2010 premium
Attached Thumbnails
Click image for larger version

Name:	image-3968242543.jpg
Views:	161
Size:	397.5 KB
ID:	132142  
Maperez is offline   Reply With Quote
Old 10-11-2013, 08:38 AM   #12
Lord NoMoney
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,630
Quote:
Originally Posted by Maperez View Post
on this thing ? this one is my friends . 2010 premium
well I was wrong
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Old 10-11-2013, 08:55 AM   #13
Registered Member
Regular
 
mystang50's Avatar
 
Join Date: Jul 2011
Location: houston
Region: Texas
Posts: 1,201
Quote:
Originally Posted by silverskoundrel View Post
well I was wrong
what??your never wrong! you might have to take the metal cover off? idk though
__________________
1995 5.0 u/d,cai,t/b,shorty headers,x pipe,flows 40's,373 gears, alum. driveshaft, alum. radiator, shift kit, e-cam, ported upper and lower intake, 100 shot of spray, 2100 stall, black 0304 cobras. suspension: upper and lower control arms, sub frame connecters, and springs all SVE
mystang50 is offline   Reply With Quote
Old 10-11-2013, 09:15 AM   #14
Lord NoMoney
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,630
ive been wrong a lot hahahaha on aftermarket radios theyre just on the backside
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Old 10-11-2013, 05:19 PM   #15
Registered User
Newbie
 
Join Date: Oct 2013
Location: Douglas
Region: Arizona
Posts: 2
where you guys able to solve this problem? I am having the same issue
alanmanquero is offline   Reply With Quote
Old 10-11-2013, 05:24 PM   #16
Registered Member
Regular
 
Maperez's Avatar
 
Join Date: Sep 2013
Location: Memphis
Region: Tennessee
Posts: 12
Quote:
Originally Posted by alanmanquero View Post
where you guys able to solve this problem? I am having the same issue
nope .
Maperez is offline   Reply With Quote
Old 10-30-2013, 03:27 PM   #17
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
Check the fuse panel for whatever is running the interior...maybe Fuse#3?? Don't quote me. Pull it out for a few minutes and put it back. This should reset the radio. Otherwise disconnect the battery for a few minutes works if nothing else.

When in doubt....reboot
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.