Idatalink/Maestro MUS1 Dash kit install. - Page 3 - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-22-2013, 11:45 PM   #71
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Finally got everything in. Absolutely love it. Took almost a month but well worth it.
Attached Thumbnails
Click image for larger version

Name:	image-2932674705.jpg
Views:	770
Size:	378.3 KB
ID:	137836  
Capn__Morgan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-23-2013, 04:34 AM   #72
Registered Member
Regular
 
EastTNMustang's Avatar
 
Join Date: Nov 2013
Location: Knoxville
Region: Tennessee
Posts: 415
Quote:
Originally Posted by Capn__Morgan View Post
Finally got everything in. Absolutely love it. Took almost a month but well worth it.
Awesome, glad you finally received a good working HU...congrats!
EastTNMustang is offline   Reply With Quote
Old 12-02-2013, 02:27 PM   #73
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
Morgan...random question. Are the blue button lights a different shade of blue than all the other interior buttons? I spoke with ADS on the issue but was told that they should be the same color as the OEM buttons in the car. Wondering if it's just my car? On mine the ADS kit buttons are more of a blue and the Mustang interior OEM buttons are a light blue (or ICE Blue as Ford calls it).

I know it's stupid but it bugs the SH*! outta me. I'd rather find out what LEDs they used in the kit and switch them to red or something contrasting so I can match my stereo/gauge colors to the kit. The two different blues are an eye twitch for me.
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-02-2013, 02:34 PM   #74
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by Double J View Post
Morgan...random question. Are the blue button lights a different shade of blue than all the other interior buttons? I spoke with ADS on the issue but was told that they should be the same color as the OEM buttons in the car. Wondering if it's just my car? On mine the ADS kit buttons are more of a blue and the Mustang interior OEM buttons are a light blue (or ICE Blue as Ford calls it). I know it's stupid but it bugs the SH*! outta me. I'd rather find out what LEDs they used in the kit and switch them to red or something contrasting so I can match my stereo/gauge colors to the kit. The two different blues are an eye twitch for me.
Yupp. It's a darker blue. I have a few small quarrels with the kit. Mainly the climate integration. The hot/cold bar should be touch sensitive. IE. I touch somewhere on the bar and the cursor moves to that location. And the time between screens. I know it won't be instant but when you're freezing and there is cold air blowing on you it's a bit inconvenient lol
Capn__Morgan is offline   Reply With Quote
Old 12-02-2013, 02:47 PM   #75
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
"Yupp. It's a darker blue."

Oh thank god...I thought I was the only one since I haven't seen anyone else mention it. While I agree with the lag and the issue with the climate bar, that's an issue with Kenwood rather than ADS. Maybe Kenwood will come out with a firmware update that will address this? Not holding my breath

Thanks for confirming the button color issue. Wonder if Mark/ADS can make a quick post telling us the part number for the flush mount LEDs they use in case some of us want to take on the challenge of soldering on a different color? I realize this would void any warranty and would be a "do at your own risk" type of thing but I'm pretty dam good with a soldering iron and would like to take that challenge.
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Old 12-02-2013, 02:48 PM   #76
Registered Member
Regular
 
12V Guy's Avatar
 
Join Date: Oct 2013
Location: Montreal
Region: Canada
Posts: 102
Quote:
Originally Posted by Capn__Morgan View Post
Yupp. It's a darker blue. I have a few small quarrels with the kit. Mainly the climate integration. The hot/cold bar should be touch sensitive. IE. I touch somewhere on the bar and the cursor moves to that location. And the time between screens. I know it won't be instant but when you're freezing and there is cold air blowing on you it's a bit inconvenient lol


Sorry about the touch sensitive temp bar. We asked for this for both the bar and the fan, but radio could not support it.
Lot of options for climate bar:


1. Press climate on button bar - takes you right to the screen, no fuss
2. Assign temp to be functions on your button bar so you can control directly, even before the screen is up.


We tried very hard to make a great product. We are listening to the feedback and correcting what we can.


Cheers,
__________________
12V Guy
Automotive Data Solutions, Inc.
Montreal, Canada
maestro.idatalink.com
12V Guy is offline   Reply With Quote
Old 12-02-2013, 02:51 PM   #77
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by Double J View Post
"Yupp. It's a darker blue." Oh thank god...I thought I was the only one since I haven't seen anyone else mention it. While I agree with the lag and the issue with the climate bar, that's an issue with Kenwood rather than ADS. Maybe Kenwood will come out with a firmware update that will address this? Not holding my breath Thanks for confirming the button color issue. Wonder if Mark/ADS can make a quick post telling us the part number for the flush mount LEDs they use in case some of us want to take on the challenge of soldering on a different color? I realize this would void any warranty and would be a "do at your own risk" type of thing but I'm pretty dam good with a soldering iron and would like to take that challenge.
Yupp! I might change it. It doesn't really bother me a great deal.

---------- Post added at 05:51 PM ---------- Previous post was at 05:50 PM ----------

Quote:
Originally Posted by 12V Guy View Post
Sorry about the touch sensitive temp bar. We asked for this for both the bar and the fan, but radio could not support it. Lot of options for climate bar: 1. Press climate on button bar - takes you right to the screen, no fuss 2. Assign temp to be functions on your button bar so you can control directly, even before the screen is up. We tried very hard to make a great product. We are listening to the feedback and correcting what we can. Cheers,
Oh it's definitely a fantastic product! I'm not questioning that lol. Just little things that someone will eventually complain about. Ya can't please everyone after all
Capn__Morgan is offline   Reply With Quote
Old 12-02-2013, 02:54 PM   #78
Registered Member
Regular
 
12V Guy's Avatar
 
Join Date: Oct 2013
Location: Montreal
Region: Canada
Posts: 102
Quote:
Originally Posted by Capn__Morgan View Post
Yupp! I might change it. It doesn't really bother me a great deal.




Before you guys change them out, can you tell me if turning the dimmer down on the dash lighting does anything to improve the match? We sourced the same LEDs used in the OEM panel. A couple of differences:


1. Our icons are very large compared to the icons on your steering wheel buttons or window switches. Does this make them seem darker because they are larger?


2. The dimmer voltage will change the drive to the LEDs. If they are dimmer does the color seem to match better or are they still darker, but less bright?


Worst case, will post you guys a schematic and tell you the LEDs to change. As for part number, you are on your own there, since if we knew a better LED to put there for the match, we would have used it.


Cheers,
__________________
12V Guy
Automotive Data Solutions, Inc.
Montreal, Canada
maestro.idatalink.com
12V Guy is offline   Reply With Quote
Old 12-02-2013, 03:14 PM   #79
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by 12V Guy View Post
Before you guys change them out, can you tell me if turning the dimmer down on the dash lighting does anything to improve the match? We sourced the same LEDs used in the OEM panel. A couple of differences: 1. Our icons are very large compared to the icons on your steering wheel buttons or window switches. Does this make them seem darker because they are larger? 2. The dimmer voltage will change the drive to the LEDs. If they are dimmer does the color seem to match better or are they still darker, but less bright? Worst case, will post you guys a schematic and tell you the LEDs to change. As for part number, you are on your own there, since if we knew a better LED to put there for the match, we would have used it. Cheers,
When I dim mine they get darker as opposed ti the others. Even at their fullest power they are still a normal blue when the ford ones are a much cooler blue. If that makes sense.
Capn__Morgan is offline   Reply With Quote
Old 12-02-2013, 03:19 PM   #80
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
I played with the dimmer on mine after installation. Didn't make much of a difference in color, just less bright. I don't know that the size of the icons makes much of a difference. The size might make it stand out more, but they just appear to be a noticeably different shade of blue any way you slice it. As a side note...the blue ADS buttons perfectly match the "OEM matched" blue that the Kenwood HU uses when you select "Initialize" in the color settings. It appears that Kenwood couldn't quite match the OEM blue either.

I would like to attempt changing the LED color to red if you could provide a schematic. And if you were able to provide the product type or part number so I could get the same type of LED lights, that would be awesome.

Also I'll mirror what Morgan said. This is a fantastic product and better than any other option on the market for the Mustang. It's a minor annoyance in the grand scheme.

Thanks for being open to questions and constructive criticism and providing AMAZING support right on the forums! Truly you guys have nailed the lost art of Customer Service.
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Old 12-02-2013, 03:23 PM   #81
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by Double J View Post
I played with the dimmer on mine after installation. Didn't make much of a difference in color, just less bright. I don't know that the size of the icons makes much of a difference. The size might make it stand out more, but they just appear to be a noticeably different shade of blue any way you slice it. As a side note...the blue ADS buttons perfectly match the "OEM matched" blue that the Kenwood HU uses when you select "Initialize" in the color settings. It appears that Kenwood couldn't quite match the OEM blue either. I would like to attempt changing the LED color to red if you could provide a schematic. And if you were able to provide the product type or part number so I could get the same type of LED lights, that would be awesome. Also I'll mirror what Morgan said. This is a fantastic product and better than any other option on the market for the Mustang. It's a minor annoyance in the grand scheme. Thanks for being open to questions and constructive criticism and providing AMAZING support right on the forums! Truly you guys have nailed the lost art of Customer Service.
Agreed with J. The fact that you guys listen and interact with your cliental is fantastic. I actually just went out to my car to take a few snap shots of the color difference. Obviously the colors aren't spot on because of phone quality but it's enough that you can see the difference....

First is the overall full and then overall dim. Then it's a close up of the ADS and the color of the screen. Dim and then bright. =)
Attached Thumbnails
Click image for larger version

Name:	image-3279526473.jpg
Views:	399
Size:	254.8 KB
ID:	139369   Click image for larger version

Name:	image-3288365669.jpg
Views:	290
Size:	312.6 KB
ID:	139370  

Click image for larger version

Name:	image-2929425005.jpg
Views:	288
Size:	356.6 KB
ID:	139371   Click image for larger version

Name:	image-995315310.jpg
Views:	302
Size:	356.9 KB
ID:	139372  

Capn__Morgan is offline   Reply With Quote
Old 12-02-2013, 03:24 PM   #82
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
Yup my buttons are slightly different blue also. I'd like it to be the same but it doesn't really bother me.

The speed of screen changes is probably the biggest (of my very small) gripes. But I made temp up/down two of the hard buttons so I just poke the hell out of those and ignore the screen for the most part for temp changes. Made press and hold fan up/down on those buttons also - so temp change - poke, poke, poke. fan change - press and hold until desired speed is reached. I'm considering reversing that operation at some point but haven' driven it enough to decide.

It seems to me at least on my radio that the seek up and down are just that. I'd like a way to jump through my preset stations but I'm not seeing that. Kenwood DNN770HD.
timle8n1 is offline   Reply With Quote
Old 12-02-2013, 03:29 PM   #83
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
HAHA kind of ironic that your OEM display reads "Blue"tooth Clarity considering the discussion.
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Old 12-02-2013, 03:31 PM   #84
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
Its interesting that the info and diamond icon look like a slightly different color (and closer to the factory color). I wonder if its something with the buttons and not the LEDs.

Maybe I'll install it without a button out and see what it looks like.
timle8n1 is offline   Reply With Quote
Old 12-02-2013, 03:46 PM   #85
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
My pictures too

Looks about the same color difference wise as the ones above.
Hmm they are all upside down - right side up on my computer though.
Attached Thumbnails
Click image for larger version

Name:	IMG_3528.JPG
Views:	336
Size:	1.28 MB
ID:	139379   Click image for larger version

Name:	IMG_3529.JPG
Views:	231
Size:	1.25 MB
ID:	139380  

Click image for larger version

Name:	IMG_3530.JPG
Views:	332
Size:	1.40 MB
ID:	139381  
timle8n1 is offline   Reply With Quote
Old 12-03-2013, 03:59 PM   #86
Registered Member
Regular
 
12V Guy's Avatar
 
Join Date: Oct 2013
Location: Montreal
Region: Canada
Posts: 102
Quote:
Originally Posted by timle8n1 View Post
Looks about the same color difference wise as the ones above.
Hmm they are all upside down - right side up on my computer though.
Guys,


You are not crazy!!


We powered up one of the ones from stock and found that some of the LEDs are not the correct color. It seems it may be related to production of the LEDs themselves. They come on a tape and reel and are inserted by machine. So it's not possible that some wrong parts were mixed in. The entire reel of parts must have had a color variation.


We are investigating the issue further and once we have a solution, will update you all on how to get the fix. Most likely, will involve exchange of just the button bar for corrected one.


Sorry about this, our 48 piece pilot run, and the random samples we checked from production were all perfect. Please be patient as it will take us some time to get this squared away.


Cheers,
__________________
12V Guy
Automotive Data Solutions, Inc.
Montreal, Canada
maestro.idatalink.com
12V Guy is offline   Reply With Quote
Old 12-03-2013, 04:02 PM   #87
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by Double J View Post
HAHA kind of ironic that your OEM display reads "Blue"tooth Clarity considering the discussion.
Hahahahah. Couldn't have planned that any better if I tried.
Capn__Morgan is offline   Reply With Quote
Old 12-03-2013, 04:42 PM   #88
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
No worries 12volt! I love how open and honest you guys are about your product. It's obvious you guys care a lot about quality.

Keep up the good work!
timle8n1 is offline   Reply With Quote
Old 12-03-2013, 05:39 PM   #89
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
At this point I'm pretty happy J mentioned the color difference. Who would've thought one minor quip could detect something like this.
Capn__Morgan is offline   Reply With Quote
Old 12-04-2013, 08:08 AM   #90
Registered Member
Regular
 
Double J's Avatar
 
Join Date: Oct 2013
Location: Duluth
Region: Minnesota
Posts: 37
I guess sometimes it pays to be anal

Although now that I've been thinking of changing the color to red for so long I'm almost disappointed that I won't get to do that. HAHA, oh well I'd rather it be OEM color I guess but red would have been cool too.

Maybe ADS can make me a special "one off" button bar for being the one that detected the defect LOL
__________________
2010 Black GT. Appearance mods only so far. SS center fog grille, DG Customs side and window scoops, SLP Loudmouth axle backs, Roush center console button, Roush white shift knob and boot, ADS/Maestro RR dash kit w/ Kenwood NAV setup to retain SYNC.

NOTE: OEM grille, mufflers, and 401A shift knob w/boot are for sale if interested. PM me an offer.
Double J is offline   Reply With Quote
Old 12-12-2013, 08:35 AM   #91
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Hey 12volt. Any update?
Capn__Morgan is offline   Reply With Quote
Old 12-13-2013, 08:32 PM   #92
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
I think reading this thread cleared everything up for me. I have a base non-synch model GT...At first I didn't think I needed the Maestro RR module because I have no steering wheel controls or Blue tooth, etc...But it sounds like I need the module in order for the Climate controls and OBDII info to successfully get to the Kenwood unit.

Do you guys think a guy with no radio-install experience can pull this off in his driveway? Are the directions clear? My only concern would be the OBDII splice, and making sure the stock AUX port in the center counsel is hooked up right.
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Old 12-13-2013, 08:58 PM   #93
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by CHIZ_65 View Post
I think reading this thread cleared everything up for me. I have a base non-synch model GT...At first I didn't think I needed the Maestro RR module because I have no steering wheel controls or Blue tooth, etc...But it sounds like I need the module in order for the Climate controls and OBDII info to successfully get to the Kenwood unit.

Do you guys think a guy with no radio-install experience can pull this off in his driveway? Are the directions clear? My only concern would be the OBDII splice, and making sure the stock AUX port in the center counsel is hooked up right.

Well regardless you won't have the aux ports in the center console. That is wired into the stock radio. You'll need the Maestro module to get the climate/info/gauges on the Kenwold unit. As far as the install goes it wasn't too hard. Radio is straight forward and the instructions are on the Maestro website (although it took me a minute to find them) just take your time and do it right. Any questions post em in the this thread during install. I get notifications on my phone so I can almost always give you an answer within a few minutes. Took me about an hour once I had all of the right parts lol. Good luck and post pics when done!
Capn__Morgan is offline   Reply With Quote
Old 12-13-2013, 09:23 PM   #94
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
Are you good at soldering? That's most of it soldering the maestro harness to the Kenwood harness.

Removing and installing the radios is simple.
timle8n1 is offline   Reply With Quote
Old 12-13-2013, 11:05 PM   #95
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
Quote:
Originally Posted by timle8n1 View Post
Are you good at soldering? That's most of it soldering the maestro harness to the Kenwood harness.

Removing and installing the radios is simple.
Does the solder damage the copper wiring at all when you melt it on? Does it effect conductivity? You recommend soldering and then wrapping with electric tape?

How hard is it to do the soldering to the OBDII part? Easy to get to?
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Old 12-13-2013, 11:15 PM   #96
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by CHIZ_65 View Post
Does the solder damage the copper wiring at all when you melt it on? Does it effect conductivity? You recommend soldering and then wrapping with electric tape?

How hard is it to do the soldering to the OBDII part? Easy to get to?

Very easy. Just pull it down and pull off some of the cloth tape and splice it into the white and blue/white wire. Maestro explains the color code in their instructions.
Capn__Morgan is offline   Reply With Quote
Old 12-14-2013, 12:27 PM   #97
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
Quote:
Originally Posted by Capn__Morgan View Post
Very easy. Just pull it down and pull off some of the cloth tape and splice it into the white and blue/white wire. Maestro explains the color code in their instructions.
Hey Capn, any issues with tuning in to radio stations? Is the DNX good to go or do i need to buy that adapter to make the stock antenna work?
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Old 12-14-2013, 01:55 PM   #98
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by CHIZ_65 View Post
Hey Capn, any issues with tuning in to radio stations? Is the DNX good to go or do i need to buy that adapter to make the stock antenna work?

You'll need an adapter. This should work. http://www.crutchfield.com/p_12040CR...a-Adapter.html
Capn__Morgan is offline   Reply With Quote
Old 12-14-2013, 05:14 PM   #99
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
Alright, the order has been placed! I got everything for $890 with free shipping. I called and went through a performance shop out of Vegas who also happen to be Kenwood distributors.

$529 -DNX890HD ...Its factory refurbished, but they're hand choosing the cleanest/best one for me and updating all the software, etc. before shipping..w/ 6 mo. warranty.
$227 - Maestro ADS MUS1 dash kit
$132 - Maestro MRR module (I told the guy I don't own a PC computer, so they are going to open it and update/program it with the DNX for my car before they ship it...) Score!


And I just picked up that Antenna Adapter for like $4 on Ebay. I'll keep you guys posted on how the install goes.
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Old 12-14-2013, 06:05 PM   #100
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by CHIZ_65 View Post
Alright, the order has been placed! I got everything for $890 with free shipping. I called and went through a performance shop out of Vegas who also happen to be Kenwood distributors.

$529 -DNX890HD ...Its factory refurbished, but they're hand choosing the cleanest/best one for me and updating all the software, etc. before shipping..w/ 6 mo. warranty.
$227 - Maestro ADS MUS1 dash kit
$132 - Maestro MRR module (I told the guy I don't own a PC computer, so they are going to open it and update/program it with the DNX for my car before they ship it...) Score!


And I just picked up that Antenna Adapter for like $4 on Ebay. I'll keep you guys posted on how the install goes.

Did you get it from 702 Motorsports??
Capn__Morgan is offline   Reply With Quote
Old 12-14-2013, 06:15 PM   #101
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by Capn__Morgan View Post
Did you get it from 702 Motorsports??

Also they'll need the serial number off the DNX unit for the proper update on the MRR module. So...you might run into a bit of a snag there...just a heads up
Capn__Morgan is offline   Reply With Quote
Old 12-14-2013, 06:36 PM   #102
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
Quote:
Originally Posted by Capn__Morgan View Post
Also they'll need the serial number off the DNX unit for the proper update on the MRR module. So...you might run into a bit of a snag there...just a heads up
Yeah, 702 Motorsports. Found them on EBAY but I dealt with them outside of EBAY. Found their website and called them directly. They are definitely going to match the serial # from the DNX they chose to the MRR for me before they send it out.

http://www.702motoring.com/
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Old 12-14-2013, 06:45 PM   #103
Registered Member
Regular
 
timle8n1's Avatar
 
Join Date: Nov 2013
Location: St Augustine
Region: Florida
Posts: 57
I don't have a PC either, I use a Mac. However borrow from a friend or run a VM. There are lots of options to choose in programming the buttons. It's nice to be able to reprogram until you get just what you want.
timle8n1 is offline   Reply With Quote
Old 12-14-2013, 06:59 PM   #104
Registered Member
Regular
 
Capn__Morgan's Avatar
 
Join Date: May 2013
Location: Smithsburg
Region: Maryland
Posts: 215
Quote:
Originally Posted by CHIZ_65 View Post
Yeah, 702 Motorsports. Found them on EBAY but I dealt with them outside of EBAY. Found their website and called them directly. They are definitely going to match the serial # from the DNX they chose to the MRR for me before they send it out.

http://www.702motoring.com/

Yupp. I got mine refurbed from there too. Paul is a super guy. First one I got was damaged in shipping (as you can tell from the earlier posts) but Paul worked with me from start to finish to get me everything. Stand up guy. You'll be happy.
Capn__Morgan is offline   Reply With Quote
Old 12-14-2013, 07:29 PM   #105
Registered Member
Regular
 
CHIZ_65's Avatar
 
Join Date: Dec 2013
Location: Los Angeles
Region: California
Posts: 34
Quote:
Originally Posted by Capn__Morgan View Post
Yupp. I got mine refurbed from there too. Paul is a super guy. First one I got was damaged in shipping (as you can tell from the earlier posts) but Paul worked with me from start to finish to get me everything. Stand up guy. You'll be happy.
haha that's awesome. I just hung up with Paul. He was just finishing up flashing the module and just wanted to confirm that I was bone-stock (no amp, etc..) before doing so. And he told me that the box would be packed and ready to ship before he leaves tonight. Super great customer service thus far. ...Glad to hear I'm not the only guy running a refurb. lol ....Stupid to pay over $1K for something half the price and just as good!
__________________
-2011 GT , 6AT, 3.73 FRPP Gears, Bassani Longtubes, Bassani HiFlo cats, Bassani Cat-Back Xhaust, BOSS 302 Intake, Steeda BOSS 101mm CAI, BBK85mm TB, Eibach Pro Shocks/Struts/Springs, BMR LCAs, UPR Relo. Brackets..
-1965 FB 2+2 , 289 4bbl Edlebrock Performance, Raven Exhaust..
CHIZ_65 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:05 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.