Sub install with Stock stereo, Help please. - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-03-2009, 11:26 PM   #1
Registered Member
Regular
 
Renegade 800's Avatar
 
Join Date: Jun 2008
Region: Idaho
Posts: 45
Sub install with Stock stereo, Help please.

I installed an amp and sub and I used the High level inputs on the amp. The problem is when power is turned on there is a loud "Thump" Also when I hit the brakes and use the turn signals. I tried a line level converter and used the RCA inputs and it does the same. It is really annoying. I unplugged the sub for now. I am sure the amp has a good ground so I am at a loss. The converter is a cheap one so maybe I will buy a better one. I don’t know what else to do. Any thoughts?

I am not sure what stock radio I have. I think there is an amp under the CD player. No sound from the radio with out the CD player plugged in. 2000 Model with the split radio/CD Player.
Renegade 800 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2009, 07:01 AM   #2
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: Sub install with Stock stereo, Help please.

In my 2001, the sub would make a "thump" when the amp was turned on. I just chalked it up to a small surge of power going through the amp and into the sub. The sub will react to an electrical signal it gets. It also happened every time I shut the amp off.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 02-04-2009, 04:44 PM   #3
Registered Member
Regular
 
Renegade 800's Avatar
 
Join Date: Jun 2008
Region: Idaho
Posts: 45
Re: Sub install with Stock stereo, Help please.

I can deal with the turn on and off thump, it is the brake and turn signal that is driving me crazy.
Renegade 800 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2009, 04:54 PM   #4
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: Sub install with Stock stereo, Help please.

Are you using a FM modulator to run the amp? Also, are you running the RCA's and power wires on the same side of the car or relatively close to each other?
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 02-04-2009, 05:13 PM   #5
Registered Member
Regular
 
Join Date: Apr 2007
Region: Alabama
Posts: 201
Re: Sub install with Stock stereo, Help please.

It sounds like a bad ground somewhere to me. Low is right in that if you use low quality RCA cables and run them along side power wires, noise will bleed into them, but it sounds like you aren't running RCA cables at all now.

I'd check the grounds, on everything, the amp, the factory stuff, hell the battery under the hood. What amp/sub are you running anyways?
ThaWill is offline   Reply With Quote
Old 02-04-2009, 05:56 PM   #6
Registered Member
Regular
 
Renegade 800's Avatar
 
Join Date: Jun 2008
Region: Idaho
Posts: 45
Re: Sub install with Stock stereo, Help please.

Correct I am not running RCA’s at the moment. I did run the Power on the driver’s side. The remote turn on is coming off the power from the radio and is running down the middle under the carpet. I did run Some RCA for the future when I get a replacement deck on the left side of the car.

The amp and sub is a lightning audio set up, I got It new for $90. I am on a budget, I wasn't even going to get a sub until I ran across this.Lightning Audio® : Product Details

There is no thump when I unplug the inputs. It does sound like a bad ground to me also. I will check them again.
Renegade 800 is offline   Reply With Quote
Old 02-04-2009, 05:59 PM   #7
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: Sub install with Stock stereo, Help please.

I would recommend getting an FM modulator and tapping into the rear speakers to get your input, that will help clear up sound.

Also, make sure the amp is securely grounded. I ended up tapping a new spot behind the carpet on the driver side in the trunk and grounding my system that way in my last mustang. Never had a problem with it.

Take some sand paper and get it down to bare metal beforehand.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 02-04-2009, 09:44 PM   #8
Registered Member
Regular
 
Renegade 800's Avatar
 
Join Date: Jun 2008
Region: Idaho
Posts: 45
Re: Sub install with Stock stereo, Help please.

FM Modulator? I am not trying to hook up an Ipod. Do you mean one of these?
Scosche Factory OEM Interfaces Hi/Lo Line Level Interfaces SPKR LEVEL CONV 80W at Scosche.com
Renegade 800 is offline   Reply With Quote
Old 02-05-2009, 06:35 PM   #9
Registered Member
Regular
 
DaDant!'s Avatar
 
Join Date: Nov 2008
Region: North Carolina
Posts: 329
Re: Sub install with Stock stereo, Help please.

this should help
fm modulator - Google Product Search

edit. fm modulators are used for factory headunits that do not have RCA output. basicly it is used to send the signal to the amp where otherwise you could not w/o the RCA. to sum it up it is an adapter. (if i am wrong some one will not hesitate to correct me)
__________________
]
00 gt:u.d. pulleys, K&N CAI, UPR O/R X-pipe, Flowmaster 40 tips

im getting there.
.
DaDant! is offline   Reply With Quote
Old 02-05-2009, 08:23 PM   #10
Registered Member
Regular
 
Renegade 800's Avatar
 
Join Date: Jun 2008
Region: Idaho
Posts: 45
Re: Sub install with Stock stereo, Help please.

The FM modulator is for RCA "Input" Not Out. I bought the Scosche line converter I posted above and that did the trick.
Renegade 800 is offline   Reply With Quote
Old 02-05-2009, 11:04 PM   #11
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Re: Sub install with Stock stereo, Help please.

I dunno why I have FM modulator stuck in my mind. I started looking it up last night and my neighbor's internet died....
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 02-06-2009, 11:00 AM   #12
Registered Member
Regular
 
DaDant!'s Avatar
 
Join Date: Nov 2008
Region: North Carolina
Posts: 329
Re: Sub install with Stock stereo, Help please.

congrats.
__________________
]
00 gt:u.d. pulleys, K&N CAI, UPR O/R X-pipe, Flowmaster 40 tips

im getting there.
.
DaDant! is offline   Reply With Quote
Old 03-22-2009, 10:42 PM   #13
Registered Member
Regular
 
upton7's Avatar
 
Join Date: Jan 2009
Region: Illinois
Posts: 1,756
Re: Sub install with Stock stereo, Help please.

i had a thump thing goin on in my 01 i got a new cd player and it worked fine oh
upton7 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang Audio & Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help asap with Stereo install Scorpion1 Pre-2005 V6 Mustang 13 07-10-2008 02:34 AM
2001 gt mach stereo sub & amp install gwilkrrs Mustang Audio & Video 2 07-08-2008 07:09 PM
Complete Stereo Install! onetwin69 Mustang Audio & Video 2 03-27-2007 08:36 AM
2000 mustang stereo install?? stang00 Mustang Audio & Video 11 01-03-2006 03:28 AM
How to on stereo install lowflyn Pre-2005 V6 Mustang 4 11-13-2003 07:43 PM

» Like Us On Facebook



02:19 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.