Hi! 99-01 SVT cobra high beam problems (Australia) - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > New Member Introductions & Greetings



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-31-2014, 10:31 PM   #1
Registered User
Newbie
 
Join Date: Aug 2014
Location: Melbourne
Region: Australia
Posts: 8
Hi! 99-01 SVT cobra high beam problems (Australia)

High Beam doesn't work. Could someone please give some direction? Fuses ok, globes ok, low beam and driving lights ok. High beam indicator light on dash works but not the High Beams.
When I flick to High Beams all forward lights go out.
It may be the Circuit breaker but I don't know where it is or how to test it.
ozcobra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-31-2014, 11:58 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,418
Greetings Mate!

We'd be happy to help you with your lighting problem. I have a couple of ideas of where to look next and I'm sure that the other guys do as well.
You've posted your question in the wrong forum though.
Why don't you start a new thread in the 96-04 Mustang GT technical forum and we'll see if we can figure out the problem.
straybullitt is offline   Reply With Quote
Old 09-01-2014, 12:12 AM   #3
Registered User
Newbie
 
Join Date: Aug 2014
Location: Melbourne
Region: Australia
Posts: 8
Thank you

Thanks for your response and direction.
ozcobra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-01-2014, 12:21 AM   #4
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,418
Not a problem.
The "powers that be" on this website don't like to clutter up this forum with technical threads. You'll get a better response in the technical forum.

You surely don't want to, solely, rely on my advice.
straybullitt is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > New Member Introductions & Greetings

Tags
svt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Drivers side high beam doesn't turn on 1997mustanggt 1996-2004 Mustang GT 8 10-25-2013 10:21 PM
HID High Beam issue zinc_yellow 1996-2004 Mustang GT 6 03-19-2013 01:06 PM
2001 SVT Cobra :: 2001 Ford SVT Cobra 98StangKid Member Garages 0 06-22-2012 04:49 PM
FS High beam fog light kit! SerbStang Mustang Parts for Sale and Wanted 13 10-13-2011 04:05 PM
Left low beam headlight wont work but i will when i turn on high beams p1blake04 1996-2004 Mustang GT 4 09-05-2011 11:30 PM

» Like Us On Facebook



10:40 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.