CEL/Problems - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-04-2009, 03:25 PM   #1
Registered User
Newbie
 
Join Date: Oct 2009
Posts: 2
CEL/Problems

So, I just recently purchased this stang. A couple of weeks ago, it threw a CEL I think because I accidently filled up with 93. I had the codes read and it said:

P0506 Idle lower than expected
P0420 Catalyst System Bank Efficiency below Threshold - Bank No 1.
P0430 Catalyst System Bank Efficiency below Threshold - Bank No 2.


So I cleared the codes and they did not come back for a couple of weeks, I attributed it to the gas. The other day they came back. Now....

Sometimes when i am stopped it will stall several times in a row and I have to hold on the gas to keep it started. Then other times it will run fine. I have been noticing the smell of gas at idle times (running rich?).

So today I was driving along, and I made the shift from 2-3. After I depressed the clutch, the engine started revving itself. Oddly enough, my foot was not on the gas, cruise nothing was on. I put it into gear and let the clutch out and it drove itself. Very odd and scary, felt like the gas pedal was stuck, but it wasn't. After a minute or two it stopped.


I could start with the 02 sensors, which some suggested on other forums, but which 02 sensor is it?


Any other ideas?
05torch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2009, 01:49 AM   #2
Registered Member
Regular
 
2007STANG's Avatar
 
Join Date: Mar 2009
Region: West Virgina
Posts: 295
Re: CEL/Problems

I'm thinking clean the MAF
__________________
Billet fuel door, Daiblo 91 Tune, Xenon ram air hood scoop, MAC performance direct fit headers, 3" 304 SS Dual exhaust, hood pin appearance kit, Red l.E.D. underbody lights, Boy Racer rear wing, Helix power tower plus Throttle body spacer, ventvisor deflector, Aeroform chin spoiler, SVT 18" 9.5 45/255 frount SVT 18" 9.5 40/285 rear trire , GTO rear blackout kit, OEM rear splash guards, Steeda CAI, 8.8 rear axle with 3.73.1 LSD, killer Glass Hose, Smoked Window Louvers by GT Styling 35% Tenting on rear and side windows.
2007STANG is offline   Reply With Quote
Old 10-05-2009, 02:03 AM   #3
Registered User
Newbie
 
Join Date: Oct 2009
Posts: 2
Re: CEL/Problems

Do you think a dirty MAF could throw all three of those codes?
05torch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2009, 02:05 AM   #4
Registered Member
Regular
 
OsirisGuy's Avatar
 
Join Date: Jun 2007
Location: New York
Region: New York
Posts: 1,262
Send a message via AIM to OsirisGuy
Re: CEL/Problems

Well first start figuring out why the idle is so low. What RPMs are you idling at? Cleaning the MAF could help.

Since you have both Bank 1 and Bank 2 codes, ones on passenger side one's the driver side. I don't know off the top of my head if it's the first set or second set but I would guess it's the set after the Cats. If I think about it hard though I change my mind to the set before the cats though.

Sorry for not really helping.
__________________
Quote:
Originally Posted by MetallicMist View Post
OsirisGuy is correct
Quote:
Originally Posted by stangaroo View Post
OsirisGuy is right
2002 Mustang GT

BBK CAI - Flowmaster Catbacks - Pro 5.0 Shifter
OsirisGuy is offline   Reply With Quote
Old 10-05-2009, 02:07 AM   #5
Registered Member
Regular
 
2007STANG's Avatar
 
Join Date: Mar 2009
Region: West Virgina
Posts: 295
Re: CEL/Problems

it sounds like its running rich to me
__________________
Billet fuel door, Daiblo 91 Tune, Xenon ram air hood scoop, MAC performance direct fit headers, 3" 304 SS Dual exhaust, hood pin appearance kit, Red l.E.D. underbody lights, Boy Racer rear wing, Helix power tower plus Throttle body spacer, ventvisor deflector, Aeroform chin spoiler, SVT 18" 9.5 45/255 frount SVT 18" 9.5 40/285 rear trire , GTO rear blackout kit, OEM rear splash guards, Steeda CAI, 8.8 rear axle with 3.73.1 LSD, killer Glass Hose, Smoked Window Louvers by GT Styling 35% Tenting on rear and side windows.
2007STANG is offline   Reply With Quote
Old 10-05-2009, 02:11 AM   #6
Registered Member
Regular
 
OsirisGuy's Avatar
 
Join Date: Jun 2007
Location: New York
Region: New York
Posts: 1,262
Send a message via AIM to OsirisGuy
Re: CEL/Problems

Scratch that last post (my post). The codes get thrown involving both O2 sensors. Here's some info:
OBD-II Trouble Code: P0420 Catalyst System Efficiency Below Threshold (Bank 1)

Looking at this does your car have Cats? If not that is your problem. If you do have Cats they might be bad. Did the car have to pass an emissions test?

Basically what's going on is the the Downstream sensors (second set/after Cats) are reading the same chemical emissions as the Upstream sensors (first set/before Cats).

Of course the problem could still be the O2 sensors, and might include any of them, but most likely it might be something else.
__________________
Quote:
Originally Posted by MetallicMist View Post
OsirisGuy is correct
Quote:
Originally Posted by stangaroo View Post
OsirisGuy is right
2002 Mustang GT

BBK CAI - Flowmaster Catbacks - Pro 5.0 Shifter
OsirisGuy is offline   Reply With Quote
Old 11-15-2009, 08:25 PM   #7
Registered User
Newbie
 
Join Date: Oct 2009
Region: Maryland
Posts: 18
Re: CEL/Problems

93 octane by itself..certainly 1 tank only won't hurt your car...
billr814 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cel help saleenman 1996-2004 Mustang GT 4 10-23-2009 10:19 PM
P0442 and P0456PD CEL OsirisGuy 1996-2004 Mustang GT 4 09-01-2009 12:57 PM
CEL now on... p1520? jimmy_beaner 1996-2004 Mustang GT 7 04-01-2008 02:04 PM
hey I have a CEL that.... Fishers Stang 1996-2004 Mustang GT 11 07-03-2005 11:14 AM
new 02 sensor but still CEL??!! a1yola Pre-2005 V6 Mustang 9 12-06-2003 05:53 AM

» Like Us On Facebook



11:53 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.