Clutch problems..... - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-31-2011, 03:25 PM   #1
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
Clutch problems.....

I was drivin down the road the other day, another car ran me off the road and I went into some sand. didn't get stuck but right away my clutch starte to feel weird. Later on that day I went to go drive my car and it was almost impossible to get into gear when I was goin down the road. I turned around jacked up the car and check everything and all Seemed to be good. I pressed an released the clutch about ten times and tried again and it worked. But now at high rpm it's kinda hard to shift. Any suggestions?......
Gibby is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-31-2011, 03:33 PM   #2
Road Trip!
 
Join Date: Apr 2011
Region: Texas
Posts: 2,223
Send a message via Skype™ to Texastboneking
Re: Clutch problems.....

Quote:
Originally Posted by Gibby View Post
I was drivin down the road the other day, another car ran me off the road and I went into some sand. didn't get stuck but right away my clutch starte to feel weird. Later on that day I went to go drive my car and it was almost impossible to get into gear when I was goin down the road. I turned around jacked up the car and check everything and all Seemed to be good. I pressed an released the clutch about ten times and tried again and it worked. But now at high rpm it's kinda hard to shift. Any suggestions?......
weird problem, first think i might look at is take the shift boot out and make sure there aint sand sitting around the shifter. just a guess...

i dont see how sand should effect the clutch or the tranny
Texastboneking is offline   Reply With Quote
Old 05-31-2011, 03:49 PM   #3
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
Well I thought sand may have gotten in the tranny through the inspection hole. The s197 isn't a drop in shifter its a linkage. So I'm baffled. : /
Gibby is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-31-2011, 03:53 PM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Texas
Posts: 2,223
Send a message via Skype™ to Texastboneking
Re: Clutch problems.....

Quote:
Originally Posted by Gibby View Post
Well I thought sand may have gotten in the tranny through the inspection hole. The s197 isn't a drop in shifter its a linkage. So I'm baffled. : /
well the transmission is sealed for the most part. sand shouldnt be able to get in it.
Texastboneking is offline   Reply With Quote
Old 05-31-2011, 03:57 PM   #5
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
The tranny is sealed but the bell housing has inspection holes. I thought maybe some sand got up in the clutch or some ****. Hell I don't know. Ive been wanting to buy an after market clutch and flywheel anyways so I'm gonna do that and see if I can't see anything.
Gibby is offline   Reply With Quote
Old 05-31-2011, 04:00 PM   #6
Road Trip!
 
Join Date: Apr 2011
Region: Texas
Posts: 2,223
Send a message via Skype™ to Texastboneking
Re: Clutch problems.....

Quote:
Originally Posted by Gibby View Post
The tranny is sealed but the bell housing has inspection holes. I thought maybe some sand got up in the clutch or some ****. Hell I don't know. Ive been wanting to buy an after market clutch and flywheel anyways so I'm gonna do that and see if I can't see anything.
lol my bad. when you stated it was hard to shift i thought you ment the shifter was tight and hard to get into the gears. you mean the clutch is hard to press. yes you probably got sand in there
Texastboneking is offline   Reply With Quote
Old 05-31-2011, 04:07 PM   #7
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
The clutch pretty much feels the same, but it's hard to get into gear at high rpm.
Gibby is offline   Reply With Quote
Old 05-31-2011, 04:21 PM   #8
Road Trip!
 
Join Date: Apr 2011
Region: Texas
Posts: 2,223
Send a message via Skype™ to Texastboneking
Re: Clutch problems.....

Quote:
Originally Posted by Gibby View Post
The clutch pretty much feels the same, but it's hard to get into gear at high rpm.
sounds like its time to pull the tranny and inspect...
Texastboneking is offline   Reply With Quote
Old 05-31-2011, 04:34 PM   #9
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
Yea. Bad thing is it's my DD and I have no other car. Soo I'll have to wait till the weekend.
Gibby is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new clutch problems nasty99 1996-2004 Mustang GT 14 03-10-2011 04:04 PM
clutch engagement problems 1996v6stang Pre-2005 V6 Mustang 11 05-19-2010 09:31 AM
2006 Mustang clutch problems brokenford Pre-2005 V6 Mustang 1 03-18-2008 01:48 PM
clutch? roach 1996-2004 Mustang GT 5 03-23-2007 02:58 PM
Using a used clutch? Tbird232ci Pre-2005 V6 Mustang 2 01-16-2004 08:24 PM

» Like Us On Facebook



11:27 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.