Make Ford recall these problems!!! ...800-392-3673 - Page 2 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-19-2013, 08:44 PM   #36
Registered User
Newbie
 
Join Date: Jan 2013
Location: Lakewood
Region: Washington
Posts: 5
My driver door handle wont stay in, and when I bought it used from the dealer, I made them put a new shaker 500 system in it because it wouldnt play cd's
kahmymillz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2013, 04:29 PM   #37
Registered Member
Regular
 
StangReaper's Avatar
 
Join Date: Apr 2013
Location: Centralia
Region: Washington
Posts: 66
Does anyone have a link or list of current recalls for these years? My '06 is having all sorts of electrical issues.
StangReaper is offline   Reply With Quote
Old 04-13-2013, 08:54 PM   #38
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by StangReaper
Does anyone have a link or list of current recalls for these years? My '06 is having all sorts of electrical issues.
Hopefully you didn't get it from the east coast
tc x 4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2013, 10:08 PM   #39
Registered Member
Regular
 
StangReaper's Avatar
 
Join Date: Apr 2013
Location: Centralia
Region: Washington
Posts: 66
Nope West Coast
StangReaper is offline   Reply With Quote
Old 04-16-2013, 10:06 AM   #40
Registered User
Newbie
 
Join Date: Apr 2013
Location: Greensboro
Region: North Carolina
Posts: 1
At 50k miles the alternator in my 05' shot as well as the driver door actuator all at the same time other than that no issues except a clutch replacement to a stage 2 exedy havnt had a problem since but the alternator issues have been more prominent mine was actually surging for weeks before it just died one day
silentstang is offline   Reply With Quote
Old 04-17-2013, 12:06 PM   #41
Registered Member
Regular
 
StangReaper's Avatar
 
Join Date: Apr 2013
Location: Centralia
Region: Washington
Posts: 66
My '06 GT with 65k miles is has been an electrical nightmare. Passenger side door actuator doesn't work, my flashers won't turn on, the rear defrost element came off but I had that fixed, passenger side airbag sensor issue, I have that fuel tank filling problem, and my car always says to check charging system (probably the alternator) and last but not least I have had to replace 3 batteries in 4 years. Wish ford would fix them for free.
StangReaper is offline   Reply With Quote
Old 04-17-2013, 12:31 PM   #42
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Lol, you people crack me up. You guys have 4-9 year old cars and expect them to have no issues. Things break and wear out...part of it.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 04-17-2013, 01:51 PM   #43
Registered Member
Regular
 
StangReaper's Avatar
 
Join Date: Apr 2013
Location: Centralia
Region: Washington
Posts: 66
We don't expect them to not have problems, obviously like you said some are almost 9 years old. This thread is for comparing problems we all seem to have and whether or not the dealer will take care of them.
StangReaper is offline   Reply With Quote
Old 04-17-2013, 03:16 PM   #44
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by lowflyn View Post
Lol, you people crack me up. You guys have 4-9 year old cars and expect them to have no issues. Things break and wear out...part of it.
Well a car might be 9 yrs old but only having 50k miles I don't think any problems should be there
Terminator is offline   Reply With Quote
Old 04-17-2013, 04:44 PM   #45
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
My 03 cobra has 40k miles and 04 gt has 50k miles. I expect to replace things with that age. Mileage is only part of the equation.
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 05-18-2013, 07:02 PM   #46
Registered User
Newbie
 
Les 05GT's Avatar
 
Join Date: Jan 2013
Location: Franklinville
Region: New Jersey
Posts: 6
Yeah my alternator was a problem on my 2005 GT, it made my check engine light show a cam sensor code. After changing the sensor twice I did some research and found that around 05 mustangs have a notorious problem for this an many other electrical problems, good post I support.

---------- Post added at 07:02 PM ---------- Previous post was at 06:59 PM ----------

Quote:
Originally Posted by Les 05GT View Post
Yeah my alternator was a problem on my 2005 GT, it made my check engine light show a cam sensor code. After changing the sensor twice I did some research and found that around 05 mustangs have a notorious problem for this an many other electrical problems, good post I support.
Oh and of course I have the fuel tank problem whenever I get gas it always clicks off numerous times no matter what I try
Les 05GT is offline   Reply With Quote
Old 05-18-2013, 07:06 PM   #47
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by Les 05GT View Post
Yeah my alternator was a problem on my 2005 GT, it made my check engine light show a cam sensor code. After changing the sensor twice I did some research and found that around 05 mustangs have a notorious problem for this an many other electrical problems, good post I support.

---------- Post added at 07:02 PM ---------- Previous post was at 06:59 PM ----------



Oh and of course I have the fuel tank problem whenever I get gas it always clicks off numerous times no matter what I try
Just tilt the nozzle 90' deg. an it should pump gas without any issues
Terminator is offline   Reply With Quote
Old 05-18-2013, 07:11 PM   #48
Registered Member
Regular
 
Black on Boss's Avatar
 
Join Date: Nov 2012
Location: Perry, GA
Region: Georgia
Posts: 7,204
Quote:
Originally Posted by lowflyn View Post
My 03 cobra has 40k miles and 04 gt has 50k miles. I expect to replace things with that age. Mileage is only part of the equation.
Drive them cars son
Black on Boss is offline   Reply With Quote
Old 05-22-2013, 08:18 PM   #49
Registered Member
Regular
 
gladiatoro's Avatar
 
Join Date: Jul 2008
Location: Kelowna BC
Region: Canada
Posts: 771
Quote:
Originally Posted by 99ford View Post
If you were going to buy a new car today, I would say you are wasting money by not buying a Ford. They cost less than Toyota and Honda and are just as reliable.
gladiatoro is offline   Reply With Quote
Old 05-22-2013, 09:55 PM   #50
Registered Member
Regular
 
Join Date: Apr 2013
Location: Sewalls Point
Region: Florida
Posts: 21
Quote:
Originally Posted by Terminator View Post

Just tilt the nozzle 90' deg. an it should pump gas without any issues
My 05GT PARKED right now.,Engine light constant on. Blown alternators et all. AutoZone code reader said cam sensors. Tried theirs and AdvancedAuto. No fix.

Now someone says special tool for left bank cam adjustment. Always Ford owner. 46 coupe, 50 club coupe, 64 1/2 289 fast back.
I said my new 05GT WOULD BE my last new ride. I'm 76 and pretty sick, so is my friggin GT!!

PS, first time alternator shut down all electrics, had to get towed to dealer Advantage Ford. Also gas gauge read upside down!
Dealer said change whole cluster 800$!
I said no way. Found garage that changed gas gauge motor (wheel?) it worked for 200$.
CRASHG63 is offline   Reply With Quote
Old 05-23-2013, 12:17 AM   #51
Registered Member
Regular
 
Join Date: Apr 2013
Location: Sewalls Point
Region: Florida
Posts: 21
Quote:
Originally Posted by lowflyn View Post
Lol, you people crack me up. You guys have 4-9 year old cars and expect them to have no issues. Things break and wear out...part of it.
Things break, no ****! Engine lights on forever and blown alternators, on my 3rd alternator., my rides w/no problems,
46 ford coupe, 50 Ford coupe, 64 1/2 289 fastback. 49 Chevy , DeSoto Firedome v8, 90 Camaro convert RS 131k, still drive it 131,000k NO ISSUES, new paint new top.

05GT a friggin nightmare.
CRASHG63 is offline   Reply With Quote
Old 05-27-2013, 11:55 AM   #52
Registered Member
Regular
 
trejo_03's Avatar
 
Join Date: May 2012
Region: Texas
Posts: 142
Quote:
Originally Posted by stangless74 View Post
I was actually considering purchasing a used 07- just came across one yesterday.... this doesn't help my decision any I guess. Interesting posts-
I'm pretty sure you would be safe if it was late 07 by 06 the changed up theses mustangs if you go to buy parts some websites will say 05-06 or 07-09 I just got me an 08 and I love it 2nd mustang my first was an 03 gt
trejo_03 is offline   Reply With Quote
Old 06-21-2013, 01:44 PM   #53
Registered User
Newbie
 
Join Date: Jun 2013
Location: Baton Rouge
Region: Louisiana
Posts: 1
Unglued side door panels

The leather look side door panels have come unglued in this Louisiana heat. I fixed the panels using carpet tape but that only lasted about 6 months. Any suggestions?

---------- Post added at 01:44 PM ---------- Previous post was at 01:39 PM ----------

Looking for a tan leather drivers seat for a 2007 Mustang. Mine is all torn up and I would like to replace it
Cherelle is offline   Reply With Quote
Old 06-22-2013, 12:47 AM   #54
Registered Member
Regular
 
Join Date: Apr 2013
Location: Sewalls Point
Region: Florida
Posts: 21
Cherelle: my door panel re-do came out great/fantastic! As soon as I figure out how to upload pics here will do.
CRASHG63 is offline   Reply With Quote
Old 07-11-2013, 09:10 PM   #55
Registered User
Newbie
 
army05GT's Avatar
 
Join Date: Mar 2013
Location: junction city
Region: Kansas
Posts: 7
I've had my 05 for a few months now and
I had my shifter assy. Replaced (under warranty) a month ago.

Back inshop now for... diff seal leak, front struts, and my instrument cluster.

However my cluster issue is different then what I've read here, mine is with the blinker arrows the left arrow flashes normal, the right flashes like its on crack!!!! I'm talking like 200 blinks per min.
army05GT is offline   Reply With Quote
Old 07-19-2013, 11:20 AM   #56
Registered Member
Regular
 
Join Date: Jul 2013
Location: Raleigh
Region: North Carolina
Posts: 50
Yeah i would go ahead and call them up. sounds like you need to get those parts changed
ErikMustang is offline   Reply With Quote
Old 10-13-2013, 02:21 AM   #57
Registered User
Newbie
 
Ken2162007's Avatar
 
Join Date: Oct 2013
Location: Mobile
Region: Alabama
Posts: 7
Quote:
Originally Posted by Cherelle View Post
The leather look side door panels have come unglued in this Louisiana heat. I fixed the panels using carpet tape but that only lasted about 6 months. Any suggestions? ---------- Post added at 01:44 PM ---------- Previous post was at 01:39 PM ---------- Looking for a tan leather drivers seat for a 2007 Mustang. Mine is all torn up and I would like to replace it
My 07 did the same here in Alabama heat! I used liquid nail!
Ken2162007 is offline   Reply With Quote
Old 10-13-2013, 02:28 AM   #58
Registered User
Newbie
 
Ken2162007's Avatar
 
Join Date: Oct 2013
Location: Mobile
Region: Alabama
Posts: 7
Quote:
Originally Posted by trejo_03 View Post
I'm pretty sure you would be safe if it was late 07 by 06 the changed up theses mustangs if you go to buy parts some websites will say 05-06 or 07-09 I just got me an 08 and I love it 2nd mustang my first was an 03 gt
I think they worked the bugs out in 05-06 models and had a great production car from 07-10!
Ken2162007 is offline   Reply With Quote
Old 10-20-2013, 06:55 AM   #59
Registered Member
Regular
 
nunjabusiness's Avatar
 
Join Date: Feb 2013
Location: LA (Lower Alabama)
Region: Alabama
Posts: 38
Quote:
Originally Posted by army05GT View Post
I've had my 05 for a few months now and
I had my shifter assy. Replaced (under warranty) a month ago.

Back inshop now for... diff seal leak, front struts, and my instrument cluster.

However my cluster issue is different then what I've read here, mine is with the blinker arrows the left arrow flashes normal, the right flashes like its on crack!!!! I'm talking like 200 blinks per min.
I assume you have figured this out within the last three months, but in case anyone else reads this:
That behavior is by design to tell you that a bulb is failing on the right side circuit.
Mine does exactly the same. Replace faulty bulb and problem is solved.
nunjabusiness is offline   Reply With Quote
Old 11-04-2013, 09:57 PM   #60
Registered User
Newbie
 
Join Date: Mar 2013
Location: Warwick
Region: Rhode Island
Posts: 2
Ok, I have a 06 gt convertible. Bought it new. Problems, gas tank problem, oil pump failure and alternator dying. What I did was after my oil pump blew and destroyed my heads I rebuilt the motor using ford racing parts. Cynic ported heads ford racing cam throttle body manifold etc. cost me a lot but I love this car now and with the rebuilt engine I love it. I have no end gone issues now. I did have alternator issues so instead of buying and replacing rebuilt alternators I got a paperformance alternator which is lifetime so if it dies they replace it. You can buy me from one of the site sponsors, trust me for the extra money it's worth it plus the car runs so much smoother with it as it is strong as heck. You think an alternator would not make a difference but trust me it does. A rebuilt one cost around 150 and up a paperformance cost 300 they even powder coat them too for extra. We'll worth it. Also if you got an 06 mustang replace that oil pump as it has happened to a bunch of 06. Of course my blew 2000 miles after my 100k warranty expired.

---------- Post added at 10:57 PM ---------- Previous post was at 10:54 PM ----------

Sorry hit the send button before I checked spelling and such. I also have my right window go back down when I put it up. Drives me nuts.
Thomashogan640 is offline   Reply With Quote
Old 12-11-2013, 08:42 AM   #61
Registered User
Newbie
 
Join Date: Dec 2013
Location: Georgetown
Region: Kentucky
Posts: 1
2009 V6 issues

I have a 2009 Mustang and today the issues have started, the car only has 43,000 miles, was bought new (1st new car ever owned) and has been very well maintained. From what I am reading I am not happy, yesterday the "wrench" icon came on and the car completely "bogged" down on me and I am scared now at seeing it can be the Transmission?? Will it have to have a new one? What is the cost? I called Ford as well and was told there were no issues/recalls and they knew of nothing... Help......
LB2009 is offline   Reply With Quote
Old 12-11-2013, 08:58 AM   #62
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by LB2009 View Post
I have a 2009 Mustang and today the issues have started, the car only has 43,000 miles, was bought new (1st new car ever owned) and has been very well maintained. From what I am reading I am not happy, yesterday the "wrench" icon came on and the car completely "bogged" down on me and I am scared now at seeing it can be the Transmission?? Will it have to have a new one? What is the cost? I called Ford as well and was told there were no issues/recalls and they knew of nothing... Help......
Have you had the code read? it could be as simple as replacing the TPS sensor or an 02 sensor
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 12-11-2013, 08:59 AM   #63
Registered Member
Regular
 
nhcowboy's Avatar
 
Join Date: Jun 2011
Location: Houston
Region: Texas
Posts: 1,171
Quote:
Originally Posted by LB2009 View Post
I have a 2009 Mustang and today the issues have started, the car only has 43,000 miles, was bought new (1st new car ever owned) and has been very well maintained. From what I am reading I am not happy, yesterday the "wrench" icon came on and the car completely "bogged" down on me and I am scared now at seeing it can be the Transmission?? Will it have to have a new one? What is the cost? I called Ford as well and was told there were no issues/recalls and they knew of nothing... Help......
A wrench and the car going into limp mode can be hundreds if not thousands of things. I'm no psychic... Not is anyone else here. If the car is outside of warranty... You will have to pay. That how it works. Not every problem will demand a recall. Mechanical things (all) eventually fail. Doesn't matter how well maintained. Wear and tear of driving and it is a risk you take.

Take the car in. They can read the code. And tell you how much. If you think that is wrong.. Then start leasing vehicles ... That way you always have a shiny new car and full warranty.
__________________

2011 Black Mustang GT Premium
Corsa XO & Sport AB/Airaid/Bama 93R
Best 1/4 mile to date 60' 2.009
12.538 ET @112.33
100+ Deg 85 Hum RPR 3PM 1/2 tank street tires
nhcowboy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Mustang SVT Cobra Project yellow99 1979-1995 Mustang GT 0 09-03-2011 06:51 PM

» Like Us On Facebook



04:02 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.