Break fluid level low - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-19-2012, 07:58 PM   #1
Registered User
Newbie
 
Mr.Saleen005's Avatar
 
Join Date: Mar 2012
Region: Canada
Posts: 5
Break fluid level low

Hey guys first off great place for us mustang lovers keep up the good work. I have a small issue with my 2007 Saleen. My break fluid light comes on saying its low but it's at the right level. Sometimes it stays on for few minutes and sometimes for a day or two. Any advice? Does any one had a same thing happened to them?
Mr.Saleen005 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-19-2012, 08:37 PM   #2
Registered Member
Regular
 
RedGT's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 102
If its intermittent then it's probably a bad wire. Try jiggling the wire at different areas and seeing if the light comes on. That's the easiest way to find out. Could be the sensor itself too. That's where I would look first. Beyond that, maybe your fluid level is low and you didn't look at it properly.
RedGT is offline   Reply With Quote
Old 03-19-2012, 10:32 PM   #3
Registered User
Newbie
 
Mr.Saleen005's Avatar
 
Join Date: Mar 2012
Region: Canada
Posts: 5
Thanks for the advice RedGt. I'll start with the wires first tomorrow and If that doesn't work I guess ill be going to my mechanic. The fluid level is good , I've checked it more then ones and I was on a level ground as well. I'll keep you posted what happens.
Mr.Saleen005 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-20-2012, 05:55 AM   #4
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
I wouldn't take it to a mech unless he's a buddy of yours. As redgt said, check wires, then replace the sensors. Most , not all tho, mechanics are nothing more than parts changers, they change everything til they fix the prob at ur expense.
tc x 4 is offline   Reply With Quote
Old 03-20-2012, 07:21 AM   #5
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Does it come on over bumps and turns only? My old ford brake light would come on when I turn or hit a bump, turns out the fluid level was low even tho it was still at or above the mark, put alittle in and never happened again
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 03-20-2012, 08:53 AM   #6
Registered Member
Regular
 
RedGT's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 102
Quote:
Originally Posted by Mr.Saleen005
Thanks for the advice RedGt. I'll start with the wires first tomorrow and If that doesn't work I guess ill be going to my mechanic. The fluid level is good , I've checked it more then ones and I was on a level ground as well. I'll keep you posted what happens.
Keep in mind if it's a broken wire you might have to search a little. Also, most sensors work within a limit. So you could have a corroded wire as well. Don't throw a sensor at it just cuz you can't find a bad spot in the wires.
RedGT is offline   Reply With Quote
Old 03-20-2012, 09:33 PM   #7
Registered Member
Regular
 
SSC182's Avatar
 
Join Date: Sep 2011
Region: North Carolina
Posts: 131
Just unplug the sensor and if the light comes on and stays on the sensors good your problem is elsewhere. Or just take a voltmeter and check your voltage at the sensor. Also the red brake light is also for the parking brake so make sure those wires arnt loose or corroded either
SSC182 is offline   Reply With Quote
Old 04-02-2012, 09:18 AM   #8
Registered User
Newbie
 
Mr.Saleen005's Avatar
 
Join Date: Mar 2012
Region: Canada
Posts: 5
Thanks to all you guys for great advice. It was a lose wire n so far it's all good.
Mr.Saleen005 is offline   Reply With Quote
Old 04-02-2012, 10:49 AM   #9
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: Break fluid level low

you sure your fluid is not a bit low? If so you may have a little leak (probably where the line meets the caliper~)
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011+ 5.0 Mustang Low Oil Thread 04TRV6 2011-2014 Mustang GT 113 05-05-2014 08:25 PM
spring break svo The Bar 0 03-19-2012 10:21 AM
Low break fluid warning light Mr.Saleen005 Saleen & SMS Mustang 0 03-17-2012 06:44 PM
302 break in fordracing63857 1979-1995 Mustang GT 3 03-17-2012 09:47 AM
Are low riders making a comeback? Project Pony The Bar 9 03-15-2012 10:37 PM

» Like Us On Facebook



03:23 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.