Front strut problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-31-2012, 12:38 PM   #1
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Front strut problem

Have 05 GT lowered 2in with h&r springs and used eibach shock and struts along with j&m caster plates and front with tower brace also have 20in rims but my problem is that the front struts both sides the top of it is rubbin against my hood where it's creating metal shavings an makes me worry that it might do damage to my hood was wondering if anyone has encountered this sort of problem?
Terminator is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2012, 09:02 PM   #2
Registered User
Newbie
 
Join Date: Mar 2012
Region: Alabama
Posts: 11
Send a message via Yahoo to meganzhang
Re: Front strut problem

I've lowered my 05GT. using FRPP springs dropping it 11/2 inch. but did not change the shocks/struts yet.
meganzhang is offline   Reply With Quote
Old 03-31-2012, 10:14 PM   #3
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Hope all well goes for you lol not like me
Terminator is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any problem? joaohm 2011-2014 Mustang GT 14 03-31-2012 01:05 AM
correct offset on front and rear wheels Savage stallion Classic Mustangs 0 03-30-2012 11:48 PM
electrical problem, maybe a short somewhere jacop Pre-2005 V6 Mustang 2 03-30-2012 11:35 PM
1966 Mustang ammeter problem Gatorlee12 Classic Mustangs 2 03-30-2012 09:54 PM
1965 fastback electrical problem Shoop15 Classic Mustangs 4 03-29-2012 08:47 PM

» Like Us On Facebook



04:22 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.