Alternator - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-11-2012, 09:24 PM   #1
Registered Member
Regular
 
Texas nightmare's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 40
Alternator

Had to get a new one today. Wondering if anyone else has had to replace theirs, and if so, how many miles did u have when it happened??
Texas nightmare is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-12-2012, 12:00 PM   #2
Registered Member
Regular
 
Charles.young10's Avatar
 
Join Date: Jan 2012
Region: Oklahoma
Posts: 299
Quote:
Originally Posted by Texas nightmare
Had to get a new one today. Wondering if anyone else has had to replace theirs, and if so, how many miles did u have when it happened??
Pretty well known problem with S197s, I haven't had to replace mine yet. But it's a well documented issue
Charles.young10 is offline   Reply With Quote
Old 04-12-2012, 03:49 PM   #3
Registered Member
Regular
 
RedGT's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 102
At what mileage do they usually go? I've got just shy of 80k and haven't replaced it yet.
RedGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-12-2012, 08:01 PM   #4
Registered Member
Regular
 
06rick's Avatar
 
Join Date: Feb 2011
Region: Illinois
Posts: 69
when mine went bad it threw out cam sensor codes,that was at around 125000miles tho
06rick is offline   Reply With Quote
Old 04-13-2012, 06:58 AM   #5
Registered Member
Regular
 
Stringy's Avatar
 
Join Date: Apr 2012
Region: Nevada
Posts: 45
Mine went bad at 70k. 06Gt.
Stringy is offline   Reply With Quote
Old 04-13-2012, 11:40 PM   #6
Registered Member
Regular
 
Texas nightmare's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 40
Quote:
Originally Posted by Charles.young10

Pretty well known problem with S197s, I haven't had to replace mine yet. But it's a well documented issue
Thanks man

---------- Post added at 10:40 PM ---------- Previous post was at 10:39 PM ----------

Quote:
Originally Posted by RedGT
At what mileage do they usually go? I've got just shy of 80k and haven't replaced it yet.
Dang, I'm at 79k and just had to.

---------- Post added at 10:40 PM ---------- Previous post was at 10:40 PM ----------

Thanks for the feedback everyone
Texas nightmare is offline   Reply With Quote
Old 04-14-2012, 09:11 PM   #7
Registered Member
Regular
 
Solomo2's Avatar
 
Join Date: Dec 2011
Location: Charleston
Region: South Carolina
Posts: 450
Have they figured out what causes this issue?
Solomo2 is offline   Reply With Quote
Old 04-14-2012, 09:43 PM   #8
Registered Member
Regular
 
janorton05's Avatar
 
Join Date: Mar 2012
Location: Glendale
Region: Arizona
Posts: 25
Re: Alternator

I just replaced mine at 95000 miles. I also received the wonderful p0340 cam sensor CEL before it went out.
janorton05 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.