Help!!! Dtc codes p0174 and p2197 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-01-2012, 12:53 PM   #1
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Got headers x pipe flowmasters outlaw mufflers cold air intake and custom bama tuner installed on my 2007 mustang gt automatic about 2 months ago and now my check engine light is on and I'm getting the codes p0174 and p2197 they checked the o2 sensors those were fine.. Next they are doing a smoke test to see If there is any vacuum leaks.. Any other suggestions ??
Attached Thumbnails
Click image for larger version

Name:	image-3830830447.jpg
Views:	255
Size:	490.5 KB
ID:	52639   Click image for larger version

Name:	image-4001548275.jpg
Views:	396
Size:	505.9 KB
ID:	52640  

Click image for larger version

Name:	image-77355618.jpg
Views:	227
Size:	485.2 KB
ID:	52641  
Kochieey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-01-2012, 02:30 PM   #2
Registered Member
Regular
 
WillysYJ's Avatar
 
Join Date: Feb 2012
Region: Virginia
Posts: 269
You could have a bad sensor.
WillysYJ is offline   Reply With Quote
Old 06-01-2012, 06:29 PM   #3
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Nope car is at shop they checked and tested o2 sensors they were all good... Next they are performing a smoke test to see if I have a vacuum leak
Kochieey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-01-2012, 07:42 PM   #4
Registered Member
Regular
 
WillysYJ's Avatar
 
Join Date: Feb 2012
Region: Virginia
Posts: 269
codes p0174 is linked to your MAF sensor. have you tries cleaning that?
WillysYJ is offline   Reply With Quote
Old 06-01-2012, 10:06 PM   #5
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
No I didn't try cleaning it.. How do u clean it ? Sorry I'm new to this... You use a maf sensor cleaner right that they sell in the auto store
Kochieey is offline   Reply With Quote
Old 06-01-2012, 10:24 PM   #6
Registered Member
Regular
 
WillysYJ's Avatar
 
Join Date: Feb 2012
Region: Virginia
Posts: 269
You can get a can of MAF cleaner from the auto parts store, DO NOT USE CARB CLEANER! Pull off the neg battery cable, pull out the sensor, spray it a couple times and let it sit and dry out(shouldn't take long at all) reinstall and reconnect the battery and try it out. Definitely keep us up to date. Btw, I would spend the few $ on cleaning the sensor before getting a smoke test done.
WillysYJ is offline   Reply With Quote
Old 06-01-2012, 11:10 PM   #7
Registered Member
Regular
 
galindojr24's Avatar
 
Join Date: Jan 2011
Region: California
Posts: 193
I had the same problem a few months ago i cleaned my MAF sensor but everything worked fine turns out i cracked my cold air intake.. I had a JlT carbon fiber intake now i have a C&l racer intake. I recommend taking off your intake and inspecting it... Take it completely apart

---------- Post added at 11:10 PM ---------- Previous post was at 11:08 PM ----------

Ohh by the way you crack your cold air intake by over tightening it... Lol carbon fiber is very fragile
galindojr24 is offline   Reply With Quote
Old 06-02-2012, 12:08 AM   #8
Registered User
Newbie
 
5.4 DOHC's Avatar
 
Join Date: Jun 2012
Region: Michigan
Posts: 3
Lean faults on bank 2. Monitor fuel trims for both banks at idle and 2500rpms. Swap O2s from bank to bank and retest. Intake manifold off recently?
5.4 DOHC is offline   Reply With Quote
Old 06-02-2012, 09:49 AM   #9
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Thanks everybody for the info i will keep you all updated !!!!
Kochieey is offline   Reply With Quote
Old 06-02-2012, 10:16 AM   #10
Registered Member
Regular
 
Zaks06GT's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 451
Quote:
Originally Posted by galindojr24
I had the same problem a few months ago i cleaned my MAF sensor but everything worked fine turns out i cracked my cold air intake.. I had a JlT carbon fiber intake now i have a C&l racer intake. I recommend taking off your intake and inspecting it... Take it completely apart

---------- Post added at 11:10 PM ---------- Previous post was at 11:08 PM ----------

Ohh by the way you crack your cold air intake by over tightening it... Lol carbon fiber is very fragile
Carbon Fiber is not fragile at all! It's prolly was the gel coat or the fiber glass that cracked, most of the CF intakes and auto body parts are mostly fiberglass with a few layers if carbon fiber, i just know by working with it for 10 years lol
Zaks06GT is offline   Reply With Quote
Old 06-02-2012, 10:31 AM   #11
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Okay thank you I will check it out
Kochieey is offline   Reply With Quote
Old 06-03-2012, 05:40 AM   #12
Registered Member
Regular
 
Stringy's Avatar
 
Join Date: Apr 2012
Region: Nevada
Posts: 45
I had p0174. My intake was loose. The cars RPMS jumped when idle too.

---------- Post added at 03:40 AM ---------- Previous post was at 03:38 AM ----------

How many miles does the pony have?
Stringy is offline   Reply With Quote
Old 06-03-2012, 10:33 PM   #13
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Pony has almost 57k

---------- Post added at 10:33 PM ---------- Previous post was at 10:30 PM ----------

Okay keeping every body up to date friday i gor the car out of the shop they told me they unplugged and tested the o2 sensors and said they were all working and then the cleared the check engine codes and called me to pick up the car and see if the light came back on ... Well i drove the car for about 100 miles this weekend and filled up with a full tank of gas.. And no check engine light came back on I'm keeping my fingers crossed hoping it stays that way!
Kochieey is offline   Reply With Quote
Old 06-04-2012, 09:51 AM   #14
Registered Member
Regular
 
galindojr24's Avatar
 
Join Date: Jan 2011
Region: California
Posts: 193
How do you fill the way your car drives? Normal? Hows your idle?
galindojr24 is offline   Reply With Quote
Old 06-05-2012, 08:03 AM   #15
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Yes I been driving the car and everything feels normal drove over 100 miles and the check engine light never returned
Kochieey is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:50 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.