Something wrong with my gas tank? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-25-2012, 11:52 AM   #1
Registered Member
Regular
 
galindojr24's Avatar
 
Join Date: Jan 2011
Region: California
Posts: 193
Something wrong with my gas tank?

So every time i go to the gas station it is a pain in the *** trying to fill up my tank? About 3/4 tank it clicks and says that its full? And i cant put anymore gas in its just clicks and clicks and says it full every time!! at every gas station i go to??? Anyone else have this problem? I have a 07GT
galindojr24 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-25-2012, 12:03 PM   #2
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Yeah, that's common for the '05 - '09's. I've read a couple of threads where people had brought this up but I'm not sure if there is a fix for it.
primer2tone is offline   Reply With Quote
Old 06-25-2012, 02:41 PM   #3
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Quote:
Originally Posted by galindojr24
So every time i go to the gas station it is a pain in the *** trying to fill up my tank? About 3/4 tank it clicks and says that its full? And i cant put anymore gas in its just clicks and clicks and says it full every time!! at every gas station i go to??? Anyone else have this problem? I have a 07GT
Omg I was about to post the same dang thing.... I've lived with this problem for 4 years, of course it doesn't do it all the time

---------- Post added at 02:41 PM ---------- Previous post was at 02:40 PM ----------

I saw a exxon with $ 3.09 a gallon here in houston.....but my car only had a quarter of a tank and it said it was full really made me mad so I left
05MUSTANG4.0L is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-25-2012, 02:55 PM   #4
Registered Member
Regular
 
garbill2003's Avatar
 
Join Date: Jun 2012
Region: Pennsylvania
Posts: 914
Ha ha mine does it to if you turn the nozzle upside down it takes it a hole lot better.
garbill2003 is offline   Reply With Quote
Old 06-25-2012, 02:57 PM   #5
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Mine has to be cold most of the time, usually won't take any if I've been riding dirty (fast)
05MUSTANG4.0L is offline   Reply With Quote
Old 06-25-2012, 03:12 PM   #6
Registered Member
Regular
 
galindojr24's Avatar
 
Join Date: Jan 2011
Region: California
Posts: 193
So i read more and it said all 05-09 models have this problem and factory warranty does not cover it so you got to go out of pocket which is like $300.00
galindojr24 is offline   Reply With Quote
Old 06-25-2012, 03:22 PM   #7
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
But what s the issue?
05MUSTANG4.0L is offline   Reply With Quote
Old 06-25-2012, 03:43 PM   #8
Registered Member
Regular
 
Jayjay's Avatar
 
Join Date: Feb 2012
Region: California
Posts: 458
Just put the nozzle at a 90 degree and u shouldn't have a problem. Has something to do how the gas flows...
Jayjay is offline   Reply With Quote
Old 06-25-2012, 04:15 PM   #9
Registered Member
Regular
 
galindojr24's Avatar
 
Join Date: Jan 2011
Region: California
Posts: 193
90 degree angle huh and something about a sensor i think
galindojr24 is offline   Reply With Quote
Old 06-25-2012, 09:19 PM   #10
Registered Member
Regular
 
Silversky545's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 1,627
I have this problem too... make sure your car is off... when I started running 93 octane race tune problem went away
Silversky545 is offline   Reply With Quote
Old 06-25-2012, 10:47 PM   #11
Registered Member
Regular
 
Jake's Avatar
 
Join Date: May 2012
Region: Oklahoma
Posts: 681
Ive never had this problem?? Should i expect it to come up soon?? I have 40k on it??
Jake is offline   Reply With Quote
Old 06-25-2012, 11:30 PM   #12
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
I had the same dumb issue I just point nozzle horizontally at 180* degree and works perfect cause having the nozzle upside looks a lil weird my method works for me
Terminator is offline   Reply With Quote
Old 06-26-2012, 12:25 AM   #13
Registered Member
Regular
 
T_math_6's Avatar
 
Join Date: May 2012
Region: Oklahoma
Posts: 111
Quote:
Originally Posted by Jake
Ive never had this problem?? Should i expect it to come up soon?? I have 40k on it??
No it's nothing to worry about. Mine did it a few times.
T_math_6 is offline   Reply With Quote
Old 06-26-2012, 05:19 AM   #14
Registered Member
Regular
 
Jake's Avatar
 
Join Date: May 2012
Region: Oklahoma
Posts: 681
Quote:
Originally Posted by T_math_6

No it's nothing to worry about. Mine did it a few times.
Okay bud
Jake is offline   Reply With Quote
Old 06-26-2012, 08:24 PM   #15
Registered Member
Regular
 
Gil_T2's Avatar
 
Join Date: Nov 2010
Location: N VA
Region: Virginia
Posts: 434
Re: Something wrong with my gas tank?

Ford rerouted the fill tube in 08, I have not had any problems with my 08 or my 09.
__________________
BBK LT's, Catted Xpipe, Sniper tune, UDP's GT500 TB, Ford Racing CAI, CM delete, 4.10, TR6060, 1 piece DS
Gil_T2 is offline   Reply With Quote
Old 07-01-2012, 08:33 AM   #16
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
I tried a dollar store gas treatment last week when I filled my tank up and let it run all the way empty til the gas light warning came on and filled up with out stopping not even once
05MUSTANG4.0L is offline   Reply With Quote
Old 07-01-2012, 04:59 PM   #17
Registered Member
Regular
 
SSC182's Avatar
 
Join Date: Sep 2011
Region: North Carolina
Posts: 131
There is a TSB out for this ill try to find it
SSC182 is offline   Reply With Quote
Old 07-01-2012, 05:35 PM   #18
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Mine has done it off and on since I got it. My father in law got his 06 new and it's done it from day one. I'm used to it by now.
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.