CAI/engine service problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-28-2012, 06:54 PM   #1
Registered Member
Regular
 
ReggStang's Avatar
 
Join Date: Jan 2012
Region: Virginia
Posts: 58
CAI/engine service problem

Have a 2007 mustang GT. some how while I was driving yesterday my CAI came out of the housing and it made my engine shut off. I was in the middle of the road so I just shoved it back in for the time being to drive home I got home and tightened it back down good but now my check engine light won't shut back off when I put it back in the first time it went off just not after I got home. Anybody else know what's happening. My car now runs fine again
ReggStang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-28-2012, 07:07 PM   #2
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Quote:
Originally Posted by ReggStang
Have a 2007 mustang GT. some how while I was driving yesterday my CAI came out of the housing and it made my engine shut off. I was in the middle of the road so I just shoved it back in for the time being to drive home I got home and tightened it back down good but now my check engine light won't shut back off when I put it back in the first time it went off just not after I got home. Anybody else know what's happening. My car now runs fine again
Use ur tuner and check and clear the light
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 06-28-2012, 07:30 PM   #3
Registered Member
Regular
 
ReggStang's Avatar
 
Join Date: Jan 2012
Region: Virginia
Posts: 58
I don't have the tuner I bought the car this way. It's a K&N it may not even have a tune
ReggStang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-28-2012, 07:48 PM   #4
Registered Member
Regular
 
Gibby's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 501
It probably set off the MAF with the air not goin past it. Disconnect your battery for like 5 minutes and start er back up…
Gibby is offline   Reply With Quote
Old 06-28-2012, 08:14 PM   #5
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Quote:
Originally Posted by Gibby
It probably set off the MAF with the air not goin past it. Disconnect your battery for like 5 minutes and start er back up…
OBD 2 stores all codes, you have to clear it if I'm not mistaking
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 06-28-2012, 09:26 PM   #6
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Quote:
Originally Posted by ReggStang
I don't have the tuner I bought the car this way. It's a K&N it may not even have a tune
Mine did the same before I had a tuner. It'll go off by itself after a week or so depending how far you drive. Just make sure it's snugged up good.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 06-29-2012, 09:24 AM   #7
Registered Member
Regular
 
garbill2003's Avatar
 
Join Date: Jun 2012
Region: Pennsylvania
Posts: 914
Quote:
Originally Posted by Gibby
It probably set off the MAF with the air not goin past it. Disconnect your battery for like 5 minutes and start er back up…
X2
garbill2003 is offline   Reply With Quote
Old 06-29-2012, 09:53 AM   #8
Registered Member
Regular
 
ReggStang's Avatar
 
Join Date: Jan 2012
Region: Virginia
Posts: 58
Thanks guys the engine light went off after the battery trick I appreciate it
ReggStang is offline   Reply With Quote
Old 06-30-2012, 05:17 AM   #9
Registered Member
Regular
 
LAS97GT's Avatar
 
Join Date: Jan 2012
Location: Spring Lake
Region: North Carolina
Posts: 681
Any small code reader should be able to clear the code. Auto zone does it for free. They'll give you the reader have you do it yourself. They won't do it for you.
__________________
---Las97GT
LAS97GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Tags
cai

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:32 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.