Dying stang - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-02-2012, 08:29 AM   #1
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
Dying stang

Anybody figure out how to fix the dying battery problem ?
king_drae is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2012, 09:00 AM   #2
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Yes, buy a battery.
tc x 4 is offline   Reply With Quote
Old 07-02-2012, 09:22 AM   #3
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
It not the battery
king_drae is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-02-2012, 10:14 AM   #4
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by king_drae
Anybody figure out how to fix the dying battery problem ?
I bought one at Ford they've replaced it once. Are you sure your not leaving something on?
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 07-02-2012, 10:21 AM   #5
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Get everything checked out for free at auto zone : battery starter and alternator
05MUSTANG4.0L is offline   Reply With Quote
Old 07-02-2012, 11:13 AM   #6
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Re: Dying stang

I had my 06 gt at the dealer gettig my smog test and they told me my battery will need replacing soon is it a common problem with the 2005-2009 gts?
wereKEV is offline   Reply With Quote
Old 07-02-2012, 11:33 AM   #7
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
I've had battery and alt check I turn everything off and if it sits it dies but as soon as battery cables clamp on its good to go
king_drae is offline   Reply With Quote
Old 07-02-2012, 11:53 AM   #8
Registered Member
Regular
 
JetWolf's Avatar
 
Join Date: Sep 2011
Region: Arizona
Posts: 2,087
Send a message via Skype™ to JetWolf
I literally just got done putting a new battery in JetWolf ha! and everything from interstate batteries was fffrreeeeeeee!

check the water level in your battery, surprisingly they do need to be maintained, if not a cell will pull water from the other cell and then icky goopy battery acid gets everywhere. Twice during the summer and once during the winter I fill mine up here in AZ! Usually mechanics check this when you get an oil change, next time ask them if they'd check the battery for you everytime you come in. Regular maintenance is sooo much better than replacement! (:
__________________
2006 JetWolf Gilbert, AZ. Come race me, I dare you. ASU!
JetWolf is offline   Reply With Quote
Old 07-02-2012, 11:56 AM   #9
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by king_drae
I've had battery and alt check I turn everything off and if it sits it dies but as soon as battery cables clamp on its good to go
Did you recently install a radio?
tc x 4 is offline   Reply With Quote
Old 07-02-2012, 12:36 PM   #10
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
Ima have them check the cells and no radio same crappy shaker 500
king_drae is offline   Reply With Quote
Old 07-02-2012, 12:47 PM   #11
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by king_drae
Ima have them check the cells and no radio same crappy shaker 500
Kinda hard to help ya when your going in circles. Was the battery checked or not?
tc x 4 is offline   Reply With Quote
Old 07-02-2012, 12:54 PM   #12
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
When autozone checked said fine I thought he was saying something else needed to be checked
king_drae is offline   Reply With Quote
Old 07-02-2012, 12:59 PM   #13
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Quote:
Originally Posted by king_drae
When autozone checked said fine I thought he was saying something else needed to be checked
What codes did the give u at az?
05MUSTANG4.0L is offline   Reply With Quote
Old 07-02-2012, 01:04 PM   #14
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Trace the neg cable down and make shur It's tight first. That's after a parts store has checked the system. Has any kind of electrical work been done on car?
tc x 4 is offline   Reply With Quote
Old 07-02-2012, 01:06 PM   #15
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
No codes everything good

---------- Post added at 06:06 PM ---------- Previous post was at 06:04 PM ----------

I'll check and no elec work been done neither
king_drae is offline   Reply With Quote
Old 07-02-2012, 01:35 PM   #16
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
No lose terminals?

---------- Post added at 01:35 PM ---------- Previous post was at 01:34 PM ----------

The terminals are hard to replace for this car, $40 at the auto parts and az don't sell it for this car
05MUSTANG4.0L is offline   Reply With Quote
Old 07-02-2012, 02:08 PM   #17
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
So u think I should replace them
king_drae is offline   Reply With Quote
Old 07-02-2012, 02:25 PM   #18
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
I had to replace one mines bx I was makin a short to my alternator and it was melting the thick wire that went to the alternator from the battery bx I had a lose connection
05MUSTANG4.0L is offline   Reply With Quote
Old 07-02-2012, 03:10 PM   #19
Registered User
Newbie
 
king_drae's Avatar
 
Join Date: Jul 2011
Posts: 13
All right thx I'll look at it when I get off
king_drae is offline   Reply With Quote
Old 07-02-2012, 03:29 PM   #20
Registered Member
Regular
 
GTRob504's Avatar
 
Join Date: Jul 2011
Region: Louisiana
Posts: 158
One Word - Optima
Don't look back. Get a high end battery already
__________________
2008 Metallic Alloy GT Convertible Premium
Show : black top| 18" bullitt polished wheels| CDC light bar and black billet replacement grilles | black/amber corner lights | GT500 rear spoiler| AH chin spoiler Go: FRPP CAI with StangHi tunes | Kooks LT's | FR500 axle back | Steeda Sport springs | Koni STR.t struts/shocks | J&M camber plates | UMI adj. panhard bar | LCA relocation brackets | GT500 LCA's | Hurst Billet shifter | 3.73 gear | FRPP axle girdle | Baer Rotors and Pads
GTRob504 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:26 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.