Help!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-30-2012, 08:27 PM   #1
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
Help!!

Okay so after I put an after market stereo in my car I can't seem to get these light to turn off and idk why I've taken it all apart again and made sure all the plugs were in right and they still won't shut off any one have this problem before?
Attached Thumbnails
Click image for larger version

Name:	image-743359934.jpg
Views:	131
Size:	334.5 KB
ID:	61482   Click image for larger version

Name:	image-3318954607.jpg
Views:	118
Size:	313.1 KB
ID:	61483  

Justintriner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-30-2012, 08:37 PM   #2
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
Here they are again I think it messed up
Attached Thumbnails
Click image for larger version

Name:	image-2651182251.jpg
Views:	117
Size:	334.5 KB
ID:	61485   Click image for larger version

Name:	image-3605005773.jpg
Views:	107
Size:	313.1 KB
ID:	61486  

Justintriner is offline   Reply With Quote
Old 07-30-2012, 08:49 PM   #3
Registered Member
Regular
 
Black05gt's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 21
Did you check for blown fuses? Do they stay on all the time or are they off and on? No problems with my aftermarket stereo.
Black05gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-30-2012, 09:07 PM   #4
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
Which fuses? And no they stay on everything but the door light on the dash.(I had my door open when I took the picture) but my trc light will not switch off which i don't get because the hazard lights are controlled by the same plug and they work just fine. The hand brake will not turn off and and the abs light either. I've taken everything apart and put it back together exactly how it's suppose to be. I've even tried disconnecting the battery to try and see it would reset itself but no luck. I just don't want to take it to a dealership just so they can over charge me for something stupid and stupid ya know
Justintriner is offline   Reply With Quote
Old 07-31-2012, 05:26 PM   #5
Registered Member
Regular
 
Black05gt's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 21
Did you have to cut any wires? Or did everything plug in with adaptors? I would pull every fuse and just make sure they are all good.
Black05gt is offline   Reply With Quote
Old 07-31-2012, 06:52 PM   #6
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
No I didn't have to cut any thing at all. But I can't see it being a fuse, if it was a fuse don't you think it wouldn't even come on at all? Because there would be no source of power cause it has to run through the fuse first
Justintriner is offline   Reply With Quote
Old 07-31-2012, 07:00 PM   #7
Registered Member
Regular
 
Black05gt's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 21
If you were to pull out a A.B.S brake fuse. Your A.B.S light would come on saying there is something wrong. Just check all the fuses it will only take ten min. And that's a good place to start. (And I'm only using the brake fuse as an example ) pull every fuse one at a time and check it!
Black05gt is offline   Reply With Quote
Old 07-31-2012, 07:04 PM   #8
Registered Member
Regular
 
mustang06gt's Avatar
 
Join Date: Jul 2012
Region: Virginia
Posts: 167
Either you have the wrong adapters on, or you tapped into the wrong power source.

---------- Post added at 08:04 PM ---------- Previous post was at 08:01 PM ----------

Also, consider relays.
mustang06gt is offline   Reply With Quote
Old 07-31-2012, 07:40 PM   #9
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
Alright I'll check it out. I don't see how it could have tripped a fuse but I'll look. Thanks
Justintriner is offline   Reply With Quote
Old 07-31-2012, 07:46 PM   #10
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
I installed a radio in my f150 a few years ago and I blew something and all the electronics went CRAZY. From then on I always pay $20-$30 for a shop to install it. Totally worth it
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 07-31-2012, 10:46 PM   #11
Registered Member
Regular
 
Justintriner's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 69
What kind of shop?
Justintriner is offline   Reply With Quote
Old 07-31-2012, 10:48 PM   #12
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
A local audio shop here in my town. They only charged me $60 to install my touchscreen unit and the HPS box/antenna and the speaker for the Bluetooth. Some locally owned shops can give you pretty good prices if you shop around
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:44 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.