Help me!! 2007 mustang gt - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-02-2012, 04:16 PM   #1
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Help me!! 2007 mustang gt

Was driving the other day and my abs light and traction light came on the dash board and all the lights in my car including the stereo and dashboard went out... I got home and turned off the car and it wouldn't start afterwards so i bought a brand new battery thinking it was that and now the battery light comes on the dash and goes out constantly... and now with the new battery the abs light and traction light just came on again and car will not start again with new battery... What could this be... ???
Kochieey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2012, 04:28 PM   #2
Registered Member
Regular
 
Silversky545's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 1,627
Stock?
Silversky545 is offline   Reply With Quote
Old 08-02-2012, 04:49 PM   #3
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
No shorty headers high flow cats x pipe outlaw flowmaster mufflers cold air intake and bama custom tune
Kochieey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2012, 05:31 PM   #4
Registered Member
Regular
 
Badinuf's Avatar
 
Join Date: Mar 2010
Location: Phoenix
Region: Arizona
Posts: 132
Re: Help me!! 2007 mustang gt

Have someone check out the alternator. I recall someone on here having problems just like yours and it turned out the alternator was bad.
__________________
2007 Torch Red Mustang GT, Parchment Leather, Saleen Supercharger, SCT X-Cal Programmer,brenspeed.com tunes, Tuned by X-Act Dyno (Tempe, Az) 425rwhp, 4:10 Gears, Axel-back MAC exhaust, Dashhawk OBD-II Computer Monitoring System, Sequential Tail Lights, Halo Driving Lights, Eagle Eye Headlights with 6000K HID's, Clear Turn Signal Lenses, Projector Switchback Bulbs, Painted White LeMans Style Stripes, CDC Aggressive chin spoiler, Billet hood pins, Pirelli P-Zero P255 40 ZR19 wheels mounted on 2014 Mustang GT Wheels
Badinuf is offline   Reply With Quote
Old 08-02-2012, 05:48 PM   #5
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
Re: Help me!! 2007 mustang gt

The car is not starting with the new battery as you have indicated? So I would look at all of your fuses. You will need to find out why it will not start before you will be able to check alternator. I would suspect the problem is fuse blown.
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Old 08-02-2012, 05:53 PM   #6
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Sounds like your alternator has gone out and after you replaced your battery you drove it like that and now the new battery has drained. Take your battery back and have it recharged and replace your alternator.
primer2tone is offline   Reply With Quote
Old 08-02-2012, 05:55 PM   #7
Registered Member
Regular
 
black9D5's Avatar
 
Join Date: Jul 2011
Posts: 223
Yeah alternator. Usually if you drive down the road after jumping it off your lights and stuff will go off and the volts will dwindle down and the car dies lol
black9D5 is offline   Reply With Quote
Old 08-02-2012, 06:28 PM   #8
Registered Member
Regular
 
Silversky545's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 1,627
How long ago was your last mod?

---------- Post added at 05:28 PM ---------- Previous post was at 05:28 PM ----------

How long ago was your last mod
Silversky545 is offline   Reply With Quote
Old 08-02-2012, 08:29 PM   #9
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
The car started after it sat for about 30 mins

---------- Post added at 08:29 PM ---------- Previous post was at 08:29 PM ----------

Last mod was back in about march
Kochieey is offline   Reply With Quote
Old 08-02-2012, 09:39 PM   #10
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Just drive car home started up fine after driving less then 5 mins everything went out head lights tail lights brake lights stereo interior lights widows wouldnt work had no power to anything at all! Just put a brand new battery... 590 amps I do have a after market stereo system with subwoofers an amplifier and a capacitor... Do you think I need an new alternator ??? Help!!!
Kochieey is offline   Reply With Quote
Old 08-02-2012, 09:51 PM   #11
Registered Member
Regular
 
Gil_T2's Avatar
 
Join Date: Nov 2010
Location: N VA
Region: Virginia
Posts: 434
Re: Help me!! 2007 mustang gt

How hard headed are you, get the dam alt tested
__________________
BBK LT's, Catted Xpipe, Sniper tune, UDP's GT500 TB, Ford Racing CAI, CM delete, 4.10, TR6060, 1 piece DS
Gil_T2 is offline   Reply With Quote
Old 08-02-2012, 09:54 PM   #12
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
very hard headed I was in a terrible accident and got severe brain damage and lucky to even be alive... Thanks for the information very much appreciated going to get the alternator tested tomorrow... Thanks again
Kochieey is offline   Reply With Quote
Old 08-02-2012, 10:30 PM   #13
Registered Member
Regular
 
Silversky545's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 1,627
.... so many jokes....

I bet it's system related
Silversky545 is offline   Reply With Quote
Old 08-03-2012, 01:39 AM   #14
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
Re: Help me!! 2007 mustang gt

It sounds like it's definitely your alternator bro. Take it to Autozone or Local shop for a free test. So sorry to hear about your accident. Take care of yourself.
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Old 08-03-2012, 07:56 AM   #15
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Thank you so much taking the alternator to the store today to be tested much appreciated
Kochieey is offline   Reply With Quote
Old 08-03-2012, 08:17 AM   #16
Registered Member
Regular
 
GrabberBlue305's Avatar
 
Join Date: Mar 2012
Region: Ohio
Posts: 184
Re: Help me!! 2007 mustang gt

def alternator, just had the same thing happen to my dads 02 vette, put in new battery same probs to the T. Alternator fixed it. Autozone tested the alternator and it failed both tests.
__________________
2011 Mustang 3.7 * Grabber Blue * 3.55 FRPP GEARS *20" Dyno in BF G-Force TA KDW * BBK CAI * Roush Axelbacks * BBR 93 Race Tune
GrabberBlue305 is offline   Reply With Quote
Old 08-03-2012, 08:58 AM   #17
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
If you drive a 4.6 ford engine, I recommend just replacing the alternator with a PA Performance alternator when you have the money rather than waiting for it to fail. That was one of the first "mods" I did after I got my car. It's not that expensive and it's pretty easy to do yourself. Peace of mind is worth it and it's better than getting stranded somewhere.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 08-03-2012, 09:59 AM   #18
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by Badinuf
Have someone check out the alternator. I recall someone on here having problems just like yours and it turned out the alternator was bad.
Quote:
Originally Posted by primer2tone
Sounds like your alternator has gone out and after you replaced your battery you drove it like that and now the new battery has drained. Take your battery back and have it recharged and replace your alternator.
Quote:
Originally Posted by Kochieey
Just drive car home started up fine after driving less then 5 mins everything went out head lights tail lights brake lights stereo interior lights widows wouldnt work had no power to anything at all! Just put a brand new battery... 590 amps I do have a after market stereo system with subwoofers an amplifier and a capacitor... Do you think I need an new alternator ??? Help!!!
Quote:
Originally Posted by GrabberBlue305
def alternator, just had the same thing happen to my dads 02 vette, put in new battery same probs to the T. Alternator fixed it. Autozone tested the alternator and it failed both tests.
Alternator for the win! Definitely sounds like your problem. your lucky the car hasn't died in traffic. It happened to me in a Government Motors product.
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 08-03-2012, 10:06 AM   #19
Registered Member
Regular
 
MavyMav's Avatar
 
Join Date: Dec 2011
Region: Ohio
Posts: 158
FYI...

If it tests good it may not be accurate. Had the same issue with my GF's Grand Am. Tested the alternator many times and it tested fine. I went to Pull a Part and got an alternator and it has ran fine for over a year now. The voltage regulator was the culprit, which is inside the alternator. The tests do not actually show problems with the internal regulator. Keep this in mind if it tests OK. You may still need to replace it.
MavyMav is offline   Reply With Quote
Old 08-03-2012, 11:34 AM   #20
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Which pa performance alternator do you recommended 130 amp or the 200 amp I have a stereo system with the 2 subwoofers and an amplifier and a capacitor....
Kochieey is offline   Reply With Quote
Old 08-03-2012, 12:20 PM   #21
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Kochieey
Which pa performance alternator do you recommended 130 amp or the 200 amp I have a stereo system with the 2 subwoofers and an amplifier and a capacitor....
I would do the 200 with that system. I do not know that you actually need it though. Call the guys at AM, they'll probably be able to help you out.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 08-03-2012, 12:20 PM   #22
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Okay thank you!
Kochieey is offline   Reply With Quote
Old 08-05-2012, 10:09 PM   #23
Registered Member
Regular
 
2007pullinaway's Avatar
 
Join Date: Mar 2012
Region: Texas
Posts: 78
Quote:
Originally Posted by Kochieey
Okay thank you!
An easier way of testing it is turning it on and once it's on disconnect the battery and if it turns off its your alternator
2007pullinaway is offline   Reply With Quote
Old 08-05-2012, 10:16 PM   #24
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Yes thank you I found out it was my alternator I bought brand new yellow top optima battery and unplugged positive terminal and car turned off
Kochieey is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Tags
2007 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:56 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.