Error codes. Bad TPS? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-20-2012, 08:34 PM   #1
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Error codes. Bad TPS?

Ok so my car keeps going into fail safe engine mode and runs as slow as a Honda I'm getting error codes p2106 p2135.

Says some **** about the TPS on my SCT tuner.

When I return car to stick it goes away..

---------- Post added at 08:34 PM ---------- Previous post was at 08:24 PM ----------

Guess its parked till bama opens tomorrow.
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-20-2012, 08:51 PM   #2
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 525
Re: Error codes. Bad TPS?

I know the slightest buildup in the drive by wire TB will cause TP codes,,They do it at work all the time,,I just clean them real good and everythings good
__________________
mymustang is offline   Reply With Quote
Old 08-20-2012, 08:59 PM   #3
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
I've got electric contact cleaner use that?
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2012, 01:57 AM   #4
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Re: Error codes. Bad TPS?

can you test a tps on an s197 the same way as any other car with a multimeter? might not hurt if you can to test the volts
1slosix is offline   Reply With Quote
Old 08-21-2012, 08:38 AM   #5
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
I've got a multimeter. How do you test it? I guess it's time for a good old google search!
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-21-2012, 11:52 AM   #6
Site Sponsor
Sponsor
 
AMWill's Avatar
 
Join Date: Apr 2012
Location: Malvern
Region: Pennsylvania
Posts: 2,171
Re: Error codes. Bad TPS?

Quote:
Originally Posted by Jgill1992 View Post
Ok so my car keeps going into fail safe engine mode and runs as slow as a Honda I'm getting error codes p2106 p2135.

Says some **** about the TPS on my SCT tuner.

When I return car to stick it goes away..

---------- Post added at 08:34 PM ---------- Previous post was at 08:24 PM ----------

Guess its parked till bama opens tomorrow.

Jgill1992,

Give you throttle body a good cleaning. This is somewhat common for 05-10 GT's having dirty a throttle body that mess with the TPS sensor. If you've been running your Bama tune for a while without any issues, it definitely makes me suspect something mechanical, then the tune.

Keep me updated on this issue, I want to make sure you turn out okay!

Shane
__________________
Will Levantovsky | AmericanMuscle.com
Toll Free: 866.727.1266
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A $1500 MMD STYLING PACKAGE
Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 08-21-2012, 09:35 PM   #7
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 525
Re: Error codes. Bad TPS?

Quote:
Originally Posted by Jgill1992 View Post
I've got a multimeter. How do you test it? I guess it's time for a good old google search!
I know you can ,,just need a wire print,,but i always use a scanner to watch it,,guess im spoiled..The trucks at work you can remove the duct work ,,cycle the key and the throttle self checks itself,,if it dirty you can look closely,,and see it stutter just a little,,that will cause the computer to jump in fail safe mode after a few times..I use a citrius orange cleaner,,and carefully open up the plates and clean them out..Contact cleaner might be ok,,but i would research it a little
__________________
mymustang is offline   Reply With Quote
Old 08-22-2012, 07:18 PM   #8
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
I just ran a stragity tune and manually put in my 4.10's and disabled the cats. It's working ok but I miss the power and response from my bama tunes. Hopefually I'll get off work sometime when they are open and give them s call.

I don't think it's a physical problem the throttle body is clean and if the TPS was bad it shouldn still be showing bad no matter the tune right?
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-27-2012, 12:32 PM   #9
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Cleaned the throttle body and the MAD. Still doing it.. All voltages are good on the TPS.
Attached Thumbnails
Click image for larger version

Name:	image-4078577053.jpg
Views:	332
Size:	454.2 KB
ID:	65801   Click image for larger version

Name:	image-1575478624.jpg
Views:	322
Size:	466.9 KB
ID:	65802  

__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-27-2012, 12:40 PM   #10
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Jgill1992
Cleaned the throttle body and the MAD. Still doing it.. All voltages are good on the TPS.
We have almost the same setup. I'm having issues too (thread idle surge) and several people have told me its that BBK TB. There's a lot of people that have issues with them apparently. I don't know for sure, but maybe try putting the stock TB back on and see what happens?
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 08-27-2012, 12:45 PM   #11
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Also my fuel gauge totally craps out when using the tune...

I don't get idle surge at all on the stock tune.. And no error codes.. And the gays gauge works perfect..
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-27-2012, 02:18 PM   #12
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Jgill1992
Also my fuel gauge totally craps out when using the tune...

I don't get idle surge at all on the stock tune.. And no error codes.. And the gays gauge works perfect..
Well, I tend to talk to random people a lot. I travel a lot so I get lots of practice. I was talking to a guy that works for a local performance shop about my issue, and the problem he had with the BBK TB, is he said it doesn't respond to tunes well.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 08-27-2012, 02:19 PM   #13
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
Hummm.
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-27-2012, 09:27 PM   #14
Registered Member
Regular
 
Join Date: May 2011
Location: Mercedes
Region: Texas
Posts: 46
Quote:
Originally Posted by Jgill1992
Hummm.
Is the bbk messed up then
AGmustang11 is offline   Reply With Quote
Old 08-27-2012, 09:47 PM   #15
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
No it's a tune thing. I'm not sure anything can really "go wrong" with it. If anything the TPS might be acting up but that's not part of the TB.
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-28-2012, 12:39 AM   #16
Registered Member
Regular
 
Join Date: May 2011
Location: Mercedes
Region: Texas
Posts: 46
Quote:
Originally Posted by Jgill1992
No it's a tune thing. I'm not sure anything can really "go wrong" with it. If anything the TPS might be acting up but that's not part of the TB.
Okay but why does it act up but the tb is clean and it comes with everything
AGmustang11 is offline   Reply With Quote
Old 08-28-2012, 02:22 AM   #17
Registered Member
Regular
 
Jgill1992's Avatar
 
Join Date: May 2012
Location: Rolla
Region: Missouri
Posts: 1,405
It does the same error with the stock TB.
__________________

2015 Mustang GT Premium. No mods yet.
Jgill1992 is offline   Reply With Quote
Old 08-28-2012, 09:10 AM   #18
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Jgill1992
It does the same error with the stock TB.
Well, it's gotta be the tune then. Or maybe just replace the TPS. It's only $111 or so and it takes about 3 minutes to change out.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:28 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.