Safety Inspection turned bad... - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-01-2012, 02:40 PM   #1
Registered Member
Regular
 
Pete08GT's Avatar
 
Join Date: Dec 2010
Region: Virginia
Posts: 162
Safety Inspection turned bad...

Went in for an inspection and service...left with new rear shocks and brakes...and new alternator...ugh...less than 35k miles...WTF! It's all stock except for springs, axle back, and stereo....should this be happening?

I knew something was wrong but it just sucks to have to she'll out the cash for a car with so few miles...
Pete08GT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-01-2012, 03:07 PM   #2
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
Re: Safety Inspection turned bad...

No warranty on the vehicle?
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Old 09-01-2012, 04:25 PM   #3
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Pete08GT
Went in for an inspection and service...left with new rear shocks and brakes...and new alternator...ugh...less than 35k miles...WTF! It's all stock except for springs, axle back, and stereo....should this be happening?

I knew something was wrong but it just sucks to have to she'll out the cash for a car with so few miles...
That sucks man. I put a performance alternator in at about 30k, just because I'd heard a lot of bad things about the stock Alts. But I've got 56k on the original brakes and shocks. And I checked the brakes the other day and they have a lot of life left.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-01-2012, 05:14 PM   #4
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 525
Re: Safety Inspection turned bad...

Yea i think you got burn on the brakes,,theres no way they should wear out that fast,,Was the alternator throwing a message or light,,what was the reason for the alternator
__________________
mymustang is offline   Reply With Quote
Old 09-04-2012, 10:09 AM   #5
Registered Member
Regular
 
Join Date: Apr 2012
Location: Lakeland
Region: Florida
Posts: 1,699
Send a message via AIM to Borii
Re: Safety Inspection turned bad...

Springs are the reason for shocks. Lowering the car on stock shocks WILL wear them significantly faster.

As for the alternator, was there something even wrong to begin with?
__________________
SOLD - 06 GT 371WHP/332WTQ


Sold - 1998 Camaro SS
Sold - 2001 Audi S4
Borii is offline   Reply With Quote
Old 09-04-2012, 10:12 AM   #6
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Sounds like you got up sold dude. You gotta watch out for that, even the dealer will try to pull that sh¡t once in a while.
primer2tone is offline   Reply With Quote
Old 09-04-2012, 11:45 AM   #7
Registered Member
Regular
 
garbill2003's Avatar
 
Join Date: Jun 2012
Region: Pennsylvania
Posts: 914
It sounds like you got ripped
garbill2003 is offline   Reply With Quote
Old 09-04-2012, 02:51 PM   #8
Registered Member
Regular
 
Gil_T2's Avatar
 
Join Date: Nov 2010
Location: N VA
Region: Virginia
Posts: 434
Re: Safety Inspection turned bad...

I don't think you got rip. I service my own car, at 3,800 miles my rear shocks were bad. and i test the charging system every oil change, and found low voltage at 19,000 miles. It was not bad enought to show codes. Took it to the dealer and they fixed it under warranty both times. no problems.
__________________
BBK LT's, Catted Xpipe, Sniper tune, UDP's GT500 TB, Ford Racing CAI, CM delete, 4.10, TR6060, 1 piece DS
Gil_T2 is offline   Reply With Quote
Old 09-05-2012, 07:15 PM   #9
Registered Member
Regular
 
bluefirstgt's Avatar
 
Join Date: Jun 2011
Posts: 44
Quote:
Originally Posted by Gil_T2
I don't think you got rip. I service my own car, at 3,800 miles my rear shocks were bad. and i test the charging system every oil change, and found low voltage at 19,000 miles. It was not bad enought to show codes. Took it to the dealer and they fixed it under warranty both times. no problems.
How do you test for low voltage at home?
bluefirstgt is offline   Reply With Quote
Old 09-05-2012, 07:20 PM   #10
Registered Member
Regular
 
DaBluedude's Avatar
 
Join Date: Oct 2008
Region: Canada
Posts: 1,996
Yeah it sound like you got ripped off. The strut so would believe but the rest of it... I kinda doubt it. Especially the alternator thing.
__________________
2003 Mach 1
DaBluedude is offline   Reply With Quote
Old 09-05-2012, 07:45 PM   #11
Registered Member
Regular
 
Gil_T2's Avatar
 
Join Date: Nov 2010
Location: N VA
Region: Virginia
Posts: 434
Re: Safety Inspection turned bad...

Quote:
Originally Posted by bluefirstgt View Post
How do you test for low voltage at home?
I was a mechanic and owned my own shop for 32 years, and i still have most of my equipment. As far as shocks and struts go's, Even tho they are gas, when they go bad there is still some oil that leaks out. easy to see.
__________________
BBK LT's, Catted Xpipe, Sniper tune, UDP's GT500 TB, Ford Racing CAI, CM delete, 4.10, TR6060, 1 piece DS
Gil_T2 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:30 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.