Replaced cam pos sensors, still getting CEL - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-05-2012, 11:44 AM   #1
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Replaced cam pos sensors, still getting CEL

I have replaced both camshaft position sensors but I am still getting a check engine light has anybody got any ideas what else it could be I am going to go out and check the codes again,but I don't know what else it can be.
wereKEV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2012, 12:16 PM   #2
Registered Member
Regular
 
06rick's Avatar
 
Join Date: Feb 2011
Region: Illinois
Posts: 69
it could be your alternator,when they go bad they throw out cam sensor codes,the same thing happened to me and with new alternator all the problems stopped.
06rick is offline   Reply With Quote
Old 10-05-2012, 12:34 PM   #3
Registered Member
Regular
 
F4m0usfr34k's Avatar
 
Join Date: Oct 2011
Location: Surprise, AZ
Region: Arizona
Posts: 332
Agreed ^..... sad but tbh pretty positive it's the alternator .... Don't plan any trips to far cuz ur battery might die in the next couple days-week lol.... Take it from experience lol...... But seriously my car did the exact thing ... And when I replaced both same problem... Ended up to be the alternator
__________________
*f4m0usfr34k*
F4m0usfr34k is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2012, 01:47 PM   #4
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Happened to me too.installed New alternator and code disappeared.
Alonzo.dargan1 is offline   Reply With Quote
Old 10-05-2012, 03:02 PM   #5
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Don't replace with OEM. Get a PA Performance Alt from AM. But yeah, I'll bet that makes the code go away. Mine did the same thing.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting away from E303 cam... Beastynotch 1979-1995 Mustang GT 9 01-23-2012 10:49 AM

» Like Us On Facebook



06:53 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.