Instrumental Panel Not Working....died - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-21-2008, 02:19 PM   #1
Registered User
Newbie
 
Join Date: Apr 2008
Region: Louisiana
Posts: 2
Instrumental Panel Not Working....died

My instrumental panel or cluster just died on my 06 GT while I was re-installing my SCT tune. The only thing that lights up is the 'airbag' light come on. The lights or the gauges do nothing on startup and my tuner won't work or statup when I pug it in either. Everything else works and the car runs fine. I've tried to reboot by removing the negative on the battery and there are no fuses blown on both fuse boxes, I don't want to take it to the stealership either....can anyone help? Thanks
djesoj is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2008, 02:26 PM   #2
Legacy Member
Legacy
 
05RedDevil's Avatar
 
Join Date: Jan 2008
Region: Maryland
Posts: 436
Send a message via AIM to 05RedDevil
Re: Instrumental Panel Not Working....died

Who did you get the tune from? I would check with them.
__________________
Some show. Some go.
462 rwhp/ 446 ft-lbs
05RedDevil is offline   Reply With Quote
Old 04-21-2008, 02:31 PM   #3
Registered User
Newbie
 
Join Date: Apr 2008
Region: Louisiana
Posts: 2
Re: Instrumental Panel Not Working....died

from brenspeed, but i've reloaded it a few time everytime I install something new and it has worked great, just happend to go blank in the process this last time...kinda strang
djesoj is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2008, 02:35 PM   #4
Legacy Member
Legacy
 
05RedDevil's Avatar
 
Join Date: Jan 2008
Region: Maryland
Posts: 436
Send a message via AIM to 05RedDevil
Re: Instrumental Panel Not Working....died

I would definitely call their tech support if I were you
__________________
Some show. Some go.
462 rwhp/ 446 ft-lbs
05RedDevil is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Those who died in service sonic04edge The Bar 1 08-15-2008 04:17 PM
O'Rly has died :( timpryor The Bar 13 02-18-2006 02:08 AM
I think my computer just died on me. Dom The Bar 14 10-14-2004 03:35 PM
superman died Monkey The Bar 16 10-11-2004 08:20 PM

» Like Us On Facebook



04:20 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.