speedometer problem???? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-30-2012, 10:49 AM   #1
Registered Member
Regular
 
Join Date: Sep 2012
Region: Florida
Posts: 66
speedometer problem????

So my 05 gt lately has had a speedo prob. Ill start it up and itll go to 30 80 or 120 & will not drop from there itll go past it and say im doing well over 140 & sometimes it fixes itself. Any idea so i can use my warranty for free through my job rather then spend 100$ & drop it off at ford. Id rather get paid to fix it then spebd money!
BlacknRed05gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2012, 12:04 PM   #2
Registered Member
Regular
 
Butch's Avatar
 
Join Date: Nov 2011
Region: New Mexico
Posts: 1,653
Could just be your foot to the floor all the time ;}

Speed sensor or speedo cable but regardless get it warranty looked at, your job of course
__________________
I love speed and Nascar driving,,,
killing gears and dodging traffic,,,
-----NEHP---
{Never Enough HP}
Butch is offline   Reply With Quote
Old 10-30-2012, 03:08 PM   #3
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by BlacknRed05gt
So my 05 gt lately has had a speedo prob. Ill start it up and itll go to 30 80 or 120 & will not drop from there itll go past it and say im doing well over 140 & sometimes it fixes itself. Any idea so i can use my warranty for free through my job rather then spend 100$ & drop it off at ford. Id rather get paid to fix it then spebd money!
There have been a lot of problems with the 05 dash boards, get it replaced, not fixed.
tc x 4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2012, 03:45 PM   #4
Registered User
Newbie
 
Join Date: Oct 2012
Region: Virginia
Posts: 18
Quote:
Originally Posted by BlacknRed05gt View Post
So my 05 gt lately has had a speedo prob. Ill start it up and itll go to 30 80 or 120 & will not drop from there itll go past it and say im doing well over 140 & sometimes it fixes itself. Any idea so i can use my warranty for free through my job rather then spend 100$ & drop it off at ford. Id rather get paid to fix it then spebd money!
have you looked into the stepper motor problems that people have been having with the 05 and 06's
jaymjohnson is offline   Reply With Quote
Old 10-31-2012, 05:14 AM   #5
Registered Member
Regular
 
Join Date: Sep 2012
Region: Florida
Posts: 66
Quote:
Originally Posted by jaymjohnson

have you looked into the stepper motor problems that people have been having with the 05 and 06's
After seeing this i looked into it and it looks like a common problem. A lite bit of solder and some TLC fixes it so im gonna start with the stepper motors & see how it goes

---------- Post added at 05:14 AM ---------- Previous post was at 05:12 AM ----------

Quote:
Originally Posted by BlacknRed05gt

After seeing this i looked into it and it looks like a common problem. A lite bit of solder and some TLC fixes it so im gonna start with the stepper motors & see how it goes
Only thing i need to look into now is how much of a pain it is to remove the cluster
BlacknRed05gt is offline   Reply With Quote
Old 10-31-2012, 05:46 AM   #6
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Why would you even mess with it if you have a warranty?
tc x 4 is offline   Reply With Quote
Old 10-31-2012, 08:19 PM   #7
Registered Member
Regular
 
Sirtat's Avatar
 
Join Date: Oct 2011
Region: Canada
Posts: 294
to remove cluster; pull on speedo bezel and then remove 4x8mm bolts... and btw I have a spare cluster here if you end up needing one
__________________
IBLT IT
2005 Promar Performance forged long block
Kenne Bell 2.8L LC mammoth supercherger
and and and I DRIVE IT LIKE I STOLE IT !!!!
http://www.youtube.com/watch?v=_K_QJ...ure=plcp<br />http://www.youtube.com/watch?v=NWfvYVYlfio&feature=plcp
Sirtat is offline   Reply With Quote
Old 11-01-2012, 07:56 PM   #8
Registered Member
Regular
 
Join Date: Sep 2012
Region: Florida
Posts: 66
Quote:
Originally Posted by Sirtat
to remove cluster; pull on speedo bezel and then remove 4x8mm bolts... and btw I have a spare cluster here if you end up needing one
That was my only worry and thankfully my extended warranty company covers it and i wont pay the deductable to get it fixed since its at my shop. just have to send it to ford for reprogramming. Im getting paid two hours to do it now i just have to wait on the adjuster to come look at it and ok the over 750$ repair. Im glad i bought that warranty on it. Next task is the spark plugs!
BlacknRed05gt is offline   Reply With Quote
Old 11-05-2012, 11:29 PM   #9
Registered Member
Regular
 
Graham1992's Avatar
 
Join Date: May 2012
Location: Tompkinsville
Region: Kentucky
Posts: 414
Wow. Seems like you may need some further help with that mess. Sorry to hear!
Graham1992 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:05 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.