Front end clunks??? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-20-2012, 04:18 PM   #1
Road Trip!
 
Join Date: Sep 2012
Location: Pierson
Region: Florida
Posts: 510
Front end clunks???

So yea it's NOT the sway bar links lol. O well. Any ideas? Thinking its the strut mounts. Probably gonna do the mounts and the struts. How's that sound? Thanks fellas
muscledom is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-20-2012, 05:32 PM   #2
Registered Member
Regular
 
S197stanGT's Avatar
 
Join Date: Mar 2012
Region: Idaho
Posts: 23
I was recently experiencing a front end clunk also and I replaced my end links, no luck. Thought it were the strut mounts but nope. So I decided to take my sway bar off and drive it and clunk was gone. I replaced my front sway bar mount bushings. Easy, cheap fix. Mines an 07 gt with 75k
S197stanGT is offline   Reply With Quote
Old 11-20-2012, 05:43 PM   #3
Road Trip!
 
Join Date: Sep 2012
Location: Pierson
Region: Florida
Posts: 510
Quote:
Originally Posted by S197stanGT
I was recently experiencing a front end clunk also and I replaced my end links, no luck. Thought it were the strut mounts but nope. So I decided to take my sway bar off and drive it and clunk was gone. I replaced my front sway bar mount bushings. Easy, cheap fix. Mines an 07 gt with 75k
Hmmmmmm it seems like its coming just out of the right. Ill take the sway bar off and see what happens. I was gonna do that originally but got impatient which cost me $70 lol. Thanks for the info
muscledom is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-23-2012, 07:02 AM   #4
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by S197stanGT
I was recently experiencing a front end clunk also and I replaced my end links, no luck. Thought it were the strut mounts but nope. So I decided to take my sway bar off and drive it and clunk was gone. I replaced my front sway bar mount bushings. Easy, cheap fix. Mines an 07 gt with 75k
I've been watching this thread, my jacked up truck has been making the same noise. Your answer makes the most sense to me, I never had the issue til I put 37" tires on it.

---------- Post added at 08:02 AM ---------- Previous post was at 08:00 AM ----------

It makes a really loud poping noise, but drives perfect.
tc x 4 is offline   Reply With Quote
Old 11-23-2012, 07:20 AM   #5
Road Trip!
 
Join Date: Sep 2012
Location: Pierson
Region: Florida
Posts: 510
My only problem with that theory for my car is that I can definitely isolate the noise the the front right. Pretty sure it's a strut or the mount. Ill find out this week.
muscledom is offline   Reply With Quote
Old 11-25-2012, 02:05 AM   #6
Registered Member
Regular
 
S197stanGT's Avatar
 
Join Date: Mar 2012
Region: Idaho
Posts: 23
If you're doing your own work I would first check the end links or strut mount bushings. It's easy and quick. Just take your sway bar off. Then of its not that proceed with the strut mounts I guess.. How many miles does it have?
S197stanGT is offline   Reply With Quote
Old 11-25-2012, 06:33 AM   #7
Road Trip!
 
Join Date: Sep 2012
Location: Pierson
Region: Florida
Posts: 510
Quote:
Originally Posted by S197stanGT
If you're doing your own work I would first check the end links or strut mount bushings. It's easy and quick. Just take your sway bar off. Then of its not that proceed with the strut mounts I guess.. How many miles does it have?
81k. Already did the end links. On to the strut mounts.
muscledom is offline   Reply With Quote
Old 11-29-2012, 10:13 PM   #8
Registered User
Newbie
 
Join Date: Nov 2012
Region: Michigan
Posts: 1
Check the bolts where the k member mounts to the frame. All mine were loose and the car only has 15,000 miles. Fixed my problem. Good luck!
jjw460 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:05 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.