CEL 0345? Help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-27-2012, 11:18 AM   #1
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
CEL 0345? Help

I got a CEL with 0345 and 0349, both cam codes for drivers side cam sensor. Engine was running bad, but not consistently, seemed to be a clutch problem. It was almost time for oil change, checked and was almost 3 quarts LOW, but oil pressure was normal. After adding oil, the 0349 code went away, cars runs normal. Clear CEL and start engine fine, runs fine. Turn it off and restart and get CEL 0345, clear, start, drive no CEL, turn off, restart, CEL 0345 back.
But the car seems to run fine. Any ideas?? Anybody??
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2012, 11:55 AM   #2
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
3 quarts low!!!!!!!! Man that can't be good, how often do you change your oil?

---------- Post added at 12:55 PM ---------- Previous post was at 12:55 PM ----------

Also I heard the ALT causes problems like this, check into that
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 11-27-2012, 12:04 PM   #3
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Quote:
Originally Posted by BaSohol View Post
3 quarts low!!!!!!!! Man that can't be good, how often do you change your oil?

---------- Post added at 12:55 PM ---------- Previous post was at 12:55 PM ----------

Also I heard the ALT causes problems like this, check into that
Every 5K. I've heard some ALT issues, but I thought that was for 2005-2006, there was a TSB for it, mine is 2007. Yeah the oil scared me.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2012, 12:20 PM   #4
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Ya idk what to tell you besides maybe a failing sensor.
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 11-27-2012, 06:04 PM   #5
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Aggiesrok

Every 5K. I've heard some ALT issues, but I thought that was for 2005-2006, there was a TSB for it, mine is 2007. Yeah the oil scared me.
No, the alt issue definitely extended into 07. I promise it did... I know.

Check the alt first (it's free to check, do why not?), then I would replace the CPS's. It's easy to do, but if I remember correctly its around 40 bucks per. Do NOT get them from Pep Boys or Autozone. Get them from the dealer, it sucks, but I bought a CPS for my car from Pep Boys and it lasted about 2 weeks. Got one from Autozone for my Powerstroke and it lasted about 6 days. Both times, got another from the dealership and no further issues.

Hope this helps.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 11-27-2012, 06:14 PM   #6
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Thanks for the info. I'm gonna check sensors first by switching sides, then if not, I'll check alt.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-01-2012, 01:29 PM   #7
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
I think I found the problem. Pretty sure the right is supposed to look like the left sensor. Now I gotta pull the valve cover to get the rest of the sensor.
Attached Thumbnails
Click image for larger version

Name:	image-983851072.jpg
Views:	136
Size:	658.0 KB
ID:	78720  
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-01-2012, 07:10 PM   #8
Registered Member
Regular
 
BCS06GT's Avatar
 
Join Date: Dec 2011
Location: College Station
Region: Texas
Posts: 197
Quote:
Originally Posted by Aggiesrok
I think I found the problem. Pretty sure the right is supposed to look like the left sensor. Now I gotta pull the valve cover to get the rest of the sensor.
Wtf? How did you manage that?
BCS06GT is offline   Reply With Quote
Old 12-01-2012, 07:42 PM   #9
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Aggiesrok
I think I found the problem. Pretty sure the right is supposed to look like the left sensor. Now I gotta pull the valve cover to get the rest of the sensor.
Damn! Yeah, that's probably the issue. Seriously though, how did that happen? Did you break it pulling it out?
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Old 12-02-2012, 11:54 AM   #10
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Quote:
Originally Posted by BenGT07 View Post

Damn! Yeah, that's probably the issue. Seriously though, how did that happen? Did you break it pulling it out?
No it was already was gone. I pulled off valve cover last night and the cam sprocket is bent. The outside tines tore up the sensor. Now I have to replace the entire cam sprocket. The clock spring on the sprocket broke 4 inches off the end.
Attached Thumbnails
Click image for larger version

Name:	image-1947500431.jpg
Views:	109
Size:	488.8 KB
ID:	78835   Click image for larger version

Name:	image-3631411533.jpg
Views:	120
Size:	480.0 KB
ID:	78836  

__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-17-2012, 07:39 PM   #11
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Update


Found phaser broken off cam sprocket. Spring also broken. Replaced cam sprocket and code is gone. Fortunately got broken spring out without it falling down into timing cover.
Attached Thumbnails
Click image for larger version

Name:	image-2780473938.jpg
Views:	108
Size:	698.6 KB
ID:	81502   Click image for larger version

Name:	image-2510377585.jpg
Views:	94
Size:	661.4 KB
ID:	81503  

__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-18-2012, 05:29 AM   #12
Registered Member
Regular
 
BenGT07's Avatar
 
Join Date: Jul 2012
Region: Florida
Posts: 309
Quote:
Originally Posted by Aggiesrok View Post
Update

Found phaser broken off cam sprocket. Spring also broken. Replaced cam sprocket and code is gone. Fortunately got broken spring out without it falling down into timing cover.
Glad to hear you were able to get it fixed man. That's crazy though, I've never heard of that happening.
__________________
In the market for a Fox body...
SOLD: 2007 Performance white GT Premium.
Performance: Eibach lowering kit, SVT wheels, Steeda Camber Casters, Steeda short throw, FRPP 4.10's, Airraid CAI, BBK 62mm TB, Brenspeed Detroit Rockers, Pypes Longtubes with O/R H and Violators.
For fun: Window louvers, 15% tint, Raxiom tinted taillights, J&L Audio sub.
BenGT07 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:29 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.