Alternator replacement time! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-26-2013, 11:17 AM   #1
Registered Member
Regular
 
fury88's Avatar
 
Join Date: Jan 2013
Location: Willow Spring
Region: North Carolina
Posts: 84
Alternator replacement time!

Well I have my second project and its maintenance related! Alternator went on the car. I ordered one from AM. Seems like an easy replacement. Never worked on a car before. I'm actually looking forward to it! I've built computer servers and installed ceiling fans, indoor/outdoor lights etc but this is a new breed. earlier this month I installed the iSimple Gateway. That was easy but getting under the good should be an experience!

---------- Post added at 12:17 PM ---------- Previous post was at 12:16 PM ----------

Under the HOOD that is.
fury88 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-26-2013, 11:25 AM   #2
Registered Member
Regular
 
Jake's Avatar
 
Join Date: May 2012
Region: Oklahoma
Posts: 681
Its really easy. Get a friend, its tough to get your hand in the tight spots alone. Just get a breaker bar and couple of wrenches and your good to go. Took me and a friend about 10-15 mins
Jake is offline   Reply With Quote
Old 01-26-2013, 11:45 AM   #3
Registered Member
Regular
 
Wolverine0587's Avatar
 
Join Date: Jan 2013
Location: Copperas Cove
Region: Texas
Posts: 359
I replaced mine as well an it was simple. Got the higher amp alternator and now need to figure out how to keep the lights from brightening or dimming based on the throttle. Not anything serious at least.
Wolverine0587 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-26-2013, 12:26 PM   #4
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by fury88 View Post
Well I have my second project and its maintenance related! Alternator went on the car. I ordered one from AM. Seems like an easy replacement. Never worked on a car before. I'm actually looking forward to it! I've built computer servers and installed ceiling fans, indoor/outdoor lights etc but this is a new breed. earlier this month I installed the iSimple Gateway. That was easy but getting under the good should be an experience!

---------- Post added at 12:17 PM ---------- Previous post was at 12:16 PM ----------

Under the HOOD that is.
Did you have any signs of it before it took a dump on you I think I made need a new alternator soon as well :/ hope not
Terminator is offline   Reply With Quote
Old 01-26-2013, 05:31 PM   #5
Registered Member
Regular
 
fury88's Avatar
 
Join Date: Jan 2013
Location: Willow Spring
Region: North Carolina
Posts: 84
Quote:
Originally Posted by Terminator View Post

Did you have any signs of it before it took a dump on you I think I made need a new alternator soon as well :/ hope not
Yes though I've only had my car 3 weeks. when I bought it I noticed the battery was having problems. Looked and the battery is brand new and it checked out. Talked to a guy at work who owns 3 mustangs and said the alternator was flawed in the 2005 timeframe. Only lasts around 75k miles. My car has 84k and I noticed battery having problems still after running it. Also headlights dimming when I idle. That's a good sign also.
fury88 is offline   Reply With Quote
Old 01-28-2013, 11:52 AM   #6
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
Quote:
Originally Posted by fury88 View Post

Yes though I've only had my car 3 weeks. when I bought it I noticed the battery was having problems. Looked and the battery is brand new and it checked out. Talked to a guy at work who owns 3 mustangs and said the alternator was flawed in the 2005 timeframe. Only lasts around 75k miles. My car has 84k and I noticed battery having problems still after running it. Also headlights dimming when I idle. That's a good sign also.
Mine just took a dump today I guess I jinxed myself >_<
Terminator is offline   Reply With Quote
Old 01-28-2013, 11:57 AM   #7
Registered Member
Regular
 
Stang23's Avatar
 
Join Date: Dec 2010
Region: California
Posts: 916
Mine went to **** at 56k miles. I just replaced it. Didn't exactly go out on me but kept getting a check charging system message and the red battery icon would light up. And battery is new so the alternator was on its way out. Replaced it about a month ago and haven't thrown a code since.
__________________
Full Exhaust, Full Bolt Ons, Full Suspension and Much More..

Custom Dyno Tune By B&D Racing
340 RWHP
325 RWTQ
Stang23 is offline   Reply With Quote
Old 01-28-2013, 06:08 PM   #8
Registered Member
Regular
 
Kochieey's Avatar
 
Join Date: Mar 2012
Region: New York
Posts: 66
Had to replace alternator on my 07 gt at 60k was quite easy good luck!
Kochieey is offline   Reply With Quote
Old 01-28-2013, 06:51 PM   #9
Registered Member
Regular
 
Jake's Avatar
 
Join Date: May 2012
Region: Oklahoma
Posts: 681
Dang you guys got lucky, mine took a crap at 40k!
Jake is offline   Reply With Quote
Old 02-04-2013, 06:48 PM   #10
Road Trip!
 
Join Date: Feb 2013
Location: Etna green
Region: Indiana
Posts: 102
My lights also dim at idle. I read on a few other forums that a diode goes bad in factory alt and throws a cam sensor code so your check engine light comes on. Mine did that last week anyone else have this issue?
06gt2fast4u is offline   Reply With Quote
Old 02-04-2013, 06:55 PM   #11
Registered Member
Regular
 
fury88's Avatar
 
Join Date: Jan 2013
Location: Willow Spring
Region: North Carolina
Posts: 84
No check engine lights here. I actually just replaced my alternator today! First time working on a car. What fun! Went to autozone to get it tested and the battery was already shot. the date on the battery says 9/12 so I'm going to take it to a place that sells interstate batteries to see if they can swap it.
fury88 is offline   Reply With Quote
Old 02-05-2013, 07:41 PM   #12
Registered User
Newbie
 
Join Date: Nov 2012
Location: florida
Region: Florida
Posts: 1
I made it 22,000 miles so there must be a bad bunch out there
ABS light would come on then traction control then the radio and a/c would shut down and you would have a weird feeling when accelerating due to the throttle body getting a power problem
2006 mustang gt is offline   Reply With Quote
Old 02-05-2013, 07:43 PM   #13
Road Trip!
 
Join Date: Feb 2013
Location: Etna green
Region: Indiana
Posts: 102
I have 54k miles
06gt2fast4u is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

« Black rims | Plenum »
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:23 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.