Battery light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-27-2013, 07:35 AM   #1
Registered User
Newbie
 
CATMAN1012's Avatar
 
Join Date: Feb 2013
Location: Loganville
Region: Georgia
Posts: 4
Battery light

My batter light is on after I replaced battery and alternator. I went to Auto Zone and they said battery had too much charge and alternator was good. I just drained battery and then jumped it off and light still on. Any suggested problems? I appreciate any assistance!
CATMAN1012 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-27-2013, 10:00 AM   #2
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Where did you get the alt from?
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 02-27-2013, 10:03 AM   #3
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
Id say the alt is overcharging....have another autoparts test your charging system.
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-27-2013, 10:06 AM   #4
Registered User
Newbie
 
CATMAN1012's Avatar
 
Join Date: Feb 2013
Location: Loganville
Region: Georgia
Posts: 4
Quote:
Originally Posted by BaSohol View Post
Where did you get the alt from?
I got it off a expedition at a impound yard
CATMAN1012 is offline   Reply With Quote
Old 02-27-2013, 10:11 AM   #5
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
.....and do you know what amperage that alt is putting out compared to what your car needs?
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 02-27-2013, 10:13 AM   #6
Registered User
Newbie
 
CATMAN1012's Avatar
 
Join Date: Feb 2013
Location: Loganville
Region: Georgia
Posts: 4
Quote:
Originally Posted by 1slosix View Post
.....and do you know what amperage that alt is putting out compared to what your car needs?
No I do not. So basically I should go spend the money and get the correct one ?
CATMAN1012 is offline   Reply With Quote
Old 02-27-2013, 10:22 AM   #7
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Quote:
Originally Posted by 1slosix View Post
.....and do you know what amperage that alt is putting out compared to what your car needs?
Does that matter??? You can buy and aftermarket 200 amp and not have a battery light come on
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 02-27-2013, 11:23 AM   #8
Registered Member
Regular
 
Join Date: Apr 2012
Location: Lakeland
Region: Florida
Posts: 1,699
Send a message via AIM to Borii
Quote:
Originally Posted by BaSohol View Post
Does that matter??? You can buy and aftermarket 200 amp and not have a battery light come on
It does depend. The light will come on if overcharged or undercharged. Depends on that specific vehicles tolerance.

I would put random parts in my 95 subaru with 160k which leaks oil but I would never junkyard any part for my Mustang.
__________________
SOLD - 06 GT 371WHP/332WTQ


Sold - 1998 Camaro SS
Sold - 2001 Audi S4
Borii is offline   Reply With Quote
Old 02-27-2013, 11:31 AM   #9
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
I think he might of put a bad alt on there, I had a 93 Lincoln mark VIII, and I ordered a 96 cobra alt for it cause it had more amps then the factory Lincoln's, everything worked great just had to extend the wire harness to it a bit.
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 02-27-2013, 11:38 AM   #10
Registered Member
Regular
 
Join Date: Apr 2012
Location: Lakeland
Region: Florida
Posts: 1,699
Send a message via AIM to Borii
Quote:
Originally Posted by BaSohol View Post
I think he might of put a bad alt on there, I had a 93 Lincoln mark VIII, and I ordered a 96 cobra alt for it cause it had more amps then the factory Lincoln's, everything worked great just had to extend the wire harness to it a bit.
Well one story is not the tell all tale but yes, bad alternator is a likely possibility.
__________________
SOLD - 06 GT 371WHP/332WTQ


Sold - 1998 Camaro SS
Sold - 2001 Audi S4
Borii is offline   Reply With Quote
Old 02-27-2013, 11:47 AM   #11
Registered Member
Regular
 
Boomdizzle's Avatar
 
Join Date: Feb 2013
Location: Cincinnati
Region: Ohio
Posts: 681
I'd say bad alternator also. Go to a different store and have them test it. I always thought auto zones test was wrong, multiple times they've said I needed a new alt and all I needed to do was clean off my ground cable and everything worked fine. The best way to have them test it is to take it off and have them test it.
__________________
Torque: It's like crack for your right foot
Boomdizzle is offline   Reply With Quote
Old 02-28-2013, 11:34 AM   #12
Registered Member
Regular
 
Davo_281GT's Avatar
 
Join Date: Feb 2013
Location: Bogalusa
Region: Louisiana
Posts: 326
Quote:
Originally Posted by Borii View Post
It does depend. The light will come on if overcharged or undercharged. Depends on that specific vehicles tolerance.

I would put random parts in my 95 subaru with 160k which leaks oil but I would never junkyard any part for my Mustang.

I'm with you on that one dude. I didnt even put junk parts on my Sentra Spec-V.
Davo_281GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:27 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.