Brake Noise - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-09-2013, 02:08 PM   #1
Registered User
Newbie
 
Join Date: May 2013
Location: Coral Springs
Region: Florida
Posts: 2
Brake Noise

I have an 08 Mustang GT Conv in which I just replaced the brakes and rotors. The brakes are a kevlar, semi-metalic and the rotors are cross drilled and slotted. After 2 weeks, I am getting a scraping noise similar to that of low brake pad indicator.
terryj074 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-09-2013, 03:28 PM   #2
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
is it all the time or just when you brake?
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Old 05-09-2013, 06:49 PM   #3
Registered Member
Regular
 
fastmustangs1's Avatar
 
Join Date: Oct 2004
Posts: 541
could just be the pads ur running.
__________________
fastmustangs1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-09-2013, 07:15 PM   #4
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Did u clean your slides? Or half *** it and skip that step
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 05-09-2013, 08:01 PM   #5
Registered User
Newbie
 
Join Date: May 2013
Location: Coral Springs
Region: Florida
Posts: 2
It happens when I brake lightly, when I brake to stop, no noise. I've used the pads on other stangs and no noise. Nothing half-assed with what I did, Cleaned the slides and used a light coating of white lithium grease
terryj074 is offline   Reply With Quote
Old 05-09-2013, 10:01 PM   #6
Registered Member
Regular
 
BaSohol's Avatar
 
Join Date: Dec 2011
Region: Illinois
Posts: 2,789
Quote:
Originally Posted by terryj074 View Post
It happens when I brake lightly, when I brake to stop, no noise. I've used the pads on other stangs and no noise. Nothing half-assed with what I did, Cleaned the slides and used a light coating of white lithium grease
That lithium grease probably burned off by now
__________________

2007 Ford Mustang GT 5spd
Brenspeed tune, JLT 3, Hurst shifter, 4.10s
O/R Xpipe, 15x8 Jeg Stars with Micky Thompsons
BaSohol is offline   Reply With Quote
Old 05-10-2013, 05:37 AM   #7
Registered Member
Regular
 
Filf's Avatar
 
Join Date: Nov 2012
Region: Connecticut
Posts: 63
Need to use brake grease. Also did you remember to reuse the shims?
Filf is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:28 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.