On3 Turbo is in - Page 5 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-05-2013, 02:29 PM   #141
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Decided to get a turbo blanket to combat the heat, gonna beat wrap all the piping close to it as well

---------- Post added at 02:29 PM ---------- Previous post was at 02:29 PM ----------

I meant heat wrap
thatmustangguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-05-2013, 10:46 PM   #142
Registered Member
Regular
 
FORDuhl6's Avatar
 
Join Date: Oct 2011
Region: Texas
Posts: 654
Good idea!
FORDuhl6 is offline   Reply With Quote
Old 07-06-2013, 03:49 PM   #143
Registered Member
Regular
 
MATT.TURBO_S197's Avatar
 
Join Date: Apr 2013
Location: alexandria
Region: Louisiana
Posts: 24
Got tha on e kit on my 05 as well everything is installed just waiting on a tune...it was a pain in tha *** but should be worth ig ill b on 9 psi..I have hotrod cams bbk shorty headers
MATT.TURBO_S197 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2013, 02:59 AM   #144
Registered Member
Regular
 
Graham1992's Avatar
 
Join Date: May 2012
Location: Tompkinsville
Region: Kentucky
Posts: 414
I don't know why but I'm extremely excited for this guy!!!
Graham1992 is offline   Reply With Quote
Old 07-07-2013, 12:17 PM   #145
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
I'm extremely excited for myself as well lol
thatmustangguy is offline   Reply With Quote
Old 07-10-2013, 12:53 AM   #146
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Anything new?
Alonzo.dargan1 is offline   Reply With Quote
Old 07-10-2013, 12:59 AM   #147
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Not yet, she's going on the dyno tomorrow
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 07:02 AM   #148
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by thatmustangguy
Not yet, she's going on the dyno tomorrow
Get a vid I wanna see what that beast sounds like hahah
DustyStang306 is offline   Reply With Quote
Old 07-11-2013, 11:35 AM   #149
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
I was test driving the car this morning and my boost gauge was only reading 3 psi, there's a leak somewhere, dyno had been postponed. This is so frustrating
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 11:36 AM   #150
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
On the bright side my Hurst looks nice.
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20130711_113603.png
Views:	263
Size:	1.06 MB
ID:	117721  
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 03:52 PM   #151
Registered Member
Regular
 
Graham1992's Avatar
 
Join Date: May 2012
Location: Tompkinsville
Region: Kentucky
Posts: 414
Quote:
Originally Posted by thatmustangguy View Post
On the bright side my Hurst looks nice.
I just got my Barton Industries put in. It's so sick!
Graham1992 is offline   Reply With Quote
Old 07-11-2013, 05:53 PM   #152
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Quote:
Originally Posted by thatmustangguy View Post
I was test driving the car this morning and my boost gauge was only reading 3 psi, there's a leak somewhere, dyno had been postponed. This is so frustrating
Check around your couplers. Those are the most suspect on boost leaks.
Alonzo.dargan1 is offline   Reply With Quote
Old 07-11-2013, 06:00 PM   #153
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Yea that's where it was, it was the one connecting to the catback, the y pipe included in the kit had a slightly smaller diameter than the catback so I had it welded in place
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 06:03 PM   #154
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Glad you were able to get it fixed.
Alonzo.dargan1 is offline   Reply With Quote
Old 07-11-2013, 06:18 PM   #155
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Yea but now I gotta wait for another appointment to get a dyno tune
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 06:24 PM   #156
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Im sorry to hear that....who is tuning it?
Alonzo.dargan1 is offline   Reply With Quote
Old 07-11-2013, 06:29 PM   #157
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Dynospeed in Memphis, TN. They do great work
thatmustangguy is offline   Reply With Quote
Old 07-11-2013, 08:34 PM   #158
Registered Member
Regular
 
245ciPony's Avatar
 
Join Date: May 2012
Region: New York
Posts: 193
I'm not gonna lie, I'm jealous.
245ciPony is offline   Reply With Quote
Old 07-12-2013, 12:09 AM   #159
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Quote:
Originally Posted by 245ciPony View Post
I'm not gonna lie, I'm jealous.
I have to second that.
White03GT is offline   Reply With Quote
Old 07-15-2013, 02:24 AM   #160
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
We can't let this thread die. She scheduled to be on the dyno Tuesday
thatmustangguy is offline   Reply With Quote
Old 07-15-2013, 02:57 AM   #161
Registered Member
Regular
 
MidnightBlueGT's Avatar
 
Join Date: Apr 2013
Location: Charlotte
Region: North Carolina
Posts: 3,887
Ready to see the numbers and a dyno video! :p
MidnightBlueGT is offline   Reply With Quote
Old 07-15-2013, 10:54 PM   #162
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
We fired it up for the first time after putting everything back on after the boost leak and discovered the oil isn't flowing to the turbo or engine and can't seem to find the problem, any suggestions?
thatmustangguy is offline   Reply With Quote
Old 07-16-2013, 12:44 AM   #163
Registered Member
Regular
 
Tyoung68's Avatar
 
Join Date: Jun 2011
Location: concord
Region: California
Posts: 3,475
You sure theres no oil pressure?
Tyoung68 is offline   Reply With Quote
Old 07-16-2013, 09:56 AM   #164
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Yes positive, no oil pressure
thatmustangguy is offline   Reply With Quote
Old 07-17-2013, 09:11 AM   #165
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Well problem solved, we shortened the oil lines. But now there's an oil leak
thatmustangguy is offline   Reply With Quote
Old 07-17-2013, 09:29 AM   #166
Registered Member
Regular
 
White03GT's Avatar
 
Join Date: Mar 2013
Location: Hereford
Region: Texas
Posts: 1,057
Damn man, you're just having all the luck.
White03GT is offline   Reply With Quote
Old 07-17-2013, 02:38 PM   #167
Registered Member
Regular
 
NDstang05's Avatar
 
Join Date: Sep 2012
Region: Illinois
Posts: 111
The joys of a turbo build. Once everything is in tip top shape you'll be in a world full of bliss but turbo's are just more complicated then a s/c. Can't wait to see the final product though. Hopefully your luck turns around
NDstang05 is offline   Reply With Quote
Old 07-19-2013, 01:17 AM   #168
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Well how's she coming?
DustyStang306 is offline   Reply With Quote
Old 07-19-2013, 01:19 AM   #169
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Still haven't located the oil leak. It's getting really frustrating.
thatmustangguy is offline   Reply With Quote
Old 07-19-2013, 01:26 AM   #170
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by thatmustangguy
Still haven't located the oil leak. It's getting really frustrating.
Man that sucks just keep looking once you find it fix it and get that tune the pay off will be worth all the trouble
DustyStang306 is offline   Reply With Quote
Old 07-21-2013, 10:30 AM   #171
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Did you find where the oil leak was?
Alonzo.dargan1 is offline   Reply With Quote
Old 07-21-2013, 01:58 PM   #172
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
Yea no leaks so far.
thatmustangguy is offline   Reply With Quote
Old 07-21-2013, 03:41 PM   #173
Registered Member
Regular
 
Alonzo.dargan1's Avatar
 
Join Date: Jul 2012
Region: Georgia
Posts: 273
Glad you found it
Alonzo.dargan1 is offline   Reply With Quote
Old 07-21-2013, 10:59 PM   #174
Registered Member
Regular
 
thatmustangguy's Avatar
 
Join Date: Mar 2012
Region: Arkansas
Posts: 460
I'm so damn pissed, you guys won't believe what happened today. My turbo installer fixed the oil leak and was test driving my car and against my instructions went into boost too hard and put a hole in my block. Now he owes me money for a new block. I was so close to getting it on the dyno. I'm pretty sure a rod was thrown. I told him the tune I was given was only designed for it to be driven to the dyno shop. Now I have to get another block. Anybody know a great place for a forged block?
thatmustangguy is offline   Reply With Quote
Old 07-21-2013, 11:01 PM   #175
Registered Member
Regular
 
Black on Boss's Avatar
 
Join Date: Nov 2012
Location: Perry, GA
Region: Georgia
Posts: 7,204
Quote:
Originally Posted by thatmustangguy View Post
I'm so damn pissed, you guys won't believe what happened today. My turbo installer fixed the oil leak and was test driving my car and against my instructions went into boost too hard and put a hole in my block. Now he owes me money for a new block. I was so close to getting it on the dyno. I'm pretty sure a rod was thrown. I told him the tune I was given was only designed for it to be driven to the dyno shop. Now I have to get another block. Anybody know a great place for a forged block?
Remember what we said about that turbo better luck next time
Black on Boss is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:55 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.