Fail safety engine mode - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-30-2013, 01:11 AM   #1
Registered Member
Regular
 
Jon5.0BOSS's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Region: Texas
Posts: 26
Fail safety engine mode

Car doesn't move and my tuner says its my throttle body I was getting bad gas mileage so I switched it back to stock changed my tune to stock even got a new tune but no go still can't figure out what to do.. This is my buddy's 2005 gt my guess is he fried something electrical like TPS or his ecu do anyone have any ideas? Just trying to help my buddy out
Jon5.0BOSS is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2013, 12:16 PM   #2
Registered User
Newbie
 
lucio's Avatar
 
Join Date: Aug 2013
Location: Greeley
Region: Colorado
Posts: 4
Does it start ??
lucio is offline   Reply With Quote
Old 08-30-2013, 03:16 PM   #3
Registered Member
Regular
 
Jon5.0BOSS's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Region: Texas
Posts: 26
Turns on but doesn't move
Jon5.0BOSS is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2013, 03:24 PM   #4
AmericanMuscle.com
Sponsor
 
AMDanBailer's Avatar
 
Join Date: Jul 2011
Region: Pennsylvania
Posts: 2,878
Quote:
Originally Posted by Jon5.0BOSS View Post
Car doesn't move and my tuner says its my throttle body I was getting bad gas mileage so I switched it back to stock changed my tune to stock even got a new tune but no go still can't figure out what to do.. This is my buddy's 2005 gt my guess is he fried something electrical like TPS or his ecu do anyone have any ideas? Just trying to help my buddy out
The throttle body position sensor on the 2005-2009 GT's is very touchy. I would bet that the TPS spring is adjusted wrong. This exact same thing happened to my 2007 GT when installing a larger throttle body. I couldn't get the adjustment right so I had the car towed to Ford (because it wouldn't start). It ended up being the TPS was out of adjustment. If that spring is not perfect, the car isn't going to start and if it does, the idle is going to be choppy.

This is where I would start, I hope this helps! Keep us posted and we can help you troubleshoot.

Also, check this thread out. This should be helpful! bbk throttle body - The Mustang Source - Ford Mustang Forums. Fail safe mode should clear the second your TPS voltage is correct!

-Dan
__________________
Dan Bailer | AmericanMuscle.com
Toll Free: 866.727.1266| Mon-Fri 9AM-9PM Sat 10AM-4PM EST
Bama Direct: 888.226.9764| Mon-Fri 9AM-5:30PM EST
FREE SAME-DAY SHIPPING IN THE US-48 AND PRICE MATCHING!
AMDanBailer is offline   Reply With Quote
Old 08-30-2013, 03:37 PM   #5
Registered Member
Regular
 
Jon5.0BOSS's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Region: Texas
Posts: 26
I had I bigger throttle body on but I switched it back to stock shouldn't the eliminate the spring theory
Jon5.0BOSS is offline   Reply With Quote
Old 08-30-2013, 03:57 PM   #6
Registered Member
Regular
 
Jon5.0BOSS's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Region: Texas
Posts: 26
2005 mustang gt Throttle actuator comtrol system forced idle And throttle actuator control sustem stuck closed
Jon5.0BOSS is offline   Reply With Quote
Old 08-30-2013, 05:52 PM   #7
Registered Member
Regular
 
anthonyrc618's Avatar
 
Join Date: Jul 2012
Region: Illinois
Posts: 78
My 05 GT 5 spd just went into this fail safe engine mode. It happened once before while I was driving. I was still able to drive, it was just really rough. It wouldn't let me into the upper rpms at all
anthonyrc618 is offline   Reply With Quote
Old 08-30-2013, 08:21 PM   #8
Registered User
Newbie
 
Edmr's Avatar
 
Join Date: Aug 2013
Location: Newtown
Region: Pennsylvania
Posts: 17
Hello, I had a similar problem with my F150. It turned out to be a dirty throttle body. I cleaned it with a tooth brush and some intake cleaner. Problem went away. Now I clean the throttle body every time I clean the air filter.
Edmr is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:18 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.