Car died while driving + battery light came on - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Join Mustang Evolution Today


Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-02-2013, 08:12 PM   #1
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
Car died while driving + battery light came on

I was on my way home from work going about 40mph in my 09 gt (5 speed). I came up to a red light so I threw the shifter into nuetral and braked to the light. About 75 feet before the light, my car died. RPMs read 0 and the power steering was completely out. My headlights, dashboard lights and radio were all still on. The battery light (which was orange) popped up on my dash. I pulled over, took the key out and tried to start the car up again and it started no problem. Drove another 10 miles home. I have a 93 race tune from Bama as well.

Anyone have this issue? What could it be? It was pretty scary....

All help would be very appreciated.

Thanks all
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-02-2013, 08:24 PM   #2
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
its your alternator

---------- Post added at 07:24 PM ---------- Previous post was at 07:23 PM ----------

your battery light will only turn on if your alternator is not working properly
Mustangman705 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-02-2013, 08:50 PM   #3
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
My car only has 20k miles....Is the alternator the only possibility? It seems like when I toss the car into nuetral and coast to a stop light, the rpms fall as low as 300-400rpms sometimes. Could it be the 93 race tune from bama? I never had any issues with the car till I got this Bama tune....It has been causing me a lot of problems lately.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-02-2013, 08:53 PM   #4
Registered Member
Regular
 
RedSleeper's Avatar
 
Join Date: May 2013
Location: Austin
Region: Texas
Posts: 417
Quote:
Originally Posted by Langer1099 View Post
My car only has 20k miles....Is the alternator the only possibility? It seems like when I toss the car into nuetral and coast to a stop light, the rpms fall as low as 300-400rpms sometimes. Could it be the 93 race tune from bama? I never had any issues with the car till I got this Bama tune....It has been causing me a lot of problems lately.
Call BAMA. They will help you
__________________
Loving the days when you travel down to Mexico to push your car to the limits!
RedSleeper is offline   Reply With Quote
Old 10-02-2013, 08:54 PM   #5
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
Is you're battery tightened down?
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 10-02-2013, 09:24 PM   #6
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
yah its your alternator... the battery light is run threw it. u could have a dead battery and the light wont come on. if your alternator isn't working it will come on.. take your belt off your alternator and start the car, the light will be on and u have a full battery.. its really the only thing. should replace soon before your left stranded

---------- Post added at 08:24 PM ---------- Previous post was at 08:21 PM ----------

that or its the belt but I doubt it if you made it home haha.. def your alternator bro... an auto store like napa will test it for freebut everytime you drive and that light is on means your battery is not getting charged so when its on your running on just your battery juice... terrible for your battery
Mustangman705 is offline   Reply With Quote
Old 10-02-2013, 10:05 PM   #7
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
Let me clarify better, which I should have from the beginning. The battery light stayed on for 5 seconds till I shut the car off. When I started the car back up after it died, there was no light at all. I just went out a few minutes ago and started it up and it started up just fine. I do have some times where my RPMs get super super low when coming to a stop. They will shoot down to 300 rpms and when I come to a full stop they will shoot up to 1100-1200 and then back to 700 til I begin driving again. I think its an idle issue. I think the car died because my rpms went so low that the car shut itself off.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-02-2013, 10:15 PM   #8
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
well im not sure about that but what I do know is the only way your battery light will come on is if the alternator is not working. since the car is running fine now I would take it to napa or an auto parts store and get them to test your alternator.. they do this for free... just keep in mind if the light comes back that's the issue. clean your pcv valve and iac if you think its an idle issue
Mustangman705 is offline   Reply With Quote
Old 10-02-2013, 10:20 PM   #9
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
If the RPMs fall too low can it cause the engine to shut down? Why would my RPMs fall as low as 300 and shoot up to 1200 all in a matter of stopping at a stop light? I did email BAMA, so I hope they can help. The PCM valve is connected on the left hand side of my cold air correct? How would one go about cleaning that?

Thanks for the help so far though. I appreciate it.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-02-2013, 10:30 PM   #10
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
its on the valve cover.. will be a black hose coming out of your valve cover pull it off then there will be a pcv valve.. pull that out, it should rattle.. if it doesn't replace it there like 10 bucks.. or soak it in gas... I assume the car your driving is the 2009 in your pic.. might want to just do a quick google search in images and see what im talking about
Mustangman705 is offline   Reply With Quote
Old 10-02-2013, 11:06 PM   #11
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
Alrighty, I will check it out. Thank you for the helpful advice. The PCV valve can cause RPM disturbance? I think I remember moving it around slightly when I installed my cold air.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-02-2013, 11:19 PM   #12
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
update; I just checked the pcv valve and it isn't the stock valve anymore (the one with the green clip) after I replaced the stock airbox. All it is is a rubber tube connecting the cold air intake to the pcv valve on the head. The rubber tube did look to be very loose on the cold air intake so I tightened it, so I guess we will have to see if that helped out at all.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-02-2013, 11:28 PM   #13
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
ya could of just been causing a vaccuum leak
Mustangman705 is offline   Reply With Quote
Old 10-02-2013, 11:43 PM   #14
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
Yep, it appears that was the issue. Just went for a little test drive after tightening up the pcv valve and I had no RPM drops or rises. It looks to be running much smoother at this point. Thanks again man.

Cheers
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Old 10-03-2013, 02:47 PM   #15
Registered Member
Regular
 
BadAssStang07's Avatar
 
Join Date: Jul 2013
Location: Columbia
Region: South Carolina
Posts: 103
I have the same problem when I'm going hundred plus and just put it in neutral and then it dies and the power steering is gone, scared me a few times going around curves. Would to like to know the problem

---------- Post added at 03:47 PM ---------- Previous post was at 03:45 PM ----------

Does it once in a while.
BadAssStang07 is offline   Reply With Quote
Old 10-03-2013, 03:44 PM   #16
Registered Member
Regular
 
jellyroll's Avatar
 
Join Date: Jul 2013
Location: PA
Region: Pennsylvania
Posts: 92
What cai do you have? Glad to hear things worked out.
__________________
2008 GT/CS - {SLP Loudmouth Axle Back Exhaust- SR Strut Tower Brace - Raxiom Sequential Tail Light Kit - C&L Street CAI - Bama Tune - FRPP Lowering Springs - FRPP Rear Sway Bar - FRPP Struts & Shocks - BMR TCA032 LCAs}
jellyroll is offline   Reply With Quote
Old 10-03-2013, 05:57 PM   #17
Registered Member
Regular
 
BadAssStang07's Avatar
 
Join Date: Jul 2013
Location: Columbia
Region: South Carolina
Posts: 103
I have the hpr spectre cai
BadAssStang07 is offline   Reply With Quote
Old 10-03-2013, 06:16 PM   #18
Road Trip!
 
Join Date: Sep 2013
Location: grande prairie
Region: Canada
Posts: 495
Quote:
Originally Posted by Langer1099 View Post
Yep, it appears that was the issue. Just went for a little test drive after tightening up the pcv valve and I had no RPM drops or rises. It looks to be running much smoother at this point. Thanks again man.

Cheers

aws0me bro, always awesome when things work out
Mustangman705 is offline   Reply With Quote
Old 10-03-2013, 08:28 PM   #19
Registered Member
Regular
 
Langer1099's Avatar
 
Join Date: Jun 2013
Location: Bartlett
Region: Illinois
Posts: 348
Drove it again to work with NO issues. Ran much better than usual. RPMs stayed consistent when braking in nuetral. They stayed at a constant 700-800 while stopped. I pushed the PCV valve all the way against my JLT cold air and it solved the issue.
__________________
2009 Mustang GT Premium; FRRP 4.10 Gears, J&M Lower Control Arms, BBK Long Tube Headers, BBK Catted X Pipe, Pypes M80 Mid Mufflers, Pypes Pype Bomb Axle Back, JLT Series 3 Cold Air Intake, Bama 93 Octane Race Tune, Black Decklid Panel, Weathertech Mats, SVE Shifter and Shorty Antenna.
Langer1099 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:29 PM


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.