very strange start up problem. I need help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-26-2013, 04:49 PM   #1
Registered User
Newbie
 
Join Date: Oct 2013
Location: El Paso
Region: Texas
Posts: 3
very strange start up problem. I need help

I have a strange problem with my mustang, and it is driving me crazy. I hope someone can help. Here it is. I have a 2007 mustang gt with a 4.6L engine. I set the little screen in my dashboard to my mpg setting. I can turn my car off and walk away. When I return to my car, put the key in the ignition. I turn the key to the on position without starting the engine, the screen is still at the mpg. As soon as I start the engine, the screen goes to its default position of simply stating my mileage. The battery will also die within a month of the car not being driven. I have checked every single relay that has to do with the starting system; they are all ok. I have had the battery, alternator, and starter motor checked out. All are ok. I just replaced the ignition switch in the car, and that didn't help the problem either. I am out of ideas on how to fix this, and I am asking anyone who might have an idea of what I can check.
coolguy21433 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-26-2013, 06:39 PM   #2
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
Do you have any aftermarket radio stuff in the car. Amp ect..?
Mfore33 is offline   Reply With Quote
Old 10-28-2013, 12:51 PM   #3
Registered User
Newbie
 
Join Date: Oct 2013
Location: El Paso
Region: Texas
Posts: 3
No, the entire car is all stock.
coolguy21433 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2013, 01:03 PM   #4
Registered Member
Regular
 
Torchredfrankie's Avatar
 
Join Date: Jul 2012
Region: California
Posts: 779
Is there a cd stuck in the radio? I had a cd stuck in the radio and that killed my battery because the cd will skip all the time.
Torchredfrankie is offline   Reply With Quote
Old 10-28-2013, 05:16 PM   #5
Registered User
Newbie
 
Join Date: Oct 2013
Location: El Paso
Region: Texas
Posts: 3
No, there are no cds stuck in the player. Just checked.
coolguy21433 is offline   Reply With Quote
Old 10-29-2013, 01:43 AM   #6
Registered Member
Regular
 
Jayjay's Avatar
 
Join Date: Feb 2012
Region: California
Posts: 458
Have you checked your battery at a different location.. I had a similar situation and was my battery. Checked it at autozone twice and told me my battery was good, took it to dealer and said battery was bad... I didn't believe them since autozone told me it was good. I bought a battery from ford with 5 yrs warranty and it fixed my problem. 6 months later my alternator gave up and got replaced.
Jayjay is offline   Reply With Quote
Old 10-29-2013, 06:03 AM   #7
Registered Member
Regular
 
Mfore33's Avatar
 
Join Date: Feb 2012
Location: Murfreesboro
Region: Tennessee
Posts: 540
I had my alternator checked and it was good. Similar problem like yours. Turned out the diode in the alternator was bad. Not getting a proper charge and causing a slow drain. I think the diode kit was under 30 dollars. Other than that check the fuses in the morning before the car get cranked for any signs of heat. That could indicate a circuit short of some kind. Also check for corrosion on battery post and cables. I had a truck that wouldn't start after sitting a while and it was the inside of the cable connectors that had a corrosion on them. I used a wire brush to get them shiny an it started right up. Good luck.
Mfore33 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.