2006 GT electrical Issues - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-09-2013, 06:49 PM   #1
Registered User
Newbie
 
richknowl's Avatar
 
Join Date: Nov 2013
Location: Cherry Hill
Region: New Jersey
Posts: 8
2006 GT electrical Issues

I have a problem, my 2006 GT 4.6 Supercharged electrical system is going haywire. My instrument panel and radio just go off and then come back on after about 15 minutes. The dome lights go on and off. My power windows and locks work then the don't work. You can actually hear the door locks clicking on and off. My left turn signal is staying on and won't shut off. When I try flipping the turn signal off my headlights flicker. This all started happening today. Also the passenger door open alert comes on from time to time but it's definitely closed. Does anyone know what's going on? I'm scheduled for service in the middle of the week but I need to know what it might be?
richknowl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-09-2013, 06:55 PM   #2
Registered Member
Regular
 
Doe_Rae_mi's Avatar
 
Join Date: Nov 2011
Region: South Carolina
Posts: 2,587
Quote:
Originally Posted by richknowl View Post
I have a problem, my 2006 GT 4.6 Supercharged electrical system is going haywire. My instrument panel and radio just go off and then come back on after about 15 minutes. The dome lights go on and off. My power windows and locks work then the don't work. You can actually hear the door locks clicking on and off. My left turn signal is staying on and won't shut off. When I try flipping the turn signal off my headlights flicker. This all started happening today. Also the passenger door open alert comes on from time to time but it's definitely closed. Does anyone know what's going on? I'm scheduled for service in the middle of the week but I need to know what it might be?
Sounds like a ghost
Doe_Rae_mi is offline   Reply With Quote
Old 12-09-2013, 06:59 PM   #3
Registered User
Newbie
 
richknowl's Avatar
 
Join Date: Nov 2013
Location: Cherry Hill
Region: New Jersey
Posts: 8
Tell me about it. This freaky crap started this morning and things just keep getting worse.
richknowl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-09-2013, 07:39 PM   #4
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Have you tested the alternator? I've heard they can cause some freaky stuff. Also could be a short. Did you install the SC?
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-09-2013, 07:59 PM   #5
Registered User
Newbie
 
richknowl's Avatar
 
Join Date: Nov 2013
Location: Cherry Hill
Region: New Jersey
Posts: 8
No I didn't. I bought it a month ago from a dealer. The Roush Supercharger was already installed. I've had it a month and a half and the problem started today.

---------- Post added at 08:59 PM ---------- Previous post was at 08:55 PM ----------

Thanks Aggiesrok, I will look into the alternator. Also, does the smart junction fuse box ring a bell. Someone told me that can be an issue too?
richknowl is offline   Reply With Quote
Old 12-10-2013, 12:42 AM   #6
Registered Member
Regular
 
Aggiesrok's Avatar
 
Join Date: Jul 2011
Location: Bryan
Region: Texas
Posts: 1,883
Quote:
Originally Posted by richknowl View Post
No I didn't. I bought it a month ago from a dealer. The Roush Supercharger was already installed. I've had it a month and a half and the problem started today. ---------- Post added at 08:59 PM ---------- Previous post was at 08:55 PM ---------- Thanks Aggiesrok, I will look into the alternator. Also, does the smart junction fuse box ring a bell. Someone told me that can be an issue too?
I've heard the smart junction box can cause weird stuff. They can wet and cause shorts. Also the frame can crack and cause trouble. It requires a scan tool to test it. Apparently they're expensive.
__________________
chevy runs deep, Don't step in chevy!

289 - Holley 4150 570cfm; Performer intake; mild cam; MSD HEI; 302 heads; Roller Tips; Hedman Tri-Y headers; H-pipe w/Flowmaster 40's; 9 in posi 3.50; 205/50-17F; 225/50-17R.
Aggiesrok is offline   Reply With Quote
Old 12-10-2013, 01:34 AM   #7
Registered Member
Regular
 
66Sprint200's Avatar
 
Join Date: Aug 2008
Location: Pittsburgh
Region: Pennsylvania
Posts: 305
Quote:
Originally Posted by Aggiesrok View Post
I've heard the smart junction box can cause weird stuff. They can wet and cause shorts. Also the frame can crack and cause trouble. It requires a scan tool to test it. Apparently they're expensive.
^+1 Check the passenger side carpet to see if it's soggy. Another way to check is pop the hood, remove the access panel to the cabin air filter (passenger side of the car) and look to see if it's filled with water. Ford designed the car with a double firewall. The 2 halves join together down near the footrest. To keep exhaust fumes out they use a "1 way" drains. Unfortunately, these fill with pine needles, seeds, leaves, etc and clog so water just starts filling up the void between the 2 firewalls. And to top that off, the cabin air filter just clips in about 3 inches above the drains, and it's a big square opening. So as water builds up, it just leaks into the car.
__________________
1966 Mustang Sprint 200--Wimbledon White
1998 Mustang V6 Coupe--Silver--RIP, Totalled by brother
2005 Mustang V6 Premium Coupe--Sonic Blue
66Sprint200 is offline   Reply With Quote
Old 12-10-2013, 02:28 PM   #8
Registered User
Newbie
 
richknowl's Avatar
 
Join Date: Nov 2013
Location: Cherry Hill
Region: New Jersey
Posts: 8
The passenger Side Carpet was soaked. Just like you said. I let the dealer know to look for this issue and sure enough, thats the problem. And since I just bought it and its not covered on warranty the service mgr. said the sales dept. will pick up the tab. Thanks to all for your input and help !!!!!
This Forum Rocks !!!!!
richknowl is offline   Reply With Quote
Old 12-13-2013, 02:22 PM   #9
Registered Member
Regular
 
Davo_281GT's Avatar
 
Join Date: Feb 2013
Location: Bogalusa
Region: Louisiana
Posts: 326
Quote:
Originally Posted by richknowl View Post
The passenger Side Carpet was soaked. Just like you said. I let the dealer know to look for this issue and sure enough, thats the problem. And since I just bought it and its not covered on warranty the service mgr. said the sales dept. will pick up the tab. Thanks to all for your input and help !!!!!
This Forum Rocks !!!!!
That's what we are here for. Welcome Aboard man!
__________________
"A mans reach should exceed his grasp."
Davo_281GT is offline   Reply With Quote
Old 12-13-2013, 02:29 PM   #10
Registered User
Newbie
 
richknowl's Avatar
 
Join Date: Nov 2013
Location: Cherry Hill
Region: New Jersey
Posts: 8
Thanks Again....
richknowl is offline   Reply With Quote
Old 12-13-2013, 02:38 PM   #11
Registered Member
Regular
 
66Sprint200's Avatar
 
Join Date: Aug 2008
Location: Pittsburgh
Region: Pennsylvania
Posts: 305
No problem. We are all here to help each other.
__________________
1966 Mustang Sprint 200--Wimbledon White
1998 Mustang V6 Coupe--Silver--RIP, Totalled by brother
2005 Mustang V6 Premium Coupe--Sonic Blue
66Sprint200 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:44 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.