NEED HELP - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-05-2014, 04:11 PM   #1
Registered Member
Regular
 
MasonStacks's Avatar
 
Join Date: Jul 2013
Location: Pomeroy
Region: Washington
Posts: 292
NEED HELP

I'm thinking I am having an airflow problem. Anyone experience this before?
MasonStacks is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-05-2014, 04:13 PM   #2
Registered Member
Regular
 
MasonStacks's Avatar
 
Join Date: Jul 2013
Location: Pomeroy
Region: Washington
Posts: 292
http://www.youtube.com/embed/KYTfjgCbHR0?feature=oembed
MasonStacks is offline   Reply With Quote
Old 02-18-2014, 09:13 PM   #3
Registered User
Newbie
 
06Redstang's Avatar
 
Join Date: Jan 2014
Location: Carrollton
Region: Texas
Posts: 6
I have the same thing happening on my '06 when the engine is cold. Once it's warm, this stops. But I have to start the car and let it sit before driving or else it bogs down like that when you accelerate. Imagine running late for work and the car chugging and choking like that just when you pull onto the interstate.
06Redstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:17 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.