Check Charging System - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-14-2014, 01:12 PM   #1
Registered User
Newbie
 
Join Date: Feb 2014
Location: Fort Worth
Region: Texas
Posts: 5
Check Charging System

I have a 2009 Candy Apple Red Mustang GT- I have a Check Charging System Light on. I took the Mustang to Auto Zone and checked the Chargin System and the Battery which both checked out ok. I did notice there was some corrosion on the negative battery terminal. I will clean the terminals and disconnect that negative and positve terminal and grease it. If that does not clear the code what is the next step?
rpstrickland is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2014, 01:23 PM   #2
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,409
If all of that doesn't work, your next step will be to go somewhere better than Auto Zone to have your charging system diagnosed...
straybullitt is offline   Reply With Quote
Old 02-14-2014, 01:42 PM   #3
Registered User
Newbie
 
Join Date: Feb 2014
Location: Fort Worth
Region: Texas
Posts: 5
Check Checking System

My first concern was either the Battery or the Altenator however with only 48K miles I did not suspect the Altenator. The battery was replaced in MAY OF 2012 under warranty it is a factory Ford Battery so it is about 18 months old.

Charging systems are not complex if the altenator is charging at the voltage as required and the battery is good I am thinking it is a stuck code. The code flashed on a very cold night here in Texas and with the contact not being 100% it could be pretty simple.
rpstrickland is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2014, 01:49 PM   #4
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,409
Hopefully when you clean everything up and clear the codes, it won't come back.
Carefully inspect the cables and make sure that you have good tight ground connections as well.
I presume that you haven't been experiencing any problems aside from the light being on?
straybullitt is offline   Reply With Quote
Old 02-14-2014, 02:01 PM   #5
Registered User
Newbie
 
Stfmarc's Avatar
 
Join Date: Aug 2013
Location: Montreal
Region: Canada
Posts: 18
Most of the time its the alternator
Stfmarc is offline   Reply With Quote
Old 02-18-2014, 07:06 AM   #6
Registered User
Newbie
 
Join Date: Feb 2014
Location: Fort Worth
Region: Texas
Posts: 5
Checking Charging System

I cleaned the negative battery terminal code still remains. The altenator is charging at 14.6 and the battery still checks good. Ugh...

I have had no problems other than the light the car only has 48K miles on it.
rpstrickland is offline   Reply With Quote
Old 02-18-2014, 12:20 PM   #7
Registered Member
Regular
 
Join Date: Jan 2014
Location: Boston
Region: Massachusetts
Posts: 59
Did you try clearing the code and see if it comes back?
Arustik is offline   Reply With Quote
Old 02-18-2014, 12:21 PM   #8
Registered User
Newbie
 
Join Date: Feb 2014
Location: Fort Worth
Region: Texas
Posts: 5
Charging System

How do you clear the code?
rpstrickland is offline   Reply With Quote
Old 02-18-2014, 12:22 PM   #9
Registered Member
Regular
 
Join Date: Jan 2014
Location: Boston
Region: Massachusetts
Posts: 59
Your local autozone or any gas station with a garage could do it for you usually free of charge.
Arustik is offline   Reply With Quote
Old 02-18-2014, 12:49 PM   #10
Registered Member
Regular
 
Join Date: Mar 2013
Location: Salinas
Region: California
Posts: 7,409
Just disconnect the battery for about 20 minutes. That wll clear the codes.
straybullitt is offline   Reply With Quote
Old 02-18-2014, 12:50 PM   #11
Registered Member
Regular
 
Join Date: Jan 2014
Location: Boston
Region: Massachusetts
Posts: 59
Quote:
Originally Posted by straybullitt View Post
Just disconnect the battery for about 20 minutes. That wll clear the codes.
Or that I guess.
Arustik is offline   Reply With Quote
Old 02-18-2014, 02:30 PM   #12
Registered User
Newbie
 
Join Date: Feb 2014
Location: Fort Worth
Region: Texas
Posts: 5
Thanks I will try that tonight after work.
rpstrickland is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Myths about "back-pressure" Eturner General Mustang Discussion 45 09-08-2016 02:31 PM
Louder Sound Idea!! MustacheMustang 2011-2014 V6 Mustang 196 05-19-2013 03:21 PM
For Sale: (11-14) Flowmaster American Thunder Cat-Back Exhaust System DWC_SmOziLLa Mustang Parts for Sale and Wanted 25 04-21-2013 12:50 PM
03 fuel rail Xaperez100 1996-2004 Mustang GT 3 04-12-2013 03:52 PM
'88 GT check engine light? robert81717 1979-1995 Mustang GT 7 07-13-2011 12:56 AM

» Like Us On Facebook



07:46 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.