Electrical problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-22-2014, 08:27 PM   #1
Registered Member
Regular
 
LeviG2010's Avatar
 
Join Date: Jul 2011
Posts: 105
Electrical problem

So in my 2010 Gt my fan blew it's resistor. After some extensive research I learned that the fan connector comes a little loose causing it to arc and resulting in the resistor going and the fan not working at low speeds as well as the connector being burnt. Now I told my mechanic this and he done some looking and testing and he confirmed my suspicions.
However he also told me that the fuses for the abs are getting too much current. What would cause something like this?


2010 Mustang GT steeda CAI, steeda underdrive pulleys, mangapack catback, kooks long tubes w/ hiflo cats, accel coils, FRPP throttle body
__________________
The driver doesn't pick the car. The car picks the driver.
LeviG2010 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-27-2014, 05:23 PM   #2
Registered Member
Regular
 
MarkH's Avatar
 
Join Date: Jul 2014
Location: Northeast
Region: New Hampshire
Posts: 166
Are the fuses burning up from the excess current? Based on your list of updates it does not look like you modified anything abs related. Where did the mechanic pick up the abs issue? Warranty or maybe no problem at all, I would try a ford dealer.


Sent from my iPad using Mustang Evolution
MarkH is offline   Reply With Quote
Old 07-27-2014, 05:28 PM   #3
Registered Member
Regular
 
LeviG2010's Avatar
 
Join Date: Jul 2011
Posts: 105
It hasn't burned up any fuses yet. So I'm kinda thinking maybe it's nothing or a tool error.


2010 Mustang GT steeda CAI, steeda underdrive pulleys, mangapack catback, kooks long tubes w/ hiflo cats, accel coils, FRPP throttle body
__________________
The driver doesn't pick the car. The car picks the driver.
LeviG2010 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem - 2005 2005Aaron 2005-2010 Mustang GT 5 07-27-2009 08:28 AM
electrical problem with my 65 Mustang convertible joeyemma Classic Mustangs 3 04-27-2009 10:42 PM
electrical problem? dave1170 1979-1995 Mustang GT 1 03-11-2008 01:51 PM
Problem with electrical system kitslik Pre-2005 V6 Mustang 4 11-29-2007 10:56 PM

» Like Us On Facebook



04:15 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.