Need help! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-24-2014, 08:12 AM   #1
Registered Member
Regular
 
Turtlestang39's Avatar
 
Join Date: Feb 2012
Region: Florida
Posts: 73
Need help!

Hello guys,

So for the last couple of months I've noticed that my car seems to either skip or struggle to catch the next gear while trying to accelerate while in movement. If I try to step on it from a dead stop it doesn't happen. But if I'm trying to pass someone and I'm between 2000 to 3000 it struggles to catch the extra boost. Everything is stock.

Have anyone had the same issue or might now what this is?

Thank you.



Sent from my iPhone using Mustang Evolution
Turtlestang39 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2014, 09:29 AM   #2
Registered Member
Regular
 
KamzGT's Avatar
 
Join Date: Aug 2013
Location: Oakley
Region: California
Posts: 381
Check your throttle body.


Sent from my iPhone using Mustang Evolution
KamzGT is offline   Reply With Quote
Old 09-24-2014, 10:11 AM   #3
Registered Member
Regular
 
boink's Avatar
 
Join Date: Jun 2014
Location: Pasadena
Region: Maryland
Posts: 159
[QUOTE=KAMZ01MUSTANG;2096382]Check your throttle body.

This...
I picked up a CRC twin back of MAF cleaner and throttle body cleaner for a few bucks at Walmart. I'd suggest cleaning both...


Amazon.com: CRC 05111 Single-Use MAF and Throttle Body Cleaner - Twin Pack: Automotive
__________________
2007 Mustang GT/CS Convertible - AT - Redfire
Bama 91R-V2 Tune - Roush CAI - FRPP GTA Axlebacks - 3.31 Gears
boink is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2014, 05:44 PM   #4
Registered Member
Regular
 
S281's Avatar
 
Join Date: Oct 2011
Region: Canada
Posts: 175
If it's an automatic. Check your fluid level.
S281 is offline   Reply With Quote
Old 09-25-2014, 10:36 AM   #5
Registered Member
Regular
 
Turtlestang39's Avatar
 
Join Date: Feb 2012
Region: Florida
Posts: 73
Yea I will the CRC cleaners and try it this weekend. Hopefully that's the issue.

In regards to the fluid. Is there a way of checking the fluid without refilling it?


Sent from my iPhone using Mustang Evolution
Turtlestang39 is offline   Reply With Quote
Old 09-25-2014, 02:09 PM   #6
Registered Member
Regular
 
Join Date: Mar 2014
Location: New England
Region: Connecticut
Posts: 28
What year? how many miles? have the plugs ever been changed? Any mods, or recent mods? lots of variables here
Kylar is offline   Reply With Quote
Old 09-25-2014, 07:50 PM   #7
Registered Member
Regular
 
Turtlestang39's Avatar
 
Join Date: Feb 2012
Region: Florida
Posts: 73
2006 - 75k miles - I bought it with 40k miles on it and I have never replaced the plugs since I bought it. No mods at all.


Sent from my iPhone using Mustang Evolution
Turtlestang39 is offline   Reply With Quote
Old 09-26-2014, 10:04 AM   #8
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
You're plugs are likely not the culprit then. I agree it sounds like a throttle issue as well.


Sent from my iPhone using Mustang Evolution
Cbird is offline   Reply With Quote
Old 09-29-2014, 07:39 AM   #9
Registered Member
Regular
 
Turtlestang39's Avatar
 
Join Date: Feb 2012
Region: Florida
Posts: 73
Cleaned the throttle and the MAF sensor but the issue didn't go away.

Any other ideas? I'm still hoping is a cheap inexpensive solution.


Sent from my iPhone using Mustang Evolution
Turtlestang39 is offline   Reply With Quote
Old 09-30-2014, 11:45 AM   #10
Registered Member
Regular
 
NADENE05's Avatar
 
Join Date: Aug 2014
Location: Linden
Region: New Jersey
Posts: 30
Does an indicator of a wrench light up on your dash? If so, def check ur throttle body, spark plugs, or air intake. I hope it's a semi-easy fix.
Attached Images
 
NADENE05 is offline   Reply With Quote
Old 09-30-2014, 11:06 PM   #11
Registered Member
Regular
 
Turtlestang39's Avatar
 
Join Date: Feb 2012
Region: Florida
Posts: 73
No there is no indicator. The car runs normal most of the time but sometimes the issue happens.


Sent from my iPhone using Mustang Evolution
Turtlestang39 is offline   Reply With Quote
Old 10-01-2014, 08:19 AM   #12
Registered Member
Regular
 
NADENE05's Avatar
 
Join Date: Aug 2014
Location: Linden
Region: New Jersey
Posts: 30
Take it to you nearest auto part store or your mechanic. Have them run a diognastic through the computer port with a code reader. See what codes come up in order to give some indication of what it could really be.
NADENE05 is offline   Reply With Quote
Old 10-01-2014, 12:19 PM   #13
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
Does it seem like when you put your foot down there is a delay between when your foot hits the floor and when the car downshifts?

I had a 05 v6 years ago that would sometimes hang in overdrive when flooring it for a few seconds before down shifting and opening the throttle. It was annoying to say the least, but could also be dangerous if you were trying to floor it away from a hazard.


Sent from my iPhone using Mustang Evolution
Cbird is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need quick help! Need to find 4.10 gears for 2010 v6 mustang?? Camaro Eater Pre-2005 V6 Mustang 2 06-08-2010 06:31 AM
Guys need help.. going to get new engine.. need advice Skyes97Stang Pre-2005 V6 Mustang 9 11-28-2009 01:35 AM
need some help from the electrically inclined (need to find a power transformer) fast64 The Bar 5 05-26-2006 04:58 PM
Need to choose new tires..need help KyleUSAF Mustang Wheels & Tires 13 11-29-2005 12:13 PM
Need Help with Viruses on my COMPUTER! HELP ASAP!! Autobadges.com The Bar 41 02-05-2004 10:53 PM

» Like Us On Facebook



07:31 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.