Code P0153 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-01-2014, 01:58 PM   #1
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
Code P0153

Got the code a few months ago, deleted it and waited for it to come back and it did. Research shows it's most common with longtubes but I don't have longtubes.

What's my best plan of attack? The code isn't very clear on what the problem really is.

P0153: Oxygen Sensor Circuit Slow Response (Bank2, Sensor1)

The code came on shortly after starting the car and driving away, it didn't come on in the middle of a drive.
Cbird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-01-2014, 04:13 PM   #2
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
Having some trouble getting the driver side oxygen sensor off. Any advice?
Cbird is offline   Reply With Quote
Old 11-01-2014, 04:40 PM   #3
Registered Member
Regular
 
Ross2010's Avatar
 
Join Date: Jul 2014
Location: San Diego
Region: California
Posts: 24
Are you running a tune or recently done any exhaust work?


Sent from my iPhone using Mustang Evolution
Ross2010 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-01-2014, 04:48 PM   #4
Registered Member
Regular
 
jedisaias's Avatar
 
Join Date: Sep 2014
Posts: 54
I got a similar code once I cleaned the TB and problem solved


Sent from my iPhone using Mustang Evolution
jedisaias is offline   Reply With Quote
Old 11-01-2014, 04:51 PM   #5
Registered Member
Regular
 
Ross2010's Avatar
 
Join Date: Jul 2014
Location: San Diego
Region: California
Posts: 24
I ask because I got that same code after installed my shorty headers and high flow cats. All it needed to fix it was to be retuned. I'd hold off on replacing your O2 sensor and see if it's possibly a tune issue, unless your have a lot of miles and are due for new ones.


Sent from my iPhone using Mustang Evolution
Ross2010 is offline   Reply With Quote
Old 11-01-2014, 04:58 PM   #6
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
Umm I did recently install an X pipe but the check engine first came on first before the install.
Could be an exhaust leak I've read.

I was able to change the passenger side 02 but still hung up on the driver side. I bought two different style 02 sensor sockets and everything. What a bad location.. Anyway I'm afraid of running a brand new 02 and one with 85k on the other side ya know?

Ordered a can of throttle body and maf cleaner. Also a new air filter. I'll be doing that.
Cbird is offline   Reply With Quote
Old 11-01-2014, 05:06 PM   #7
Registered Member
Regular
 
jedisaias's Avatar
 
Join Date: Sep 2014
Posts: 54
Yeah I'm sure with a good cleaning and updated tune you can get rid of that code. Good Luck


Sent from my iPhone using Mustang Evolution
jedisaias is offline   Reply With Quote
Old 11-01-2014, 05:57 PM   #8
Registered Member
Regular
 
Cbird's Avatar
 
Join Date: Jun 2014
Location: Des Moines, Iowa
Region: Iowa
Posts: 456
Quote:
Originally Posted by jedisaias View Post
Yeah I'm sure with a good cleaning and updated tune you can get rid of that code. Good Luck


Sent from my iPhone using Mustang Evolution
I sure hope so. Do you think I'm good to run a new oxygen sensor with an old? Not only that but one is NGk and the old one is motorcraft. If not, hopefully it's fine to drive it to the mechanic. I can't get it off to save my life lol.
Cbird is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FORD MUSTANG BRAINIACS what does r-code and/or c-code mean? kele74 Classic Mustangs 4 03-16-2010 06:12 PM
CEL code P1131? candmforever Pre-2005 V6 Mustang 20 09-15-2009 11:47 PM
autozone won't pull my cel code!? candmforever Pre-2005 V6 Mustang 8 12-10-2003 10:19 PM
ECU code FA23...sound right? MUSTANGJUNKY420 Pre-2005 V6 Mustang 6 08-11-2003 05:35 PM
paint code for my car... dark Mustang Audio & Video 1 08-01-2003 04:14 PM

» Like Us On Facebook



11:25 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.