Odd thumping when using vent - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-22-2014, 01:49 PM   #1
Registered User
Newbie
 
Join Date: Nov 2014
Location: Lexington
Region: South Carolina
Posts: 5
Exclamation Odd thumping when using vent

Last week, when I turn on the vent there comes an odd thumping for about 3 seconds.
Vent works fine, but sounds like someone knocking on a door.

This is a 2007 GT... Thoughts anyone?
mustangsc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-22-2014, 01:53 PM   #2
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
It's more than likely your Blend Door Actuator. Known issue on the '05-'09s.

Sent from the Death Star.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 12-22-2014, 02:01 PM   #3
Registered User
Newbie
 
Join Date: Nov 2014
Location: Lexington
Region: South Carolina
Posts: 5
Any chance anyone has worked on this?
mustangsc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-22-2014, 03:02 PM   #4
Registered Member
Regular
 
2014Vert's Avatar
 
Join Date: Sep 2014
Location: Fort Mill
Region: South Carolina
Posts: 145
I have the same problem on my 03 expedition. I pulled the motor on the rear AC and it's been sitting in my house for 2 years now. The front motor is a little iffy these days as well. The gears in the motors are plastic and they break. Only way to fix it, to my knowledge, is to either pay too much for the new motor or scavenge replacement gears out of wrecked cars and replace. Of course none of this is relevant if that isn't the issue.
2014Vert is offline   Reply With Quote
Old 12-23-2014, 12:52 PM   #5
Registered Member
Regular
 
rocknbronco's Avatar
 
Join Date: Jul 2006
Region: Tennessee
Posts: 831
Maybe it's the ghost of Hoffa....
__________________
Mustang wanted for here...
rocknbronco is offline   Reply With Quote
Old 12-23-2014, 03:18 PM   #6
Registered User
Newbie
 
Join Date: Nov 2014
Location: Lexington
Region: South Carolina
Posts: 5
Jimmy isn't here, he left... oh wait I shouldn't mention that.
mustangsc is offline   Reply With Quote
Old 12-23-2014, 03:39 PM   #7
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Quote:
Originally Posted by WhoDat View Post
It's more than likely your Blend Door Actuator. Known issue on the '05-'09s.

Sent from the Death Star.
+1 my old 2011 flex did the same thing, nows the time to change it before it totally goes out. Cheap & easy fix I bought mine on ebay.
Bigshow14 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thumping sound Subtle stang14 2011-2014 Mustang GT 7 06-04-2014 03:01 PM
Thumping Noise PonyBoyV6 1996-2004 Mustang GT 8 04-05-2014 09:28 AM
2000 v6 mustang thumping Xaperez100 Pre-2005 V6 Mustang 7 02-16-2014 01:19 PM
Odd request. Monkey The Bar 7 09-15-2003 10:14 PM

» Like Us On Facebook



03:35 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.