RPM trouble - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-16-2015, 08:22 AM   #1
Registered Member
Regular
 
MORDU1999's Avatar
 
Join Date: Jun 2015
Location: Attica
Region: New York
Posts: 40
RPM trouble

My rpm gauge is off by a thousand. My car runs the same and idles fine but when driving the rpm sound of when I would shift around 3000 is at 2000 which I assume is the gauge and not my engine. When driving in fifth gear the rpm gauge is at 500 rpms and when in neutral needle drops below zero. Never had this problem before. What could it be? Please help.


Solo Dolo
MORDU1999 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2015, 11:23 AM   #2
Registered Member
Regular
 
MORDU1999's Avatar
 
Join Date: Jun 2015
Location: Attica
Region: New York
Posts: 40
Will do. Thank you!


Solo Dolo
MORDU1999 is offline   Reply With Quote
Old 07-28-2015, 11:47 AM   #3
Registered Member
Regular
 
Join Date: Jul 2015
Location: Tampa
Region: Florida
Posts: 55
Are your other gauges working properly ?
Could be a short somewhere ?

I think a common issue with Mustangs is the Stepper Motor, you can see if the desc fits your symptoms.
Stepper Motor Replacement for the S197 Instrument Pack
refluga is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-29-2015, 01:28 PM   #4
Registered Member
Regular
 
MORDU1999's Avatar
 
Join Date: Jun 2015
Location: Attica
Region: New York
Posts: 40
Quote:
Originally Posted by refluga View Post
Are your other gauges working properly ?
Could be a short somewhere ?

I think a common issue with Mustangs is the Stepper Motor, you can see if the desc fits your symptoms.
Stepper Motor Replacement for the S197 Instrument Pack

Actually last week my speedometer needle stopped working altogether until I finally stopped and restarted my car.


Solo Dolo
MORDU1999 is offline   Reply With Quote
Old 07-29-2015, 01:39 PM   #5
Registered Member
Regular
 
MORDU1999's Avatar
 
Join Date: Jun 2015
Location: Attica
Region: New York
Posts: 40
Quote:
Originally Posted by refluga View Post
Are your other gauges working properly ?
Could be a short somewhere ?

I think a common issue with Mustangs is the Stepper Motor, you can see if the desc fits your symptoms.
Stepper Motor Replacement for the S197 Instrument Pack

Actually last week my speedometer needle stopped working altogether until I finally stopped and restarted my car.


Solo Dolo
MORDU1999 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble brewing... redrum The Bar 7 09-08-2004 12:41 AM
what kind of **** did u guys get into trouble for? Smokedya95stang The Bar 32 05-06-2004 06:05 PM
someone's in trouble! tire The Bar 6 03-16-2004 02:27 AM
I'm in MAJOR TROUBLE Rellik The Bar 7 11-06-2003 10:58 PM
More GOP trouble Lickmy The Bar 4 05-09-2003 07:57 AM

» Like Us On Facebook



11:29 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.