Rpm gauge is being weird - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-07-2015, 05:30 PM   #1
Registered Member
Regular
 
jkelt5's Avatar
 
Join Date: Mar 2015
Posts: 107
Rpm gauge is being weird

Any ideas why I'm driving under 0 Rpms lol

Click image for larger version

Name:	ImageUploadedByMustang Evolution1441664996.992533.jpg
Views:	72
Size:	31.2 KB
ID:	190822
jkelt5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-07-2015, 05:31 PM   #2
Registered Member
Regular
 
jkelt5's Avatar
 
Join Date: Mar 2015
Posts: 107
Every other gauge works fine too
jkelt5 is offline   Reply With Quote
Old 09-07-2015, 07:28 PM   #3
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
My temp gauge did that one time and then after a day or so was fine
natestang07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-07-2015, 07:52 PM   #4
Registered Member
Regular
 
jkelt5's Avatar
 
Join Date: Mar 2015
Posts: 107
Quote:
Originally Posted by natestang07 View Post
My temp gauge did that one time and then after a day or so was fine

Yeah it just happened last night so I'm hoping it finds a way to fix itself haha
jkelt5 is offline   Reply With Quote
Old 09-09-2015, 12:06 AM   #5
Registered Member
Regular
 
NutMan68's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 63
Mine did that too !! It came back next day and has not done again so far.


Sent from my iPhone using Mustang Evolution
NutMan68 is offline   Reply With Quote
Old 09-09-2015, 09:58 AM   #6
Registered Member
Regular
 
jkelt5's Avatar
 
Join Date: Mar 2015
Posts: 107
Yeah it's been about 3 days now and it's still sitting there
jkelt5 is offline   Reply With Quote
Old 09-09-2015, 10:01 AM   #7
Kevin.Cook
Guest
 
Posts: n/a
My base cluster on my 2014 did that with the MPH part. I believe the little gears inside it goes bad. I just swapped my cluster with a Premium one (with the proper tool), and now the old one just sits in my closet.

I even tried opening it, readjusting it, but after a day or so, it would fall back below 0.

You COULD take off the glass cover and tape/glue something right under the needle to MAKE it only go as low as 0 MPH. That would fix it in a ghetto way. LOL
  Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird new lower RPM squeel.. jayochs 2011-2014 V6 Mustang 18 09-19-2014 09:48 AM
2nd gear 4,000 RPM (weird sound) mcseb 2011-2014 Mustang GT 105 10-04-2012 02:18 PM
Rpm gauge install!! Help.. 89 Foxloco 1979-1995 Mustang GT 6 03-26-2012 08:20 PM
OMG.. WEIRD.. so weird.. wiarumas The Bar 14 02-17-2005 01:45 PM

» Like Us On Facebook



06:05 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.