Engine hot help! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-11-2015, 08:57 AM   #1
Registered Member
Regular
 
Join Date: Nov 2014
Posts: 112
Engine hot help!

I was driving to work just now and my temp gauge went all the way hot. Engine didn't run different. I pulled over and shut off. It has full oil and antifreeze. What is going on please help. I'm stranded.


Sent from my iPhone using Mustang Evolution
dude0715 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2015, 12:39 PM   #2
Registered Member
Regular
 
ragtopman's Avatar
 
Join Date: Jun 2015
Location: Buffalo
Posts: 185
Engine hot help!

Prob the thermostat and/or water pump? Have u tried driving after it has cooled down a bit?


Sent from my iPhone using Mustang Evolution
ragtopman is offline   Reply With Quote
Old 09-11-2015, 12:49 PM   #3
Registered Member
Regular
 
Join Date: Nov 2014
Posts: 112
Quote:
Originally Posted by ragtopman View Post
Prob the thermostat and/or water pump? Have u tried driving after it has cooled down a bit?


Sent from my iPhone using Mustang Evolution

Yes no issues. So weird


Sent from my iPhone using Mustang Evolution
dude0715 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2015, 12:57 PM   #4
Registered Member
Regular
 
ragtopman's Avatar
 
Join Date: Jun 2015
Location: Buffalo
Posts: 185
So u r saying that u started it again and drove around after it cooled down and no prob?
If that's the case prob the thermostat is sticking, going bad. Should replace soon!
I am not a mechanic so I would c if anyone else chimes in here or have someone check it out...
I have had that happen to me w a couple of other cars I have had over the years..




Sent from my iPhone using Mustang Evolution
ragtopman is offline   Reply With Quote
Old 09-11-2015, 07:46 PM   #5
Registered Member
Regular
 
Join Date: Nov 2014
Posts: 112
Quote:
Originally Posted by ragtopman View Post
So u r saying that u started it again and drove around after it cooled down and no prob?
If that's the case prob the thermostat is sticking, going bad. Should replace soon!
I am not a mechanic so I would c if anyone else chimes in here or have someone check it out...
I have had that happen to me w a couple of other cars I have had over the years..




Sent from my iPhone using Mustang Evolution

Yep that's exactly what happened


Sent from my iPhone using Mustang Evolution
dude0715 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help:Running Hot & Check Engine Light Hellish Horse 1979-1995 Mustang GT 1 08-11-2013 11:22 AM
Hot hot! OutlawGT 2.3 Mustang 7 12-04-2011 11:39 PM
Engine died at low speed. Could not start engine in hot weather Ucla1998 Pre-2005 V6 Mustang 5 08-09-2011 03:15 AM
Engine runs hot for v6 Blackedout Pre-2005 V6 Mustang 2 02-20-2011 07:42 PM
weird engine idle when hot 232SCstang Pre-2005 V6 Mustang 4 03-27-2004 01:08 AM

» Like Us On Facebook



09:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.