New Guy. 05 gt ,warnings lights ??? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-26-2015, 06:47 PM   #1
Registered Member
Regular
 
Join Date: Dec 2015
Location: Bolivia
Region: North Carolina
Posts: 52
New Guy. 05 gt ,warnings lights ???

I just got my wife an 2005 GT Convertible auto trans. It runs good has 91-k miles. The other day after a hard rain here in NC. She was driving it and was doing fine then all of a sudden the Low oil pressure warning started displaying and the oil pressure gauge was showing "0". Then same time the Low Traction warning was on then the Low Brake Fluid chimed in, then Low Coolant, then Check Engine came on. The car is running fine the tach and speedometer is working, the oil is pumping no knocking or any thing.. I cut it off let it sit for a few minutes then started it back up first few minutes was fine and all normal then it started again with low oil pressure low brake fluid low traction and the car was sitting parked at idle. the traction control on the dash is showing to be off as well. Any Ideas?? Besides a gauge cluster issue??? Should i try and scan the check engine code?
1970Ronnie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-26-2015, 08:08 PM   #2
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Yeah go ahead and scan. These things are known for cluster issues. Mine does weird stuff but nothing like that.

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Old 12-27-2015, 06:03 AM   #3
Registered Member
Regular
 
Join Date: Dec 2015
Location: Bolivia
Region: North Carolina
Posts: 52
thanks, will try that.
1970Ronnie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2015, 08:03 AM   #4
Registered Member
Regular
 
Join Date: Dec 2015
Location: Bolivia
Region: North Carolina
Posts: 52
Codes are

Quote:
Originally Posted by 1970Ronnie View Post
I just got my wife an 2005 GT Convertible auto trans. It runs good has 91-k miles. The other day after a hard rain here in NC. She was driving it and was doing fine then all of a sudden the Low oil pressure warning started displaying and the oil pressure gauge was showing "0". Then same time the Low Traction warning was on then the Low Brake Fluid chimed in, then Low Coolant, then Check Engine came on. The car is running fine the tach and speedometer is working, the oil is pumping no knocking or any thing.. I cut it off let it sit for a few minutes then started it back up first few minutes was fine and all normal then it started again with low oil pressure low brake fluid low traction and the car was sitting parked at idle. the traction control on the dash is showing to be off as well. Any Ideas?? Besides a gauge cluster issue??? Should i try and scan the check engine code?
The codes on the scanner were #P0463= "Fuel level Sensor A circuit high". And #P2068= "Fuel level sensor B circuit high".
Now this morning the oil pressure guage was reading fine and none of the warning chimes or displaying was on the info center "Normal" like it should be. I used the SCT to clear the codes and it seems to be fine. Now it has been sitting since Thursday afternoon any clue as to why it did this, recon it was from getting something wet and it needed to dry out? I have read somewhere on the inter web that if you splash mud and water on the back end it will screw up the sensors and read false codes is this happened to anyone here??? Thanks for any feedback or help you can offer.
1970Ronnie is offline   Reply With Quote
Old 12-27-2015, 11:47 AM   #5
Registered Member
Regular
 
wingntt17's Avatar
 
Join Date: Jan 2015
Posts: 58
Sometimes it could be a bad ground?


Sent from my iPhone using Mustang Evolution
wingntt17 is offline   Reply With Quote
Old 12-27-2015, 11:49 AM   #6
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Where you driving through rain? Could have gotten something wet that shouldn't be wet.

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Old 12-27-2015, 02:03 PM   #7
Registered Member
Regular
 
ragtopman's Avatar
 
Join Date: Jun 2015
Location: Buffalo
Posts: 185
Check the cabin air filter as they are prone to leak in that area if not kept clean. There is also a rubber drain gasket that is prone to clog right below that. There are TSB's out about this problem. Don't drive in the rain again until u fix it. It is an easy fix though...


Sent from my iPhone using Mustang Evolution
ragtopman is offline   Reply With Quote
Old 12-27-2015, 02:53 PM   #8
RBK
Registered Member
Regular
 
Join Date: May 2015
Location: Chapel Hill
Region: North Carolina
Posts: 105
My 2012 sat out in that same rain you are talking about and when I was driving down the street the ABS and Traction Control went crazy. Warning lights came on the ABS started to activate even though I was not applying the brakes. I pretty much tore the front end apart looking for bad suspension or anything that could have caused it but found nothing. It has been fine ever since. I figure something just got wet.
RBK is offline   Reply With Quote
Old 12-27-2015, 09:54 PM   #9
Registered Member
Regular
 
Join Date: Dec 2015
Location: Bolivia
Region: North Carolina
Posts: 52
will do thanks.
1970Ronnie is offline   Reply With Quote
Old 12-28-2015, 06:40 AM   #10
Registered Member
Regular
 
Join Date: Dec 2015
Location: Bolivia
Region: North Carolina
Posts: 52
would the bad ground be in the front end or rear you think?
1970Ronnie is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2005-2010 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash warnings! blackstang1 2011-2014 V6 Mustang 10 01-11-2015 11:25 AM
Stop Lights vs. Red Lights bbunt302 The Bar 25 12-11-2005 02:49 PM
Guage lights and ac panel lights steedav6builder Mustang Audio & Video 15 03-11-2005 04:10 PM
FOR SALE: tail lights, head lights, clear corners, tail light covers, dvd, xbox games Zim Mustang Parts for Sale and Wanted 15 12-13-2004 01:45 PM

» Like Us On Facebook



07:56 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.